[Solved] Easy Installer not working on GalaxyS9 - libusb error: -12


appreciate any help or advice anyone might be able to give. I am trying to install e on a refurbished samsung Galaxy S9 SM-G960F via the easy installer and I’m having some trouble. Basically I follow all the instructions,I have “OEM unlocking” activated, and yet somehow at the end of the process I just boot right back into regular andoid. The first thing I notice is that at the download stage the screen on the phone never tells me the download is completed. it just keeps saying “downloading” . I don’t know whether this is a problem or not, but on the PC end everything looks fine.

I follow the instructions as it says, to hold power+bixby+volume down , then once the phone turns off hold power+bixby+volume up. at the this stage, I believe the phone is supposed to boot into e recovery, at least that is what is says on the installer, however I am instead brought to android recovery, here there are similar options to what are available on e recovery though. it instructs that I select I wipe the data, and then select “apply update from adb” which I am able to select even though this isnt e recovery. next this happens:

finally, I select reboot as insturcted and I am simply brought back to factory default setting for my phone. There is no e logo like the installer says there should be, just a long wait while the phone shows the samsung logo before starting.

I apologize if there’s something very simple here I’m not getting, I have some experience with bootloaders and linux in the past but nothing like this involving phones. appreciate any advice anyone might have

some more pictures, here is what i mean when I say the phone never tells me the download is completed

while the above “downloading” is shown on the screen, this message appears on the computer, which I allow to run

It is a case of critical timing, better worded as

  • hold power+bixby+volume down,
  • the instant the screen goes black,
  • quickly move your fingers to power+bixby+volume up
  • in order to boot into the newly flashed recovery.

That is just what always happens; “Downloading” and the arrow are static and offer no signals to the user.

wdi-simple.exe provisions a Windows driver if / when required.

More context within Your first boot into TWRP and other parts of the same topic.

Good luck

thanks so much, I am pretty sure I have done just that, as soon as the screen goes black I move my finger. I’ve tried several times now and I always go to android recovery instead of e recovery.

I tried again and I really dont think the issue is the buttons. I did notice however that right before the android recovery starts up instead of e recovery, a very brief picture of the android robot logo appears with an exclamation point in a warning sign superimposed over it. there’s some text but it disappears too quickly for me to read anything

I believe the observation of the “robot action” is the wipe the Custom recovery and deployment of the backup Android recovery.

Maybe you should not wait for the screen to be black (that may be too late) but anticipate it – some models display a very pale line of miniature text which gives an advance indication – or count the seconds and move your fingers in advance of power off.

If that still fails dig out the Easy Installer log, Howto troubleshoot issues with the easy-installer to see what is happening.

Here is my Easy Installer log, appreciate any help anyone can provide.


on my last attempt I believe I perfectly timed moving my finger from volume down to volume up, and the problem still persists. I tried moving my finger even before the screen goes black, but it doesn’t seem to help.

I am using a windows 10 laptop and currently the phone is running android 10 if that info helps

Among other things in your log:-

Failed to detect compatible download-mode device.
libusb error: -12

Libusb errors can derive anywhere is the usb chain from PC motherboard to device.

Without doing a fuller analysis, try a different cable (a cable can transmit data and perform parts of the install but fail to communicate with Download mode – it has been reported that an original Samsung cable behaves this way !).

Some USB hubs should be avoided, sometimes a mix of different USB ports might be provided through such an internal hub. Try to use the USB port actually soldered to the motherboard.

I don’t use Windows, uncertain, but it would seem slightly odd if you saw wdi-simple.exe (which is a specific Windows / Samsung driver) https://doc.e.foundation/pages/install_easy_installer/win_samsung_phones repeatedly on each install attempt ??

You could open a Device manager window alongside Easy Installer and see if the phone presents as a
" :warning: Problem device "
at any time during the install, particularly in Download mode, as this seems the issue.

There are reports that certain PC / laptop “just won’t work”.

Thank you so much! after trying 3 different cables, one actually worked and I got it installed. Really strange that the one I had did not work because Easy Installer was still able to detect the model of the phone and said it was compatible.

Thanks again so much

Indeed reading the log the cable is carrying adb traffic fine – just not with Heimdall.

I hope you have a great onward journey with /e/ !

This topic was automatically closed after 6 days. New replies are no longer allowed.