[SOLVED] I completely bricked my brand new OnePlus 6T phone

Hello everyone, i installed /e/ on my brand new OP6T but it was not working properly (my phone was powering off after 10s unplugged and as the issue was opened 5 months ago i thought it would be a good thing to go back to stock rom.

I tried to restore my backup but it failed miserably.

Anyone could help me installing /e/ properly or at least go back to stock rom ?

All i can do now is accessing to fastboot but my mac don’t seems to see the device when i type “adb devices” …

Thank you.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

With the phone in fastboot mode you would use fastboot devices, adb doesn’t work in fastboot mode.

1 Like

Yes i got my phone here with its id showing up.

I then tried to flash TWRP to reinstall a stock rom using fastboot flash boot <recovery_filename>.img but when i reboot with fastboot reboot recovery it gets me straight to fastboot mode.

Here is what happen when i try to boot the image from fastboot

    fastboot boot twrp-3.2.3-2-fajita.img
Sending 'boot.img' (30288 KB)                      OKAY [  0.694s]
Booting                                            FAILED (remote: 'Failed to load/authenticate boot image: Load Error')
fastboot: error: Command failed

First, I suggest that you use the latest TWRP release (3.3.1-1) for your device.
Also, if I’m not wrong, when in fastboot mode you should be able to select “Reboot to recovery” by pressing the volume-down key and confirming by pressing the power button.

I tried rebooting manually to recovery using the phone but it keeps going in fastboot mode (just tried again with 3.3.1-1).

fastboot flash boot twrp-3.3.1-1-fajita.img
Sending 'boot_a' (31136 KB)                        OKAY [  0.730s]
Writing 'boot_a'                                   OKAY [  0.203s]
Finished. Total time: 0.942s

Just to be sure: are you following the instructions on the official TWRP page?
You should have put a .zip file inside your phone’s memory ( twrp-installer-3.3.1-1-fajita.zip )

Just to be sure: are you following the instructions on the official TWRP page?
You should have put a .zip file inside your phone’s memory ( twrp-installer-3.3.1-1-fajita.zip )

Ok i was following these intructions :


It seems that i might have f****d up the partitions …

How can i put the .zip file without adb ?

I’m sorry, but I have no idea :disappointed_relieved:

I’m currently trying to use this topic to restore every partitions :

Stay tuned o/

I can now boot TWRP using

fastboot boot twrp-3.3.1-1-fajita.img

but it’s stuck on boot.

Ok i just followed the steps in the thread up here except the ‘all criticals partitions’ part and voilà, my phone is now booting.

I hope i did not break anything vital.

1 Like


Last monday, i bricked my Oneplus 6T.
You can see my isse and my solution here :slight_smile:

Good luck,



I know nothing about Mac’s but know Linux which is similar and I was in your position with a Samsung Galaxy SIII Sunday. If your phone takes an SD card and you have access to a Windows computer, then put the card in the computer, open it and copy and paste the TWRP file to the card. Put the card in the phone and you should be able to open it as it installs to root. Install TWRP.
I hope this works, then look then for further instructions.

hey, can you help me get through this too ? i am stuck in fastboot mode. not able to flash twrp img it throws me an error (FAILED (remote: Failed to load/authenticate boot image: Load Error)) what to do ? i restarted my phone into recovery without any os installed and now i am stuck to this

Hi @DP6T welcome to the /e/ forum.

Please can I clarify a few things. You have this exact device https://doc.e.foundation/devices/fajita, and following https://doc.e.foundation/devices/fajita/install

You observed

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

Did you check your version of platform tools

Tip: Outdated fastboot releases dropped legacy A/B support, so it might attempt to flash to boot__a / boot__b rather than boot_a / boot_b if you try to flash boot. In this case, you must update fastboot to a release newer than or equal to 31.0.2. Alternatively, you can manually specify which slot to flash to based on what slot fastboot failed to flash to. For example, if fastboot fails to flash to boot__a, you must flash to boot_a.

fastboot --version

So you have no system … you find you have access to fastboot … you “restarted my phone into recovery” … do you have access to the manufacturer Recovery? Are you able to switch at will between fastboot and Recovery?

hey @aibd , I tried flashing fastboot stock rom but it wasnt working at that time , it said on many commands which ran that they failed or some things. But when i returned home in the evening i find my phone booting to osygen os by itself ! i guess I manually ran all the flash files which can be ran in my case ( which was 2/5 files , excluding flash-all bat) , now doing clean flash to project elixir.