Sony Xperia XA2 -- no sound after update

Hi all, I updated my Sony Xperia XA2 H3113 to the latest /e/-version (0.7-o-2020032847188-dev-pioneer) yesterday. Since the update, my phone does not play any sounds anymore.

So far I tried

  • setting a timer
  • setting an alarm
  • playing music (with two different players)
  • incoming messages (just vibrates, no sound)
  • receiving a call (no ringtone)

Also, after taking a call, neither me nor the other person can hear anything, so apparently the mic also doesn’t work anymore. After hanging up, the phone rebooted.

Everything worked perfectly fine with the earlier version (0.7-o-2020012438713-dev-pioneer, I think). Does somebody have an idea how to fix this?

Alternatively, is there a way to downgrade to an earlier version (without loosing all settings)?


Hi, welcome in the forum !

If I remember well, one day I have downgraded because an update broke something and there was no data loss. But I guess it depends what the update changes.
Make a backup and try, I guess you don’t want to wait for a fix.
Alternatively, you could also try to re flash the same update.

You can also report the issue by following some HOWTOs.

Thanks for your answer! Did you downgrade via TWRP or is there an easier way?

I downloaded the firmware ( and I flashed it with TWRP. No easy “downgrade” button.

Thanks. I flashed 0.7-o-2020012438713-dev-pioneer via TWRP & adb sideload, but it didn’t boot. After trying a bunch of different things (different TWRP versions, different /e/-versions, switching between the two slots of the phone…) I eventually managed to boot into /e/ again after sideloading the newest version. All settings were preserved. Interestingly, now everything works fine again.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.