Sony - Z5 Compact - suzuran - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

Hello Manoj,
as mentioned here, the link to the suzuran-build only leads to a 403 Forbidden page. Could you please fix the link? Thank you!
…not exactly a documentation suggestion, only kind of. I hope it’s okay I mention it here.

Sorry about that. The link should be fixed now. Please try again

This ROM is based on the unofficial Lineage 17.1 ROM made by Bernhard Thoben (Professor-Berni on github)

I think that the Install /e/ on suzuran documentation page should acknowledge this in some way. As the person who has taken his work and built on it to make this official /e/ ROM, I am slightly uncomfortable that he is given no credit.

(Edit: corrected XDA link above)

The way in which we acknowledge the original source for each device is by mentioning it in the device tree information …for e.g for suzuran if you scroll down to the device tree info you will find the path of the Github folder from where we have accessed the source files.
This is displayed for all devices.

That just says Device Tree: android_device_sony_suzuran. It doesn’t even mention that that is a repo in, That git repo does reference the original github repo but I wouldn’t expect many /e/ users to find it. I really don’t think that is giving the necessary public credit.

My point is that devices based on unofficial Lineage OS ROMs should be handled slightly differently from those based on official LOS ROMs. Other parts of the /e/ documentation acknowledge the work of LineageOS: there needs to be a way of acknowledging the work of the developers outside the LineageOS project who put together any unofficial ROMs that /e/ uses

Concerning the recovery image: I get confused by the install documentation. There is a recovery image in the build section, a non-functioning link to TWRP (and of course TWRP builds for suzuran do exist when searching for them via search engine or in forums) as well as a link to a custom recovery which seems to be different from the one in the build section. Please clarify which one to use in the documentation.

I can’t update the documentation - I’ll leave that to @Manoj - but I’ll post what I know

You can use TWRP either


  • TWRP 3.5.0 Linked from here

I don’t know anything about the /e/ Custom Recovery images, except that they have been appearing with recent builds. I have noticed that recent LIneageOS builds (for many / all devices) also have their own custom recovery images.

I’ll continue to use a version of TWRP (see above) that I know works for /e/ and other custom ROMs

Many thanks @petefoth for your work maintaining the “dev” version of “e” for the Xperia devices. I researched small phones among the devices list available here, and was pleased to discover the Z5 Compact which I thought would be a better replacement for a Samsung A3.
I had installed “e” on the A3 for my partner who hates big modern ones but after an unlucky fall the screen was completely unusable, hence my search for a new e-device.
Following the e-install guide and the Sony help pages I was able to get as far as unlocking the Z5 bootloader, but made the mistake of manually restarting instead of waiting for the long Sony splash screen finish the reboot. The end result was a return to a factory install I suppose as all the text was in ideograms - Japanese I suppose. Not finding a way of changing the language setting I had to navigate through the “getting started” sequence to eventually by trial and error find the developer section to enable USB debugging.
As the last step 6 of “unlocking the bootloader” in the official guide is very succinct on this matter, I found that @mike_from_ireland had written an excellent, very detailed beginner’s guide to install /e/ where he warns about the delayed reboot.

Unfortunately his guide is in the Documentation Suggestions for the Z3 Compact - not quite sure why - but I hope that @Manoj will be able to redirect it here. In fact, I suggest putting a link in the official guide that would point Linux users to this far more detailed set of instructions as @mike_from_ireland explains all the necessary preparatory steps using a Ubuntu distro: a fine job worth a big clap :clap:

So far my partner is very pleased with the Z5 and I was surprised to see how long the battery lasts, having read elsewhere that battery drain had been a problem in the past. As the Z5 has an octa-core Snapdragon CPU it seems a lot “snappier” than the Samsung A3, both phones being about 6 years old now. But the Z5 seems a lot better made.


Thanks for pointing this guide out. Will have it linked on the official install page

Hi! I have a Xperia phone, and got stuck in the same boot loop.
I tried the wipe in TWPR but it does not help unfortunately. Is there any other fix somebody knows about?

Hi @Troken welcome to the /e/ forum.

Of course there could be any reason for this.

Depends too if you are used to flashing ROMs.

Think of it as a bootloop can be caused when you have Recovery, but you don’t have a stable or bootable system.

If it was as simple as this, all you would have to do is pick up your instructions at the point you install the /e/ system with TWRP.

If not this simple – what else is wrong?

In your reply please link your phone’s devicecode, and or the instructions you are following.

Hi! Thank you for the understanding reply.

It is a Sony Xperia Z5 compact.
I successfully installed /e/ on it a while ago. It was quite complicated, but somehow I managed. So it has TWRP and all.

Recently I got the notification about /e/os 1.0, so I clicked on it and it started downloading and installing. But after a reboot it got stuck in this boot loop.

I have now downloaded the latest file (ZIP) on my device, via a computer. Can I use TWRP to install it fresh? I dont mind everything being wiped, it’s an experimental old phone to test /e/os on.

First I do not know the device. It is unfortunate that you have added to a Samsung thread. Our Sony experts may not look here!

@Manoj please might you be able to split this into a new topic, if that seems sensible to you, thanks.

So your install instrictions Install /e/ on a Sony Xperia Z5 Compact - “suzuran”
show the way to go now with adb sideload.

Are you able to pick up from there, or can you describe your difficulties?

Edit. Wiping data as instructions is going to be important.

Hi Aibd,

I have had some trouble, but I’m not a power user, just a simple dude trying to follow instructions.

Anyway, I hade to start over. When following the instructions I could not use the recovery image supplied here:
It lead to problems.

Instead, I found a Suzuran-version of TWRP on another page, fastbooted it, and hence I could install the Q-version of /E/OS. Following the instructions and wiping. After that, I tried the Android R (beta) and it worked. So I have a fresh install workning now.

The instructions are good, but I must have misunderstood something with the recovery. I think that part made me fail with the installation.

Yes. The instructions should point to a TWRP recovery image rather than /e/ recovery (which has never been tested with this device)

1 Like

The Custom recovery link on the installation page for suzuran at now links to a non-existent page at

The correct recovery image to use is at (It’s not ideal that it’s a Google Drive, link, but that’s where the developer makes his files available

@Manoj please can you update the link? Thanks

See also this issue about the broken images on the download page

Since we do not have a maintainer for the suzuran following the link as on the LineageOS wiki has been updated.

The image you linked to is not correct snd s unlikely to work for builddmore recen thsn Nougat. We needthe rdcovery usedby the upstream unofficial ROM.

Thelink I gave is to the recommended latest version

Have you tested the recovery on Google Drive?