Stephen Hawking Navigation Voice

The standard maps app on E/OS is sending me in all directions but the right one so I was looking for an alternative. Found eg Sygis or Navmii, Polaris, Here wego, Maps factor ect but they all have the same problem, the voice sounds like Stephen Hawking. The standard Maps does not have that problem. The only one I found with a normal voice was Google maps but I rather not use that.
Any suggestion what the voice problem on a lot of those apps might be?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Those apps probably all use the system default text-to-speech engine, which is eSpeak.
It really does not sound well, but you can replace it.
I downloaded RHVoice from F-Droid and changed the default tts-engine in the system settings.

1 Like

… and there is this method, Alternative to eSpeak? - #14 by pmoody

Edit, 6 days later, I had hoped that this link would add to the good answer provided by @ljahn !

The RHVoice app is the simpler solution, it can be tested quite readily, and a user can decide if it is the most suitable solution.

1 Like

The strange thing is with Maps and Google maps the voice sounds normal. It is just with the other apps this metallic robot voice appears.

1 Like

Thank you very much Ijahn, which navigation app do you use?

No idea about Google maps, but Maps includes the option in Maps > Settings > General > Sound > Voice Language > to set the voice and also to download alternatives.

One can check there which “voice” is used. Text-to-Speech is seen as an option on my device – I think a different voice arrived as default.

As said by @ljahn “text-to-speech engine, which is eSpeak” so @pmoody’s method offers to harmonise text-to-speech throughout the device.

Edit as does @ljahn’s recommended app of course.

Thank you aibd The voice in Maps is totally fine but the app itself is not working because it sends me in the wrong directions. That’s why I tried to find an alternative for it. But all alternatives have the voice problem. I will see if I can work out @pmoody method, sounds complicated.

I use OsmAnd~, but I cannot fully recommend it.
While it is very powerful, configurable and extensible in all directions via Plugins, it is also very complicated. The UI is clean, but complicated and there are so many settings and things that you can change by accident and then not find again for 10 minutes :wink:.
Navigation, offline maps and the truly needed features work fine though :+1:


Haha no we don’t want that, looking for ages to get the right settings back.
I will give it a try and see of the voice is okay.

Just installed OsmAnd but has the same voice problems. Will I still be in privacy mode using google maps? Seems like I have no other option apart form trying the @pmoody solution

If the subject is “robotic voice” I think the thing is this: which voice is any app using?

You should be able to find this within the app’s own settings.

If you use an app which relies on

then either @ljahn’s recommended app or the @pmoody method will aim to change that.

Thank you aibd.
@ljahn App has the same problem. There is one question from another user on this forum describing exactly the same problem.

The default voice engine used in E/OS works well with Maps or google maps. So it has nothing to do with the setting in the apps I guess or can it still?

BTW I tried google maps and it showed me I am logged in to google. Is this normal behavior? Am I protected through micro G? I can’t recall logging into google in google maps. Only installed Fairmail which asked for connection to me Gmail account.

Hi @eosfan I get what you are saying, but we are still going round in circles! :slight_smile:

So in my case Maps did not use eSpeak!

You could check that to see what applies …

My expectation would be that Google will deploy its own technology to provide a voice service, but I have zero desire to test any Google service.

Ha ha yes going in circles… almost the same what happens with Maps
I thought I did not express myself clear enough. I will check what service Maps is using.
Found a workaround with OsmAnd by downloading the voice text file.
Works fine but OsmAnd is indeed a little hard to operate. Even trying to exit the route was hard to find.

I think navigation apps (Maps, OsmAnd) use massive speech technologies… so must have their own voices and words and so on. Other apps use the system voice instead, that means eSpeak.

1 Like

Thank you jobal, learning step by step.

1 Like

Sorry for the late reply.
As I said in my first resonse to your question, the problem is not about the navigation app, but the system default text-to-speech engine. Google maps (and apparently also /e/ Maps) ships some own engine and doesn’t care about your system settings, but all the other apps just use the default.

So if you want to get rid of the bad voice output, you do not need to replace the maps app, but the text-to-speech engine.

1 Like

Thank you Ljahn for explaining again. I understand my best chance is using the @pmoody option?
Have a good weekend!