Stuck in download mode after installing TWRP

I tried to migrate from an Android 12 stock-ROM to /e/ OS 1.5 Android S. But I didn’t succeed because I got a problem after installing TWRP. I’m stuck in the device download mode and a little bit helpless.

My device:
Samsung Galaxy S10+ (Exynos) SM-G975F beyond2lte (not branded)

How I prepared my device:

  • Activated developer options
  • Enabled OEM Unlock option and USB-Debugging
  • Unlocked the bootloader

How I prepared my computer (Windows 10):

  • Downloaded and installed ODIN 3.14.4
  • Downloaded and installed Samsung USB Drivers
  • Downloaded TWRP image twrp-3.7.0_9-1-beyond2lte.img.tar (from

I entered download mode of my device and connected it with my PC
Odin confirmed with “Added!!”
I choosed “AP” and the TWRP-image
The only options marked were “Auto Reboot” and “F. Reset Time”
I started Odin and it confirmed installation with a green “PASS”.

And now the device is only booting in download mode showing this error:
recovery: Error validating footer (8)
recovery: Error verifying vbmeta image: invalid vbmeta header (6)

Did I choose the wrong TWRP-image?
The instructions told me to install the img.tar-file. Not the img-file.

Has anyone some suggestions what to do?

Thanks a lot

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

According to the official TWRP install documentation : Samsung Galaxy S10+ (Exynos)

Don’t forget to flash the provided custom vbmeta.img.tar (in CP) along twrp.img.tar (in AP)

See the maintainer instructions In for this device.

Thanks Piero. Flashing vbmeta.img.tar together with twrp.img.tar worked.
TWRP was properly installed.

With TWRP I then installed the /e/ OS image
… and ended up in the next bootloop. The device only boots into the Samsung boot screen.
Recovery (Volume up + Bixby + Power) doesn’t work. Only download mode.

I will retry everything according to the TWRP install documentation and the maintainer instructions you mentioned.

You might go back on the instructions page, Install /e/OS on a Samsung Galaxy S10+ - “beyond2lte”, to Pre-Install Instructions and double check the exact workflow. This generation of Samsung (on which I do not have first hand experience) seems to have caught out some users with the more securely locked bootloader !

A brief mention is here Know your hardware Samsung #Recent generation

Using TWRP, you need to format /data, reboot to recovery again to wipe the other needed partitions, before installing /e/OS

[HOWTO] an Unified Install Guide Project for /e/

Have you tried using the recovery-e instead of TWRP ?

After several weeks with endless research and testing I succeeded.
My Galaxy S10+ is now on /e/OS 1.6 S !
The /e/OS community was very very helpful :blush:

My fault was to first update my device to the latest stock ROM-version.
So the solution was to downgrade:

  • At I got the Spanish firmware AMO G975FXXSGHVI4 from September 2022
  • I flashed it with Odin 3.14.4
  • After reboot I activated developer options, USB debugging, OEM unlock
  • Then Odin again: I installed twrp-3.7.0_9-0-beyond2lte.img.tar (in AP) and vbmeta.img.tar (in CP)
  • And then followed this brilliant Howto at step 8)
  • After reboot finally the dancing “e” …

Many thanks to everybody