Stuck in the early stage of installing e/OS on Galaxy S7 with easy-installer

I’m kind of new here and this is my first attempt at installing e/OS on a phone.
I’m sorry if this has already been addressed, but I haven’t found the conversation. If it has, please, can you guide me to right thread?

I have a Galaxy S7 phone and it looks like it is among the devices that are compatible with e/OS and the easy installer.

I’m in the process of trying to install e/OS on my Samsung S7, but I’m stuck in the early stages, more specifically, in the “Enable USB File transfer”.

My phone doesn’t have a “default USB configuration”, just "USB configuration. And it doesn’t have the option “Transferring file”. It has different options, but not this one, as shown in the picture below.

The first time, I selected MTP (Media Transfer protocol), but it didn’t work at all. The process generated error messages after it started downloading the OS.

So, I have no idea what to do. Should I select another option? But which one? Or does that mean that my phone isn’t compatible with easy-installer, despite the fact that it is a Galaxy S7? I’m really at loss here.

I’m using easy-installer on my Ubuntu 21.10 computer.

Hello Chibi.
I am trying to install e/OS/ also fist time to an S7. Following the instructions of the easy-installer I get up until searching for the driver and the deviceID can not be found. I am trying to get the driver manually without success anymore. I am using a Win10 PC
Have you done the installation?
Can you give me support?


Try another cable

Hello Piero.
Now I tried some cables witch are OK to connect it to PC and have access to the smartphones memory. Nothing changed. What can be not OK with the cable?
The easy installer shows endless the screen „searching for your device. …“ and there is no cancel or break button.

In addition to trying a different cable, try to ensure you are using the USB port soldered to your motherboard (some PC might have a slightly complex hub within the PC feeding other USB ports).

Can you find the log see advice here Howto troubleshoot issues with the easy-installer.

You are using a supported model ?

Models Supported General.
Other models are not supported

However in only SM-G930F is listed.

You are not facing the difficulty of the OP in the stage ?

Meanwhile there have been difficulties with Easy Installer recently. Please tell us the version of Easy Installer as shown in the top of the Easy Installer window.

1 Like

Well, I haven’t tried again since I posted my question, 2 years ago. So, I don’t know about the motherboard.
As for the phone, it is a SM-G930F, which is listed as being compatible.
I’ll try again under someone’s supervision, to make sure I haven’t forgotten something.

The very early “screens” of Easy Installer deal with setting up the phone ready for install of /e/OS.

These screens may deal with unfamiliar subjects. I would suggest at the next run you allow time to run the first few screens slowly.

As you come to unfamiliar items perhaps compare with what is written in the early sections of the Command line install page This way you can reassure yourself that you are on the right path.

So one would need sight of those error messages to know if it was related to MTP or, more likely, something different.

The download is not expected to start until Easy Installer has made contact with the device and identified it as supported.

Know your hardware - Samsung

1 Like

The smartphone is S7 model SM-G930F
I began with installing V0.19 without success. Now 3 weeks ago I downloaded V0.20.1 and it worked fine. It might be a problem with V0.19
Thank you very much for the support

I’m going to have another try in the coming weeks, but I’ll have someone more experienced supervise me. This way, I might be able to go through the whole process. I haven’t given up, but for the last two years, I’ve been up to my ears in a lot of health and financial problems and couldn’t muster the courage to go over this again.