Stuck on Installation to S9+


For the past couple of days I have been trying to do my own install of eOS on a brand new Samsung Galaxy S9+ SM-G965F/DS that I purchased on eBay.


I am working on a Windows 10 PC.
I am stuck on Building Heimdall step 4 for Windows.
When I enter the “cmake -G” line into MSYS2 MinGW 64-bit, it gives me the following:

CMake Error: The source directory “C:/msys64/home/folder” does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

I have tried moving the “Heimdall-master” folder into the msys64 folder, as well as the …msys64/home/folder to no success (still gives the same error).

I had considered moving the “CMakeLists.txt” file from the Heimdall-master folder into the msys64 directory directly, but I noticed that there are multiple CMakeLists.txt files, and I have no idea which one should be used, if at all. I can’t move them all because they have identical file names.

Should I simply create a blank .txt file called CMakeLists using Notepad in the msys64 directory?

Additionally, I had to update the phone to Android 10 in order to access the OEM Unlock feature. Will this cause any issues?

Any help would be greatly appreciated!

Thank you!

Hi @crumm welcome to the /e/ community.

The install instructions which I guess you are reading mention Heimdall, which is really a Linux product. Windows users have the (possibly) more easy Odin3.

I would suggest you try this howto: [HOWTO] Install /e/ on a Samsung smartphone with Windows easily

I had to update the phone to Android 10

No problem, you will have seen this caution

Caution: Before following these instructions please ensure that the device is on the latest Android Stock firmware. This can be done by checking for any OTA updates available in the Updater. If available run them before installing /e/OS

The important thing is that you install /e/ in the same version, Q, (as linked in the install instructions already mentioned).

Thank you for the response!

I did try that [HOWTO], but when I attempted to install TWRP, it kept failing and the phone, in Download Mode, would display a massage saying “Only use official batch files” (or something to that effect, I cannot remember exactly). So I gave up on that method and went back to the original (now understood to be Linux) version of the install instructions.

I was also going to install the Oreo (stable) version on this particular phone. Is that not advisable?

Definitely a bad idea, if doing it by hand. :slight_smile:

Regarding the difficulty booting into TWRP - it is all timing! - try the First boot into TWRP paragraph here.

10-4! I will give it a go! Thank you so much! I will repost here if I have any other issues, if you don’t mind?

So, I understand that it can be difficult. I have tried booting into TWRP several times now and I keep getting the screen in the picture. Any ideas?

Additionally, in the “Log” of Odin3, I get these entries:

ID:0/003 RQT_CLOSE !!
ID:0/003 Complete(Write) operation failed.
OSM All threads completed. (succeed 0 / failed 1)
ID:0/003 Removed!!

I wonder if the original Samsung firmware is still intact or whether one of your attempts along the way was part successful?

Your photo shows the Samsung Android recovery. Does reboot into System give a working phone?

Can you reboot into Odin mode, Download mode, the very small text there may reveal any unexpected stoppers, like the possibility of a Regional lock, what country are you in?

A photo of the Download mode screen would help confirm. :slight_smile:

I am in California, USA.

(Sorry the glare/unclear photo. Did the best I could with my webcam.)

In Android Recovery mode, these are the options that it gives me. I have not tried anything other than “Reboot system now” which boots into stock Android 10 normally, and “Power off” which just reboots into Android Recovery.

Reboot system now
Reboot to bootloader
Apply update from ADB
Apply update from SD card
Wipe data/factory reset
Wipe cache partition
Mount /system
View recovery logs
Run graphics test
Run locale test
Power off
Repair apps

So I see RMM STATE : Prenormal. This is most likely the result of your phone being imported to USA, but having previously been intended for another market.

Loosely speaking Samsung required the phone to be used in its intended market, in which case Prenormal would have resolved harmlessly.

This Search will provide more information.

Depending or what you decide to do next, Edit, Warranty Void = 0, is saying that nobody “messed with the phone” also confirmed by CURRENT BINARY : Samsung Official (might influence what you decide to do next!) :slight_smile:

Could a combination firmware help ?

Do you mind elaborating on this? I have some programming/hardware knowledge, but I’m not sure what combination firmware is, or how to achieve it.

Not sure if it will help for resetting RRM state prenormal…
But useful to reset some others security by forcing to downdate or downgrade

If you are in the USA, better is to choose another brand,
Search the forum with “device USA” or “USA device”