Stuck on Teamwin Logo

I guess your best bet is to flash the stock ROM then. There are many guides how to do this, this is one of them: https://www.techora.net/flash-samsung-galaxy-s7-using-odin-tool-computer.html

This should recover all partitions.

After flashing stock, you can try flashing /e/ again.

1 Like

Ludix,
I tried it, two different versions of ROM. It did not work.
It irritates me, other guys have managed to get it to work, I must have been the most unlucky person in the history of /e/, in every step along the way there were problems.
Perhaps now I have come to the end of what’s possible, this phone is toast?

I have the idea to buy another Samsung Galaxy S7, maybe one with a thrashed outside, because maybe then I can put the innards into my toasted S7, which is very pretty. Not sure how difficult this would be. Or if I should just give up.
Is this level of difficulty normal, I mean is is just bloody insane how much trouble I have encountered. Read many other threads in the forum and my trouble seems more plentiful than any other…

By the way, the Download screen says: SW REV. CHECK FAIL (BOOTLOADER) DEVICE:8 BINARY:1

And it shut down. When recharging it restarts into this.

Update, I installed and ran Smart Switch. It said some thing like “Emergency…” was needed and I tried it. It did not work. Now the phone is not found.
This S7 is now scrap metal, letter press or a small boat anchor.

I have never experienced anything as troublesome as installing /e/, it has been a total nightmare. I spent 4 days on this!
Crazily though I may still not give up, I am buying another Samsung Galaxy S7 and will try again.
I might be back…

Hello Jeppe

Sorry to see you having such trouble… I’ve flashed 2 S7 and a Tab S2 with /e/ and never faced such troubles.

Maybe your phone’s flash is aged/damaged. I also thought /e/ 0.14 has massive problems with battery management until I encountered it’s a hardware problem and had to switch my phone. The S7 is a good device, but they’re aging.

Still, I’m not sure if your device really became a paperweight. It still boots.

If you start into recovery now, is it the Samsung Stock Recovery or TWRP?

Hi Ludix,
You are a rock for the technically lost!
Yes maybe it was a hardware problem with this very unit. I have had too much weird problems with it, possibly more than other users judging from what I read in the forums.

I think this S7 is a paperweight now. It does not boot, only starts up into the Error while updating… screen. Or Download mode. I will give up on it.
One idea is to do a face transplant with another S7 if I buy another one, waste the internals but keep the pretty face. There are plenty of S7’s with broken screens available.

It’s an aging model you say… Would you recommend a phone that is proved by users to be functioning well and relatively easy to install on?
I am looking for a smallish phone, about the size of the S7, about 5,1-5,2" screen, don’t want those huge types that you need a cart with wheels to bring with you out on town.

It would perhaps be a business idea for you tech-savvy people to install and sell a wider range of pre-installed phones.

Hi Jeppe

Thanks for your kind words and sorry I’m not able to help you more. Which country are you from?

Just so you know, opening the S7 is not as easy as you might think. Glueing it shut again is also not easy and something I couldn’t manage, even with a precut sheet soecificially for that (can be bought at repair stores).

On my S7 with the hardware defect I mentioned I performed a battery replacement. For opening the phone you need a heatgun, a feasible suction cup and ideally something like an iFixit Kit. If you don’t own these tools already it might be worth it to just buy a refurbished phone for a small premium.

I can’t recommend you a handset that matches your criteria right from top of my head, but this page lists all compatible devices and lets you filter them based on different criteria.

I think the Gigaset GS290 is an interesting device, if the size fits you still. Bonus is, this device can be bought pre-flashed at the /e/ store.

Flashing and selling devices sounds like a good idea at first and I played with this thought as well, but reality is that you invest a lot of time for small profits.

You’d search for devices online, try to guess the condition they’re in, hope they’re not FRP locked, bid for them (which includes the possibility they’re getting to expensive and all the invested time was for nothing), pay shipping, invest the time to flash and the time to sell it online and ship it.
Most times the devices that are cheap are damaged and you can’t be sure if they’re reparable. It can be an aging battery or a defect circuit board. A device with a smashed screen can have more damage or can be locked, which makes it unflashable. It could come from another country, with a SoC that doesn’t have an unlockable bootloader (like the Samsung US models).
You see, a lot of risk for nearly no profit.

If someone wants to send their phone for flashing service, this’d be another case - but I don’t think this should be done for money (that’s just me, everyone should decide for himself).

Hope you don’t mind the long answer and feel free to ask if you need further assistance.

Ludix,
Thanks again for your long answer.

I have realized that the face transplant idea must be abandoned.
Gigaset GS290 was the phone I was considering buying. But I think it’s a bit large.

I wouldn’t mind paying several hundreds of euros for a working /e/ phone. An iPhone costs at least 800 euro, some cost more than 1000 euro, it is crazy!
So several hundreds of euro for a new and well functioning non-big tech phone is totally ok.

Would you do flashing service for me? I wouldn’t mind paying or donating to the /e/foundation.
You’re welcome to send me a private PM if you want.

I know this thread is half a year old, but regardless I just want to add to it that I’ve experienced the exact same issue - currently stock at the Teamwin logo boot loop on a SGS7, for the exact same reason: Changing file system that never completed, forcing a reboot and ending up here.

Hi @rfalc welcome to /e/ land.

Let’s not assume you have an impossible problem! :slight_smile:

Please let us know a little about the PC or laptop you are using and the exact model and codename, (help found here: [HOWTO] Find device codename) of your device.

Please can you also provide a link to the /e/ image you downloaded.

Thanks aibd :slight_smile:

The problem is on a Samsung Galaxy S7 and I’ve been using Odin to flash TWRP.

I downloaded this https://images.ecloud.global/dev/herolte/e-0.17-o-20210531117529-dev-herolte.zip version.

Thank you @rfalc, I am not a Windows user so I am looking at defining the problem exactly! :slight_smile:

Herolte install notes

You did all this, you got a red error message, and you found yourself out of options at the last line I am quoting?

Now you’re in TWRP, congratulations, you’ve done the hardest part. Let’s detail the following procedures in several sub-steps.
A) Delete existing smartphone content

Before you reach the main menu, a message may ask you if you want to open TWRP read-only (i.e. no risk of deleting or changing anything) or not. This option shouldn’t be chosen (since we want to install a new operating system). Slide the bottom arrow from left to right.

TWRP may also ask you for a password, which is your phone password.

Once in the main menu, click on “Wipe” then “Advanced Wipe”.

Select the following items to delete and nothing else :

Dalvik / ART Cache
Data
Internal Storage
cache
system

Validate by dragging the “Swipe to Wipe” arrow from left to right.

If red error messages show up, your phone is probably encypted but TWRP can’t decrypt the /data partition (it’s a common issue on Samsung phones).

To solve that problem, go to Wipe > Advanced wipe, select “data”, click on “Repair or Change File System”, then on “Change filesystem”. Select exFAT (or another one if it doesn’t work, it doesn’t matter), then swipe from the left to the right. Redo the manipulation but this time select ext4 (which is the original file system) then slide from the left to the right.

Did you note what the red error message said?

What Android version did your phone have before you started work?

Are you sure you removed your Google account before you started? Did you do a Factory reset before you started?

Got it. :slight_smile:

I didn’t note the red errors messages to be honest, as there were many. But yes, I did everything in the listed steps: I started the TWRP step after a complete factory reset, but if a factory reset still includes a Google Account (which I assumed it didn’t), then no, I missed that step.
Honestely I’m not completely sure about which Android version was on the phone originally, but it was the most recent version for stock SGS7 (Android 8 perhaps)?

I had to look up here for the key combo for Soft reset, Volume Down and Power for over 7 seconds. Do you have any options with the hardware keys?

If not, I would consider the suggestion by @Ludix Stuck on Teamwin Logo - #20 by Ludix, perhaps wait awhile in case someone else can give an idea.

The only option I have is to get to the download file menu - all other key combinations that I know of ends up at the Teamwin loop.

I’ll go hunting for the stock image and try and flash it.

Amazing, I managed to get the stock ROM on it and it’s now back and running.

Any suggestions as to how to work around not triggering the issue with the TWRP boot loop again?

And btw., there are no accounts on the stock ROM (not Google or anything else).

So I gave it another shot and here’s the error messages I’m getting when wiping: Dalvik / ART Cache, Data, Internal Storage, cache and system.

I tried to take the next step again to change the file system to exFAT and it seems like I’m getting the same result. It says “done” in the log but the headline is “formatting” and the bar at the bottom is still alive indicating activity. But seeing others doing this on Youtube shows that it takes 10 seconds, not minutes.

[SOLVED] Choose EXT2 instead of exFAT and that solved the problem. Now running /e/!

1 Like

How did you do it? I have exactly the same problem on my S7: TWRP stuck on logo screen and I can only enter Download Mode, but flashing TWRP with Heimdall doesn’t help. I’ve tried different versions of TWRP but all get stuck on the TWRP logo.
Did you use Odin and where did you get stock image from?

Hi @Makowa welcome to the /e/ forum. Here is a link to a small part of your question! Know your hardware - Samsung

1 Like

Hey, btrother.
Same problem here. Could you tell me how did you booted into download mode.
If i boot it up into download mode i will flash the stock ROM.
But i am stuck at the logo and can’t even enter download mode.

I have Samsung A20e .

Is this device supported ?
I din’t think so, or recently !

What twrp.img did you try to flash on it ?
no problem with vbmeta or disabling encryption ?