Stuck on Teamwin Logo

I know this thread is half a year old, but regardless I just want to add to it that I’ve experienced the exact same issue - currently stock at the Teamwin logo boot loop on a SGS7, for the exact same reason: Changing file system that never completed, forcing a reboot and ending up here.

Hi @rfalc welcome to /e/ land.

Let’s not assume you have an impossible problem! :slight_smile:

Please let us know a little about the PC or laptop you are using and the exact model and codename, (help found here: [HOWTO] Find device codename) of your device.

Please can you also provide a link to the /e/ image you downloaded.

Thanks aibd :slight_smile:

The problem is on a Samsung Galaxy S7 and I’ve been using Odin to flash TWRP.

I downloaded this version.

Thank you @rfalc, I am not a Windows user so I am looking at defining the problem exactly! :slight_smile:

Herolte install notes

You did all this, you got a red error message, and you found yourself out of options at the last line I am quoting?

Now you’re in TWRP, congratulations, you’ve done the hardest part. Let’s detail the following procedures in several sub-steps.
A) Delete existing smartphone content

Before you reach the main menu, a message may ask you if you want to open TWRP read-only (i.e. no risk of deleting or changing anything) or not. This option shouldn’t be chosen (since we want to install a new operating system). Slide the bottom arrow from left to right.

TWRP may also ask you for a password, which is your phone password.

Once in the main menu, click on “Wipe” then “Advanced Wipe”.

Select the following items to delete and nothing else :

Dalvik / ART Cache
Internal Storage

Validate by dragging the “Swipe to Wipe” arrow from left to right.

If red error messages show up, your phone is probably encypted but TWRP can’t decrypt the /data partition (it’s a common issue on Samsung phones).

To solve that problem, go to Wipe > Advanced wipe, select “data”, click on “Repair or Change File System”, then on “Change filesystem”. Select exFAT (or another one if it doesn’t work, it doesn’t matter), then swipe from the left to the right. Redo the manipulation but this time select ext4 (which is the original file system) then slide from the left to the right.

Did you note what the red error message said?

What Android version did your phone have before you started work?

Are you sure you removed your Google account before you started? Did you do a Factory reset before you started?

Got it. :slight_smile:

I didn’t note the red errors messages to be honest, as there were many. But yes, I did everything in the listed steps: I started the TWRP step after a complete factory reset, but if a factory reset still includes a Google Account (which I assumed it didn’t), then no, I missed that step.
Honestely I’m not completely sure about which Android version was on the phone originally, but it was the most recent version for stock SGS7 (Android 8 perhaps)?

I had to look up here for the key combo for Soft reset, Volume Down and Power for over 7 seconds. Do you have any options with the hardware keys?

If not, I would consider the suggestion by @Ludix Stuck on Teamwin Logo - #20 by Ludix, perhaps wait awhile in case someone else can give an idea.

The only option I have is to get to the download file menu - all other key combinations that I know of ends up at the Teamwin loop.

I’ll go hunting for the stock image and try and flash it.

Amazing, I managed to get the stock ROM on it and it’s now back and running.

Any suggestions as to how to work around not triggering the issue with the TWRP boot loop again?

And btw., there are no accounts on the stock ROM (not Google or anything else).

So I gave it another shot and here’s the error messages I’m getting when wiping: Dalvik / ART Cache, Data, Internal Storage, cache and system.

I tried to take the next step again to change the file system to exFAT and it seems like I’m getting the same result. It says “done” in the log but the headline is “formatting” and the bar at the bottom is still alive indicating activity. But seeing others doing this on Youtube shows that it takes 10 seconds, not minutes.

[SOLVED] Choose EXT2 instead of exFAT and that solved the problem. Now running /e/!

1 Like

How did you do it? I have exactly the same problem on my S7: TWRP stuck on logo screen and I can only enter Download Mode, but flashing TWRP with Heimdall doesn’t help. I’ve tried different versions of TWRP but all get stuck on the TWRP logo.
Did you use Odin and where did you get stock image from?

Hi @Makowa welcome to the /e/ forum. Here is a link to a small part of your question! Know your hardware - Samsung

1 Like

Hey, btrother.
Same problem here. Could you tell me how did you booted into download mode.
If i boot it up into download mode i will flash the stock ROM.
But i am stuck at the logo and can’t even enter download mode.

I have Samsung A20e .

Is this device supported ?
I din’t think so, or recently !

What twrp.img did you try to flash on it ?
no problem with vbmeta or disabling encryption ?

hello @rfalc I have exactly the same problem.
Phone locked on the Teamwin screen after the same steps you described.
Could you please tell me where you found your stock ROM ? I cannot seem to be able to find serious websites to download it.

thank you so much in advance !

hello again, @rfalc
edit : I succeeded in reinstalling an operator ROM (yuck but anyway, it works).
I’ll now re-try the procedure, hoping I won’t get stuck again in the Teamwin screen…

well @rfalc I followed your tip about using EXT2 instead of ExFAT and IT WORKED !!

Now running /e/ on my refurbished S7 Exynos, I’m so relieved !

(note : someone could consider updating the tutorial on this aspect, to avoid further disappointments)

Hello, this tread is 2 years old not expecting any replies, i have a similar case, i installed a unofficial LOS 20 Rom and forgot to flash gapps
tried booting back to twrp and it froze, but when i restarted it took me back to LOS, but suddenly idk what happand the phone is stuck on the twrp screen, download mode wont even work (it dosent boot into LOS AND download mode) can someone help?, edit: it wont even show the charging animation, just goes straight to the s7 boot screen and into twrp im guessing i wiped the download mode code or somthing, when i plug it in into windows, windows reports as “USB Device not recognized,” and in device manager, it reports as configuration descriptor request failed. usage wise i have always used android 10 one ui 2.5 custom rom and everything was fine (it was my main phone). after i got a new phone i retired the s7 and used it to install different types of roms, one of them being LOS 20 (unofiicial) and that seemed to brick twrp AND pretty much everything else. Note that download mode did not work even at the beginnging, i used an app to put it in download mode. i wish to boot this phone up to stock rom and evrything will be fine again. ever since this issue came, i then got a samsung s4 to play around with.

(So sorry for the long paragraph i have written)


So this is the real problem !

Try to boot into Download mode after the battery has been fully drained. Read this first kudos physwizz Post #6.

A few additional methods on this old thread

The device won’t charge in download mode !
so charge it first…

it has been fully drained and i tried that multiple times. all the phone does is restarts the phone into a bootloop untill i leave the buttons and all