Stuck on Teamwin Logo

I’m installing /eos/ on my samsung galaxy s7 using this guide: [HOWTO] Install /e/ on a Samsung smartphone with Windows easily . The prbolem was that when I reached the data format section, I choose exFat but It was stuck on that screen so I force closed it using home + volume up + power. But now it’s stuck on the teamwin logo. I’m really scared that I may have bricked my phone.

someone please help me

Can you still enter download mode?

If yes, you could try reflashing TWRP. Maybe that helps.

Otherwise you could flash the stock Firmware.

Read this guide even if you are not a Linux User ! ( most steps are common )

I have the same problem. Did just that, formatted, but the phone stuck on formatting. So I forced shut down like you. Now it only restarts into teamwin, I can’t even turn it off!

Can’t enter download mode. Can’t do anything.
I guess the phone is screwed?

piero, what use is that link? I can’t find anything useful in it.

Can you do anything in TWRP?

Not sure if you are talking to me or to the original thread starter.
In my case, I can do nothing, absolutely nothing, not even turn the phone off.
If I try to restart it just goes back to the teamwin screen, and there are no buttons or anything there.

I meant you :slight_smile:

If you hold power for 30s it should pull the battery, can you boot into Download Mode after that?

Oh thanks Ludix. Appreciate the help.
No, I can’t even turn it off! Seriously, it does not respond to power off.
It is rather hot…
How the hell did it get this screwed up…
I just followed the steps in the guide: [HOWTO] Install /e/ on a Samsung smartphone with Windows easily
Where I did the reformat in TWRP and after the exFAT step it got weird, it just said “formatting…” and nothing happened, so I tried to reboot.

Sorry, I thought it’s just power, but actually it’s Vol- and Power buttons for 20 seconds. This simulates a battery disconnect.

No, no matter what I do, it just restarts to the teamwin screen.

(a few minutes later, trying and trying…)
Hey, I managed to start up the Downloading screen! No idea how that happened!
Not to screw things up again, any suggestion for the next step?

I have really struggled with this. For three days I have tried to install /e/. First with the “Easy-Installer”, which did not work (worked half the way). I have also read other threads, searched and asked in a couple of other threads. It has been unbelievably difficult and I have encountered problems on every damn step, more probably than any newbie ever.

So you could power it off with this combination?

Start it with Vol-, Home and Power. In this order. Hold it until you’re in Download mode. It can be picky, but if youre doing it like this it should work.


I’d try reflashing TWRP first.

Could not power it off. Managed to start up Download mode again. Did a TWRP reflash then.
Then I forgot to uncheck auto-reboot, but what happened was that it restarted into the frozen teamwin screen again.

Now did it again - reflash of TWRP. Auto-reboot unchecked, reboot according to the instructions in that guide above (vol down+home+power, when screen goes dark immediately go from vol down to vol up). Back at the frozen teamwin screen again…

Damn… Could you try flashing an older TWRP version? Like 3.3?

Just tried it (flash older TWRP),
I now have a yellowish teamwin screen that goes nowhere…

Update, tried again with, and the same thing happens. teamwin screen leads nowhere.
Am I supposed to do something at the teamwin screen, some magic button combinatin? Can’t remember that I used that the first time.

Normally after the splash screen the menue appears, without the need to do anything.

After flashing and restarting, are you booting straight into TWRP? This is manfatory, otherwise it isn’t persistent.

I seem to be totally screwed.
Yes it boots into TWRP, the teamwin screen. There are no options there, nowhere to go.
Also managed to boot into the Download screen.
That is all I can do. Can not turn it off.

It burns battery, totally empty in about 1,5 hour from full load, gets quite hot.
Did let it run out of battery, then connected charger, hoped it would reset somehow, but it starts up into teamwin screen automatically.

I guess your best bet is to flash the stock ROM then. There are many guides how to do this, this is one of them:

This should recover all partitions.

After flashing stock, you can try flashing /e/ again.

1 Like

I tried it, two different versions of ROM. It did not work.
It irritates me, other guys have managed to get it to work, I must have been the most unlucky person in the history of /e/, in every step along the way there were problems.
Perhaps now I have come to the end of what’s possible, this phone is toast?

I have the idea to buy another Samsung Galaxy S7, maybe one with a thrashed outside, because maybe then I can put the innards into my toasted S7, which is very pretty. Not sure how difficult this would be. Or if I should just give up.
Is this level of difficulty normal, I mean is is just bloody insane how much trouble I have encountered. Read many other threads in the forum and my trouble seems more plentiful than any other…

By the way, the Download screen says: SW REV. CHECK FAIL (BOOTLOADER) DEVICE:8 BINARY:1