Stuck without a launcher


I’m stuck without valid launcher and cant even access apps. Also, my light sensor seems off since the screen is super dark if I let it in auto luminosity.

I only have the dropdown/notification menu with shortcuts to parameters and such.

Detailed version:

Context: I have a S9 with /e/ preinstalled and bought from /e/ around last october, It has to be noted that I use HGLauncher instead of Bliss. Never tried uninstalling Bliss. Normally, when at boot, the choice is given between the 2 launchers with “once” or “always”. I select “Always HGLauncher” everytime.

Abnormality? As I dont have much knowledge on phone powers, I must say that I feel strange that a seemingly light game like “Shattered pixel dungeon” sometimes made my phone overheat and overconsume battery. Could be all unrelated to my problems.

1st step bug: I had the “apps” not working anymore, around a week ago. Last things I installed were Blokada and “Cell Tower Info”. Symptoms were new app download would always stall at 0%. I waited to be home from holidays in order to check again with ADSL link, but nope.

Second step bug: I suspected hglauncher. So I rebooted and at the launcher question I answered “Always Bliss”. At that moment, the screen went dark (Light sensor deactivated or something) and a loading circle logo appeared in the middle of the screen, and I have no access to any apps:screen is blank with only the background image.

Hint? It should also be noted that I uninstalled the weather app somehow, as I dont want one. It didnt impact.HGLauncher back then but maybe Bliss tries to find it?

Hint2: HGLauncher has a background image only where you normally acess app list after tapping the screen. Maybe HGLauncher “icon hiding” is still working?

Current symptoms: Since then, when I reboot, the launcher question is not asked anymore. After typing my PIN, I only get the loading logo in the middle of the screen and the Notification/shortcut menu with access to parameters and the rare apps that sent a notification. The light sensor is still not working.

Last tests on my own, I uninstalled the latest apps I installed in case they were cause to a problem (Blokada and Cell Tower Info) rebooted again, but same symptoms. I didnt dare uninstall HGLauncher in case it would be able to start if I were able to select it?

I don’t know if it’s going to be any helpful or lead to a solution, but have you tried booting into safe mode? (Long press Power button, then tap and hold the Power Off option). (Funnily enough, my S9 gets stuck at “Android is starting…” screen when in the safe mode, I use a 3rd party launcher, too).

Thanks for the tip. I didnt know this.

It doesnt solve the issue, though

But can you successfully log into safe mode? Because then you might be able to set your USB configuration to MTP rather than the default charging and install a launcher with the help of ADB tools? (Actually, IF you have access to options from the top status bar, you could try that without the safe mode).

I can boot in safe mode, but then I didnt succeed so far in doing this MTP stage during earlier tests. The fact that I currently only have access to a VM only computer (Qubes OS) doesnt help with USB PC to phone connexion things.

But as this should change soonish, I’d be intersested if you could point me to a simple howto url.

I don’t think there’s a howto for your specific scenario.
What I would try first is to switch back to HGLauncher (my understanding is that you’re getting stuck at the loading/blank screen after the system boots with Bliss). As you can’t do that through regular UI, perhaps you can in safe mode or through ADB.
You might want to check this out:
Prerequisites are: on your computer, having ADB tools installed, and on your phone, having both USB debugging turned on and USB configured to MTP (Settings > System > Developer options).
If for some reason you can’t default back to HGLauncher, you might want to check if removing all launchers but one automatically makes it the default one (try to find info first before deleting anything).
If you suspect there’s anything wrong with HGLauncher, you could try and install a 3rd launcher through ADB and get rid of both Bliss and HG altogether to see if that works. Your priority is to get your UI to work again, right?
On a side note, I also use a 3rd party launcher (Lawnchair 2) and Blokada, and I have disabled (and will probably soon delete) Weather and Apps, and it doesn’t seem to affect anything.

Have you read this ?


Thanks Piero!

It works. Bliss is back :smiley:

Edit! BTW, It also corrected Apps which is back too.