Teracube - 2e - Documentation Suggestions

I believe I made some progress with communication with Gagan . He believes the 2e I got shipped had a SW proceeding SW6 and that I need to flash back to SW6 then flash /e/. I am in bootloop now but still have access to the recovery partition. I will work this out as soon as I have time and report back.


This was not the issue. I flashed back to their SW6 and followed /e/'s Teracube 2e directions but still getting this error:

fastboot -w
wiping userdata…
Invalid logical-block-size 512: must be a power of 2 and at least 4096.
mke2fs 1.45.5 (07-Jan-2020)
/tmp/TemporaryFile-xe7Bmm: Unimplemented ext2 library function while setting up superblock
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata

EDIT: I am stumped on this one but have successfully installed another ROM via a simple, standard ADB sideload through TWRP. Hope to get /e/ up and going on this device someday. Would love some pointers if anyone has any.

We see here that the fail comes from the “System” mke2fs.

I have a feeling you already have “latest” platform-tools (Installing adb and fastboot on Linux PC) - but I much prefer to uninstall any and all system platform-tools, so that confusion between the two sets of platform-tools cannot happen.

1 Like

I only have “System” installed. I learned my lesson after you schooled me last time. So you think a worthy try is to uninstall “System” and run try “Latest”?

I have a fresh Ubuntu install on this partition and it is up to date. No more Mint.

Well yes. You will need latest for a modern device.

There is a school of thought that you can run latest and system side by side but I disagree with that.

If I plan to use Latest I read the package manager guides then uninstall and purge the “system” android-sdk-platform-tools before following the instructions linked above, to provide “Latest”.

1 Like

Got it. Thanks. Im giving it a shot now.

Edit: Pretty sure you and I both have seen where this causes issues up close and personal :point_down:

1 Like

Well I’ll be damned! We will see how the rest goes:

fastboot -w
wiping userdata...
Erase successful, but not automatically formatting.
File system type raw not supported.
erasing 'userdata'...
OKAY [  0.416s]
finished. total time: 0.416s

Edit: :point_up_2: I ran an adb command adb reboot fastboot (I believe) and it put me into fastbootd mode. This command was run there. Obviously wrong. I corrected this by manually powering the phone off and booting into fastboot mode using the buttons. Then everything went smoothly. Once again I am being schooled by @aibd and really appreciate his contributions. Thank you!

1 Like

I would like to hear your impressions on the Teracube as a device running /e/…warts and all!

1 Like

For anyone wondering, I purged “system” successfully from Ubuntu’s root directory with sudo rm -rf /lib/android-sdk. Do your own research first and view this only as a “hint”. This fixed my issue and then all commands came from the “latest” platform tools folder with commands all beginning with ./ . Maybe something to add to the directions or something similar?

1 Like

Pl can you check what the result for the “fastboot --version” is on your PC. Is it higher or equal to 31

Where do we raise those then? The install page links to this thread saying:

If you need help following this procedure or want to discuss any modification to it, please visit our dedicated topic on our community forum

(my emphasis)

I’ve just installed e on a brand new Teracube 2e. I boots fine but immediately tells me Bluetooth keeps stopping and then I can’t turn Wifi not Mobile data on either :frowning:

The site to raise issue is gitlab
This is mentioned on the initial page which you hit when you search for a device for example for the 2e this page has that information as to where users can raise issues…
All the same will add this link on the text and modify the statement you linked above. It is confusing. Thanks for the suggestion.

1 Like

Great, thanks @Manoj

May I suggest perhaps editing the sentence at the end of the install page to add those device and gitlab links (and/ or add them to the top post on this thread)? :slight_smile:

Yes @jdaviescoates will be adding those links on the install page…where all this confusion starts :slight_smile:

1 Like

Problem: This partition doesn't exist.

Hello all, I’m new to the community. Before getting started, I would like to apologize in advance for the novel I’m about to write; however, I am attempting to share both a very relevant solution and my experience trying to use available instructions to install /e/OS. I purchased a Teracube 2e for my son specifically to install /e/OS on it. As someone who is fairly well versed in IT, but with no experience working on unlocked Android devices, I figured I would start with the easy-installer beta. I would eventually end up with the same This partition doesn't exist issue as @free_the_phones and @egx470, but have come up with a solution that worked for me after lots of testing and sleuth work. First, let me go back to the beginning so we can see what worked for me and what didn’t in terms of the documentation. However, feel free to skip to A Solution towards the end of my post if you are stuck and want to try my method.

The easy-installer Installation guide for Windows was pretty straightforward and worked for me. Following that, the unwritten Teracube 2e drivers Install Guide suggested I try the Gigaset GS290 drivers Install Guide, which I did. However, I got stuck immediately on the tip before step one that says

Your phone must be in Fastboot mode, if you miss the fastboot interface driver

First, I had no idea what Fastboot mode was and the page does not explain how to activate it. Second, I was struggling to understand the italicized part of the tip. It was not clear if it meant that you had to be in Fastboot mode to install the driver or if it meant that you should use Fastboot mode if you don’t have the driver installed. In any case, I decided to ignore the tip and proceed with the instructions. However, the MediaTek driver never appeared in Windows Update. I decided to move ahead with easy-installer without the driver just to see what would happen.

With the Teracube 2e attached to my computer, I launched easy-installer and followed the steps of enabling developer mode (step 1), enabling USB debugging (step 2), selecting file transfer for the USB configuration (step 3), enabling OEM unlock (step 4), removing accounts (step 5), and arrived at the drivers installation check (step 6). At this point, I knew that I hadn’t succeeded with the drivers installation, so I went back to those instructions and tried Windows Update again. This time the MediaTek driver appeared and I installed it (no Fastboot required apparently?). Because it required a Windows restart, I had to exit the easy-installer and do that before proceeding.

After the Windows restart, I relaunched easy-installer, proceeded back to the drivers installation check, and the Teracube was recognized. Moving on, easy-installer downloaded /e/OS and I started the installation. It seemed to go fine for a couple of minutes until it rebooted the phone, which then displayed the /e/OS recovery screen. I had no idea what to do at that point, so I chose the reboot option and ended up back in the default OS. Needless to say, easy-installer was stuck and needed to be relaunched.

The second time around, I proceeded through easy-installer until installation started. Again, it seemed to go fine until it rebooted back to the /e/OS recovery screen. This time I chose the bootloader option, and installation seemed to proceed until it resulted in an error and quit (see image below). I tried a couple more times and got the same result.

Noticing there was a log, I decided to locate it and found it under C:\Users\[user]\AppData\Local\easy-installer. It showed the following (copied starting from the last successful item):

C:\Users\[user]\AppData\Local\easy-installer\sources\Teracube_2e>"C:\Program Files\easy-installer\bin\adb\fastboot" -s ""202011T2E001870"" flash vbmeta_vendor vbmeta_vendor.img 

Sending 'vbmeta_vendor' (4 KB)                     OKAY [  0.007s]
Writing 'vbmeta_vendor'                            OKAY [  0.005s]
Finished. Total time: 0.015s

C:\Users\[user]\AppData\Local\easy-installer\sources\Teracube_2e>if errorLevel 1 (exit /b 16  ) 
C:\Users\[user]\AppData\Local\easy-installer\sources\Teracube_2e>ping -n 1 -w 10000  1>NUL 
C:\Users\[user]\AppData\Local\easy-installer\sources\Teracube_2e>echo "Flashed vbmeta_vendor" 

"Flashed vbmeta_vendor"

C:\Users\[user]\AppData\Local\easy-installer\sources\Teracube_2e>"C:\Program Files\easy-installer\bin\adb\fastboot" -s ""202011T2E001870"" reboot fastboot 

Rebooting into fastboot                            OKAY [  0.001s]

< waiting for 202011T2E001870 >

fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.

C:\Users\[user]\AppData\Local\easy-installer\sources\Teracube_2e>ping -n 6 -w 10000  1>NUL 
C:\Users\[user]\AppData\Local\easy-installer\sources\Teracube_2e>echo "Rebooted on fastboot" 

"Rebooted on fastboot"

C:\Users\[user]\AppData\Local\easy-installer\sources\Teracube_2e>"C:\Program Files\easy-installer\bin\adb\fastboot" -s ""202011T2E001870"" flash system system.img 

Sending sparse 'system' 1/14 (131068 KB)           OKAY [  4.002s]
Writing 'system'                                   FAILED (remote: 'This partition doesn''t exist')
fastboot: error: Command failed

C:\Users\[user]\AppData\Local\easy-installer\sources\Teracube_2e>if errorLevel 1 (exit /b 18  ) 
exit value = 18

This led me to try the manual installation method egx470 already referred to. Fortunately, easy-installer had already put adb and fastboot on my system under C:\Program Files\easy-installer\bin\adb, so I didn’t need to worry about that. Not yet knowing about Adding adb path to the environment variables, I simply ran adb and fastboot from their location in the easy-installer folder I just mentioned. To further simplify, I also copied all the necessary *.img files to that folder. In any case, I always had trouble with the fastboot reboot fastboot step and had to keep choosing bootloader from the e/OS/ recovery screen that appeared. After returning to fastboot, I kept receiving the same This partition doesn't exist error when trying to flash system.img.

Now my research began in earnest because nothing was working. I came across references to fastbootd as being necessary to flash certain *.img files on Android 10+ devices and ended up finding the same dynamic partition page that aibd mentions here (unfortunately, I hadn’t found this page yet). The same website also provided me with good info about Moving Fastboot to Userspace, which includes instructions on how to access fastbootd and a list of commands you can use with it.

Despite all of this great information about fastbootd, I was still not able to access it. I then decided to give up on /e/OS and reflash the stock Teracube OS. Afterwards, I tried to access fastbootd just for kicks. As it turns out, it worked! I figured that some part of /e/OS was removing fastbootd and proceeded to flash one *.img file at a time and then retest for fastbootd. The culprit is the second installation file in the list, recovery.img. Thus, this file needs fastbootd capability added to it for proper installation on the Teracube 2e, or the sequence needs to be restructured as I outline below (either should also fix easy-installer).

A Solution
If you have already received The partition doesn't exist error, you will need to reflash the stock recovery.img file first (see free_the_phones’s OEM ROM link above) because you already replaced it earlier in the /e/OS installation sequence. FYI, the same command used to flash the /e/OS recovery.img file can be used to reflash the stock one. Then, just rearrange the installation sequence as shown below.

fastboot -w
fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot flash vbmeta vbmeta.img
fastboot flash vbmeta_system vbmeta_system.img
fastboot flash vbmeta_vendor vbmeta_vendor.img
fastboot reboot fastboot

NOTE: The above command now opens fastbootd. The fastbootd screen on the phone is basically the stock OS recovery screen, but you run the commands below despite what you see on screen.

fastboot flash system system.img
fastboot flash product product.img
fastboot flash vendor vendor.img
adb reboot bootloader
fastboot flash recovery recovery.img
fastboot reboot

That’s it finally! I hope this helps someone not waste the hours that I did. I’m just happy that I now have /e/OS running on the phone, and even received the update that was released a couple of days ago.


Hey all. I’ve had e running on my 2e for a few months and I see there’s an update (8/28). Last time I hit “install” on an update it failed and I had to manually wipe and flash from my PC. I see now that it mentions having a compatible recovery installed in order to install on the phone. What recovery can I flash that will support that?

Aside from that, if I end up flashing manually, will I have to wipe again or should the install work as overwrite?


Self-replying here…

Happy to report that the OTA installed fine and no manual intervention was required. Good stuff!

Hi prflsjn,
Thanks for your post. In the first line of your post, you apologize for the “novel” you are about to write.
This type of post is exactly what is needed for non-coder power users to be able to get this done (and save time and frustration).
I am, in fact, about to embark on this project (putting /e/ on the Teracube 2e) and I was wondering if you have any additional info/anything new transpired since last August about this.
Upon first read, by the way, this seems like a simple bug in the easy-installer (at least for the Teracube 2e) - has anything been done about this?
Thanks again:

1 Like

Hi UBoMWe,

Thanks for your comments. I have not yet had a chance to try the process again because I only set up the one phone. However, I just ordered another Teracube 2e for my other son and will be repeating the process in the near future. Did you have any luck with the easy-installer (hopefully they updated it to fix the issue) or did you have to try my instructions? I’m just curious so I will know where to start next time.