Teracube - 2e - Documentation Suggestions

I am sad to say that I am aware of no changes nor bug reports since your most useful analysis @prflsjn, any changes to Easy Installer should be evident here Releases · e / tools / Easy Installer · GitLab.

I find the Downloads section to be unclear. What does it mean to “Try” the /e/ Recovery?

The suggested guide does not explain the difference between “/e/ Recovery” and “/e/OS Build”. It does not appear to matter, since the linked zip files for the two are identical.

Thanks for inviting feedback!

In the Installing section, it might be good to start with making sure the device is in fastboot mode.
Sorry if that is just too basic.

The Requirements section instructs the reader to enable USB debugging, but the entire procedure is done in fastboot mode. Is it really necessary to enable USB debugging?

It seems I should be able to power up my new phone in fastboot mode, unlock, and start flashing without ever booting to the factory ROM.

Or maybe I don’t know what I am talking about - which is entirely possible!

@Manoj, can you clarify this for us? The Teracube 2e 2022 install Instructions have links for

/e/ Recovery for stable build
/e/OS build : R stable

but both links point to to the same page. What’s the difference?
I guess it does not matter which one to use?

Also, I still don’t understand why it says " Try the /e/ Recovery (limited functionality)" Is there a way to load the recovery and install from there?

I see the instructions for the 2020 model are the same.

Thanks for pointing this out. The /e/OS build and the /e/OS recovery image are usually displayed on the same page for all devices, for example

In the case of the 2e the recovery file does not seem to have been built. This is an issue and I shall ask the build team to look into it.

/e/OS recovery has limited functionality when compared to TWRP.

Teracube released 2 models one in 2020 which is code named 2e and one in 2021 code named emerald
The instructions are not the same …check the screenshots given below


Thanks @Manoj that helps.
I knew the instructions for the 2 models were different. What I meant to convey is that the instructions for both have the same problem with the download links (the recovery links actually pointing to build images.) Sorry for not being clear.

Checked with the build team…

In the case of the Teracube emerald build, the recovery is inside the zip file.
You do not need to separately install it.
The recovery gets installed as part of the installation steps.

The install guide has an error as it was created using templates and refers to the recovery separately.
Will have that corrected.

The instructions don’t say anything about a driver specifically for the Teracube 2e.

This causes the install to fail after the following command:
fastboot reboot fastboot

It does reboot into fastbootd, but fastboot on Windows cannot talk to it because of lack of driver.

Edit you have asked this question rather differently in another post.

The workaround for one known issue for a number of devices follows.

The cause is that when you first ask Windows to select a driver, it selects a small one rather than a combination driver which will perform development tasks.

As you work through your instructions have a Windows device manager window open. As you found, as you switch into fastboot mode a :warning: ‘problem device’ may show up.

At that point in time, use Windows update to search for a driver – usually Windows will find it automatically in its search.

In the event you describe, perhaps you could try the Windows update again, at this point where :warning: appears.

Once the :warning: is resolved you can move on with your install instructions.

It would be interesting if this trick worked, but I am not so hopeful.

Fastbootd seems to be functional in limited circumstances. One known thing is that the sequence of commands must be exactly correct. (For instance a similar thing might happen if the phone accidentally booted into system during the sequence of commands, or one stopped, then went back and retraced one’s steps.)

Yup, I did it here before realizing it was more than just a documentation request. Fixed in the other post!

The system had the adb & fastboot capable driver, but not the fastbootd driver.

Is there any Teracube 2 EasyInstaller on the horizon. I made a huge mistake by ordering a Teracube 2 from Teracube so it is on Google. Unfortunately, almost none of the instructions I found regarding uploading the OS by myself work. Even the one about opening a Command Prompt. Does anyone know of any other De-Googled OS that can be installed on a phone like the Teracube where we can easily flush ANdroid and installed the new OS with minimal instructions?

Have you made sure the instructions are for your device? There are two variants of the Teracube 2e:

It might be worth to open a topic of your own and tell the community at which point you run into a problem.

Here’s a short 1 page introduction, including how to open it on Windows, OS X and Linux … https://tutorial.djangogirls.org/en/intro_to_command_line/

And to improve the /e/OS documentation please cite or give a link to the instructions about the command prompt which didn’t work for you when you tried.
Also please tell which OS and OS version you use on your computer.

Just to manage expectations … everything currently available for your device will still be Android technically (because it will be based on AOSP) as far as I see. But you can certainly limit Google involvement by using alternative Android OSes.

Perhaps have a look at iodéOS, if you can’t get /e/OS to work. There’s a community, too.

Thanks for the tips AnotherElk,

I will give another push next week-end and I will actually make a short onscreen video of the whole thing on Screencast-O-Matic. If there is anything going south, I will simply point to the time of the video to see where I am blocked.
I am not totally ignorant about computers but I am clearly not a programmer or I.T. pro either.

For example, after some research I found out that in order to access some Developper hidden menus on my Teracube I had to press the Built number like 8 or 9 times, then BAM! it all showed up,
I don’t remember seeing anything about it in the instructions on the E-Foundations. This type of stuff is kindergarten knowledge among the “initiated” but for me this was a discovery. THat’s why I wasted some time looking all over the place for something that was hidden. Now I can pull that menu in 2 seconds. This is the type of stuff I am running into.

I will try to document those small moves so those that are not used to root their phone or change their cell phone software can have a set of “entry level” instructions, all in one document. I also think I downloaded an app allowing me to see my cell screen on one of my PC monitors so this will be helpful.

As you suggested I will start a new thread for those interested to follow it or add a few tips.

Thanks Again.

In the install instructions for both Teracube 2e variants, there’s this …

“Enable USB debugging on your device. You can find the instructions here

It’s the “here” link :wink: .

After step 7
fastboot reboot fastboot
my phone rebooted into fastbootd, but then I had to do a bunch of digging and didn’t realize that I had to install more drivers (on windows) and reboot at that time. Maybe a note after that or in the troubleshooting to say that you may have to install more drivers for that fastbootd phase!

Hi @Manoj ,
Instructions to lock the bootloader are not correct and this shall be corrected.

Refer to my post Tercaube 2e installation & documentation

There is a “fastboot reboot” command that shall no be sent before “flashing lock” command.

Hi @christophe14 thanks for pointing this out. The guides for the devices we sell are usually written by the build team members. Will have one of them check it and correct the sequence.

Thanks @Manoj

Also, 2e SN 2020 codename is zirconia.
So, I recommand to change links from https://doc.e.foundation/devices/2e to https://doc.e.foundation/devices/zirconia

We were informed by the 2e team of the change in the device codename. Changing it is a bit complicated, as the folder structure and build system all uses the older codename of emerald. That being said, we will change it ASAP.