Testing. Updating Nougat to Pie Without Firmware

Note: This is not a tutorial, how-to, or guide. Merely a journey trying to figure out how to easily and simply upgrade the Essential PH-1 from an existing /e/ Nougat ROM to Pi/e/ without losing data, going back to stock, or what have you.

Okay, for testing purposes I went all the way back down to stock Nougat firmware. Using last Nougat build from Essential (some of the Nougat back-to-stock builds are no longer available).

I edited the flashall.bat a bit. With ‘fastboot -w’ in the first line, to erase userdata beforehand.
The last two lines I used also:
‘fastboot -w’
‘fastboot reboot bootloader’

After that I did the following procedure to install TWRP using the official image and zip.
twrp-installer-mata-3.2.3-0.zip (renamed to twrp-mata.zip)
twrp-3.2.3-0-mata.img (renamed to twrp-mata.img)

fastboot getvar current-slot

It returned “_a”.

I install TWRP image to both slots.

fastboot flash boot_b twrp-mata.img
fastboot flash boot_a twrp-mata.img
fastboot --set-active=b

Use volume buttons to choose RECOVERY in bootloader screen and press power button to reboot.

Back in recovery, touch is working fine on slot b.
Push TWRP zip to phone.

adb push twrp-mata.zip /sdcard/

Flash it normally. When complete go to Reboot menu. Select original slot A. Back to Reboot Menu and select Recovery. Of course there will be repeated prompts to keep system read-omly or whether to install the TWRP app. That’s because TWRP’s settings aren’t being retained on the storage yet.
Touch is also working just fine on both slots.

Tried to boot into the stock ROM. Got thrown into TWRP instead. That’s fine.
Formatted /data and rebooted back into TWRP so I coukd change and keep its settings. Rebooted to System, it failed again. Still not a problem.

Push /e/ Nougat and TWRP to phone.

adb push -p e-0.7-n-2020021140863-dev-mata.zip /sdcard/eosn.zip (should’ve renamed it earlier :grin: )
adb push twrp-mata.zip /sdcard/

Flashed ROM, flashed TWRP, wiped dalvik and /data. Just in case. Reboot.
ROM boots up normally. Currently setting up and testing.

Nougat build was running great. All parts and pieces were a-ok. Now I get to the upgrading part.

Push Pie build and TWRP. I won’t do any wipes as I am not sure if there is anything to wipe except dalvik. Pie will flash to the other slot that may house the stock ROM. I could switch over to that slot, wipe system, flip back, then flash ROM or… take my chances that flashing will automatically remove existing /system contents. I’ll take my chances.

Flash Pie and TWRP. Wiped only Dalvik.
Pie ROM booted. First thing I noticed at the lockscreen was the mobile data icon without LTE. Even worse, no touch in the ROM. Cannot swipe at the lockscreen, cannot reboot via power menu.
Even worse than that, used Power+VolumeDown to boot to boatloader menu and then to recovery. In TWRP, no touch whatsoever. Pie killed touch. :anguished:

Hook up to PC.
adb reboot bootloader
fastboot getvar current-slot “_a”
fastboot --set-active=b
Reboot back into recovery via volume and power buttons.
Touch is working on the Nougat side (b).
Not sure if things work this way but I switched to slot A in TWRP, wiped system, then switched back to B (not really knowing if I wiped the Nougat or Pie side. Will know soon enough).
Reflash Pie build. Well, the warning page showed I may have wiped out Nougat after all. LOL.

Now that the hopes of a simple upgrade have failed for me I decided to go off the rails. The Back-To-Stock people also have what are known as NOVENDOR packages. From what I gather these allow for custom ROM users to update the underlying firmware without data or ROM loss. So making sure that I’m on the slot with the unreponsive TWRP and ROM I flashed a Pie NOVENDOR package, [PQ1A.190105.112-NOVENDOR.zip](https://sourceforge.net/projects/mata-bts/files/Pie/August/PQ1A.190105.112-NOVENDOR.zip/download].

Once complete i reboot back into recovery usimg volume rockers. Lo and behold, touch is working. Interesting. Reboot to System. Pie ROM boots but seems stuck at the lockscreen (probably should’ve wiped dalvik first). Long-pressed the volume button to reboot. ROM boots. Data is working and so is touch. Bkuetooth keeps stopping so I go back to TWRP, wipe dalvik, and reboot.

Pie for the most part is workimg. Most of the system settings have been retained. However, BlueTooth is broken. Constantly stopping even after clearimg cache and data. Wi-Fi also won’t turn on.
Everything else seems to be working fine. Syncimg of ecloud files, contacts, calendar, mail, location & Maps, and SMS.

Reaet network settings and rebooted. No change on BT and WiFi.
It’s only midnight but I’m done for the day. Next test I’ll see what happens if I do Nougat, then NOVENDOR, then Pi/e/ in a bid to retain data.

Regarding TWRP. The Essential Rooting Guide (Method 1) that provides the TWRP-SEP.img implies that touch in TWRP is technically fine but Pie images after a certain date broke it. The fact that touch worked perfectly durimg the Nougat phase but not after Pie was flashed kind of affirms that. Not the same as confirms though.

Addendum: Before retiring I flashed Pie and TWRP again so now the ROM occupies both slots. Rebooted back into recovery. Touch is working on both slots. Otherwise, no change.

@marcdw, thanks for this interesting test.

In this context it is also interesting to read this articles:

Updating to /e/OS Pie using fastboot, adb, and TWRP

Update PH1 from /e/ 0.7 to PIE …

1 Like

Thanks and so glad you mentioned that. Near the end of my testing I thought “Oh wait, I forgot about archje’s article and so probably missing something”.
One of the above is mine. Pistou and Quaternium have eventually tackled it. We all have different methods.
Just trying different things so we can get the documentation squared away.

1 Like

I recently heard of builds with integrated firmware, so that you wont have to worry about it during flash, maybe that could be implemented in the upgrade builds for /e/… Would make things a lot more user friendly…:slight_smile:

I find your way very easy.

I am not sure if I could have reached the good resutlts should I have managed my slot issue better.
Well… i let someone else try :wink: I will keep my PIE as it is now (working).

Thanks both for your support in this challenge

Yeah, my original Pie setup is good to go and backed up. Just hope I can restore it.

So @Pistou, was your setup a Nougat to Pie update while retaining data?
My second and third round of testing still results in Wi-Fi not turning on and Bluetooth repeatedly crashing. In Nougat they’re fine. The Klik camera would throw out error toasts though it did work after a reboot.
As a last move before getting ready for bed I wiped /data and dalvik. During the setup wizard the BT crashes and non-working Wi-Fi are evident.

My next round of testing will use a back to stock method without a userdata wipe. Maybe that’ll fix the hardware issues.

Oh, a dumb side note. In the first post I mentioned that the stock Nougat ROM wouldn’t boot and I’m thrown back into TWRP.
Although I know this, I guess I sort of “forget” while I’m messing around. On A/B system-as-root devices TWRP is part of the boot image. It doesn’t reside in a /recovery partition like on other/older devices.
So me flashing the TWRP image to both slots means I’m essentially overwriting any existing boot images. That’s why the stock wouldn’t boot. Reason why TWRP instructions say to get the current slot (where your ROM is) and flash image to the other slot. Flashing the TWRP zip then patches/embeds the recovery into the boot images.

The realization came when both the Pie ROM and TWRP had no touch. I thought okay, I’ll just flash the TWRP image to the slot and get touch back. Reboot back to recovery and I have touch. Went to boot the ROM and was thrown back into TWRP. Like a dope I repeated on the other slot. No bootable ROM on either slot. DOH! Had to reflash.

I uh, blame it on lack of sleep or old age ( @harvey186 has a few years on me so that excuse won’t fly). :stuck_out_tongue_closed_eyes:


For information only!

Test (successful): Downgrading LineageOS 17.1 to /e/ OS e-0.7-n(ougat) with “clean install” on the LG G5 (Int.) - “h850” without intermediate step (StockROM Android).

After a day off I played around a lot yesterday. Regardless of method, going to Nougat to Pie while retaining data and settings was always a go. Still not sure how the documentation should be written up as we have different ways to get to the same point on the mata.

My personal issues are with the loss of WiFi and Bluetooth on Pi/e/. Not sure what’s going on there. After finishing up (or being fed up) I did a full back to stock. Ran Pie stock. WiFi and BT worked fine. Installed Pi/e/ and same. Broken.

Lastly, today I cleaned and cleared everything, reformatted data, and restored my Pi/e/. Also broken even though it worked fine before. Don’t have a clue what’s going on here. I can do without them for awhile I guess.

For testing purposes I flashed three ROMs: AospExtended, Paranoid Android, and LineageOS. Bluetooth and WiFi worked on all three. Then I flashed Pi/e/ and all was good, too. Okay, nice. Took a chance and restored Pi/e/ and that was also good.
Weird but at least everything is back to normal.

This just does not make any sense. There is something which we are missing. All the same @marcdw thanks for this heavy duty testing.