Trouble when updating my device (LeEco Le 2 X527)

Hi folks,
until today I’ve downloaded 3 updates for my phone but unfortunately I wasn’t able to install any of them :face_with_raised_eyebrow:

I tried it the OTA way, as I got the updates offered when I turned on the phone.

I have the versions that were offered on Mar. 13th ( OS 0.7-2020031345025),
on Apr. 09th (OS 0.8-2020040948906 and
on Apr. 11th (OS 0.8-2020041149224).

Whenever I try to install a version I get an error message saying: “Failed to update! Cause: corrupted”

What’s going wrong here?

Any advice appreciated, thank you!



were you able to update without issue before ?

A solution would be to manually install the update you want in TWRP.
You can directly install the latest version, or the one before so that you will be able to test if the ota update works for the latest or not.

thanks for your quick reply.

No, so far I didn’t update any version of the installed OS, I’m pretty new in the “/e business”. I started using it on Feb. 26th…

What’s the thing with that “File corrupted” message?

Hello @bixxby, I still remember the installation procedure in February 2020. That is why I take the liberty of asking in advance: Do you know how to use the TWRP “File Manager”?.

Don’t have any clue…

Then in TWRP, go to “Advanced” > “File manager” and browse to : / > “data” > “lineageos_updates”.
You should have 3 files (because you have tried to download 3 updates.

Click on one of them, then on “Delete” ou “Remove”.

Do this for the 3 files.

Go back in /e/ and try to download and install an update.

Ask if you have any doubt.

You can also look at that howto in order to see how to install an update via TWRP if needed :

Hi Anonyme,
when I try to open the TWRP App on the phone it shows me something called “microG Services core”.
I assume, this is not TWRP… ?

I can only choose to sign in (to a Google Account) or to cancel. The cancellation does not work…


Boot Modes TWRP Recovery: With the device powered off, hold Volume Up + Power.(button)

Ah, my wrong… SORRY! :woozy_face:

And it’s “Volume Down” plus “Power”…

Sorry, but when I start the “Recovery Mode” I can’t do anything. All I see on the screen is the LeEco logo and the word “RECOVERY”…

Boot modes

  • TWRP Recovery : With the device powered off, hold Volume Up + Power.

  • LeEco Download : With the device powered off, hold Volume Down + Power

Sorry guys, it doesn’t work either way, I’m always stuck in RECOVERY, no chance to enter TWRP. I think I’ll stay without updating my version of the OS.

Thanks for your efforts, appreciate!

Low battery can cause this also.

Hello ! I encounter a similar yet slightly different problem on my phone. It is a Samsung Galaxy S6 Edge. Starting from the system version /e/ OS 0.7-2020021541379, I tried updating with the OTA to /e/OS 0.8-2020040948906 (9 april 2020). The update is correctly downloaded, but fails to install as well.

I then tried updating via the TWRP install fonction from the data>lineageos_updates folder. TWRP then says that the update was done succesfully. The phone reboots, I am then prompted to decrypt my phone.

What follows says I entered the correct password but the data is corrupt, and that I should reset my phone. (see image here)

I also tried the april 11th and april 13th updates, both of which gave the same result.

I decided to go back to /e/ OS 0.7-2020021541379 using the TWRP install function, and it is back to normal, but not updated.

Would someone more knowledgeable be able to enlighten me as to what to do ?

I would like to finish by saying that I am so, so grateful to all of you who take the time to help and developp this OS that I find simply fantastic !

Thank you in advance for your help and have a beautiful day :smile:

Hello, welcome in the community :slight_smile:

It’s not your fault, it’s an issue of the S6 and the v0.8 updates.

An issue has been raised here if you want to follow it :

Juste stay on the last v0.7 version for now.

Thank you for the lightning quick reply !

I spent quite a bit of time looking for a thread about this particular issue but did not find it, probably because I did not look hard enough, apologies !

I’ll stay on v.07 for now then.

Thanks again !

It’s a new issue so you are the second case reported, it’s normal if you didn’t find anything :slight_smile:

Just for further information regarding → e-0.8-n-2020041349483-dev-zeroltexx

1 Like


May I ask if there was any progress in solving this issue ? I asked on GitLab but no one answered.

Thank you !