Troubleshooting Bootloop Galaxy J7 when install /e/ img with heimdall

I tried to install /e/ on my recently acquired GalaxyJ7, model J730F-DS with my debian bullseye laptop. I first tried to use esay-installer but the phone isn’t detected by the software.

So I followed these instructions : Install /e/ on a Samsung Galaxy J7 (Exynos) - “j7elte” with latest ‘/e/’ img with J7 serie, which was : recovery-e-1.1-q-20220629200240-dev-j7elte image

I suceed to enable developper options and to unlock OEM on the phone, restarted it on download mode, skipped the part about drivers as I’m not using windows and finally run :

heimdall print-pit

The phone successfully restarted. I turned it off, then on in download mode again and flashed /e/ image to the phone through heimdall with :
heimdall flash --RECOVERY recovery-e-1.0-q-20220527189323-dev-j7elte.img --no-reboot

Terminal answer was :
Heimdall v1.4.2


Initialising connection…
Detecting device…
Claiming interface…
Setting up interface…

Initialising protocol…
Protocol initialisation successful.

Beginning session…

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device’s PIT file…
PIT file download successful.

Uploading RECOVERY
RECOVERY upload successful

Ending session…
Releasing device interface…
and a white bar appeared on the phone’s blue screen, under “Downloading… Do not turn off target”.
I had no error shown, neither through heimdall, nor on download phone mode.

Then I tried several times to turn off the phone and start it on recovery mode to follow instructions but I failed. First, it cannot be properly turned off as it restarts 2 seconds later when using volumeDown+Power. Then, EITHER the phone starts with Samsung J7 logo and get stuck on it when I do nothing or when I try to start on recovery with pressing volume up+home+power OR when I use volume down+home+power, it starts on download mode again.

Thinking it may be volumeUp that’s not functionnal, I tried to boot in recovery mode using adb since both adb and fastboot are functionnal, as I successfully installed ‘/e/’ on a OnePlus 5 previously but my GalaxyJ7 isn’t recognized anymore. List of devices attached is empty when I try to find it with adb devices and I get ‘error: no devices/emulators found’ when trying other adb commands.

Since only J700 models are listed to be supported on devices j7elte page, is this the reason why I cannot go further with my phone ?

If so, 1) is there a way to get a version that would be supported by this phone ? I’ve looked on the list there but it’s not on the list-of-unofficial-e-builds I found (I cannot link more than 2 URLs yet)

Or 2) is there any way to get back to a factory resetted phone ? I only learned about PIT files when trying to solve this issue so I haven’t download my phone’s initial PIT file before.

Also, I’ve go through a lot of forum discussions about bootloop and failed installs and read a lot about TWRP but still don’t understand what it is and if it’s relevant to know about it here.
Understanding that getting back twrp could solve the issue, I tried to download a proper twrp img file from here : Samsung Galaxy J7 (2017 Qualcomm Sprint) (but not sure it’s the right model) and flashing it but I only got back the answer :
Initialising connection…
Detecting device…
Claiming interface…
Setting up interface…

Initialising protocol…
ERROR: Protocol initialisation failed!

Any other advice welcome !

Hi @shaton welcome to the /e/ forum.

Quite a few questions there, much as I asked myself the first time I flashed a Samsung – I wrote this Know your hardware - Samsung.

Just to touch a couple of issues. The /e/ Recovery is made to be a replacement for TWRP, it has a smaller footprint, and you can be sure that the /e/ Recovery downloaded with your /e/ ROM will be the right one, no need to worry about TWRP versions. (Experts will say TWRP has useful features; others say that a more simple Recovery leaves less room for mistakes.)

In my article I mostly mention TWRP as that was what I used at the time.

Maybe one of the main issues you ran into was covered in the section

Your first boot into TWRP.

Please feel free to ask again where you need more information.