Troublesome install on Samsung Galaxy S7

Januari 2023

I have been trying to get e/os installed on a newly bought, refurbished Samsung Galaxy S7.

I tried to use the Easy Installer first.


I’m working on a Linux computer. This would not have been a problem except, when you use Linux MX you can’t use snap packages to install easy-installer without a special trick. This involves booting your computer in a ‘systemd’ mode to be able to work with snap. It took me some time searching to discover this…

In the end I got Easy-installer working.

Unfortunately Easy-installer did NOT work. When Easy-installer tried to flash TWRP it ended with an error and I could not continue/finish the installation, but my phone stayed in a useable state.

Next I tried the manual method involving command line commands and installing Heimdall (version 1.4.2), adb (Android Developer platform tools) etc. This is of course all more complicated and not for the inexperienced!

No problems so far, next I downloaded:

  • the latest version of e/os (
  • the latest TWRP for my S7 (Herolte) (twrp-3.7.0_9-0-herolte.img)

Next step is flashing TWRP with Heimdall. Unfortunately Heimdall could not finish and ended at 100% with an error stating that it encountered a faulty end of file or something like that (I did not write it down).

This left me with a bricked phone stuck in a download screen and a lot of stress. Because I could not switch off, the phone stayed on, got quite warm and after a couple of hours switched off, presumably with an empty battery.

In the days after, I did a lot of searching. Suspecting that Heimdall was the culprit, not being maintained for 7 years(!) I decided to have a go with ODIN on my Virtual Windows 7.

This took some effort, due to USB problems, but I finally got Odin working on my VirtualBox Windows 7. Alas, Odin as well, at 100%, could not finish the job, so I still had a bricked phone.
(I downloaded twrp-3.7.0_9-0-herolte.img.tar for that).

I had to find a way to get my phone in original state, so I looked to get the original ROMS. Thank god, I could get the exact right ones with a simple tool called SamLoader, look here:

With ODIN I could now restore my phone in original condition. Pweh, a sigh of relieve!

Now I suspected that, maybe the TWRP version that I used was faulty. I guessed that the easy-installer used the last version of TWRP, just like I had done. Therefore I decided to use:
twrp-3.6.1_9-0-herolte.img (instead of twrp-3.7.0_9-0-herolte.img(.tar))

Now ODIN succeed and since I’m an avid Linux user, I tried the Heimdall route on Linux again with succes! Finally I could finish the complete installation and so far I’m pleased with what I have seen in e/os.

Can anyone confirm about the corrupted/faulty TWRP images?

1 Like

as the S7 was originaly released with android 7 nougat, I think twrp version most have to be related to this generation, on many samsung devices i know (s3 to s7) twrp 3.3.x-x is the best…

Welcome to the forum, and thank you to relate your “parcourt” to /e/ running on your phone. Congratulations.
It was complicated for me too, that decided me to stay on the forum hoping i can help new users switching to /e/.
[HOWTO] an Unified Install Guide Project for /e/