Unable to start TWRP on Samsung S8

I know, many people have problems installing Teamwin on a Samsung device due to the fast switch from shutting down to force recovery mode, but its now my 5th try and since there are some other problems during the process, I decided to ask for help here. The list below are the things I did, if something is missing, do not hesitate to mention it.

I am using:

  • easy installer on Windows 10
  • a new Thunderbolt 4 cable
  • a factory reset Samsung SM-G950F
  • Samsung USB Driver

In developer settings:

  • set default USB to transferring files
  • Activated OEM
  • Activated Android USB Debugging

There was never a google (or any) account on this phone since reset.

After following the steps of easy-installer, in download mode, I press Volume Down + Bixby + Power and instantly switch from Volume Down to Volume Up when the screen turns black. Android then shows “Installing Update” and then “No command”. After this I get to the stock recovery menu.

I suspect there are some problems with my phone as it installs apps from a network provider in my country and uses a different language when showing “Installing Update” and “No command” although I factory reset the device and set it up as english.

Another thing is that Odin fails to flash TWRP. After a short time it says complete(write) operation failed. I have yet to resolve this issue.

Thank you for not immediately dismissing the post as “unable to press volume up fast enough” and thank you for your help in advance!

Hi @sebi welcome to the /e/ forum and thank you for a nice report!

Difficulties with usb cable can extend though the whole USB chain, usb hubs (avoid) usb secondary ports (that is front port rather than sometimes soldered to motherboard rear port), even the PC itself might contain hardware not recogised for some reason. Did you already find Easy Installer - FAQ.

As you mention a language issue, this makes me think of a Samsung Region Lock. This might show up as Prenormal on your Odin mode screen. It is also described here Know your hardware - Samsung.

The log, found with the help of Howto troubleshoot issues with the easy-installer, is expected to show whether TWRP was flashed successfully.

You might try to research if you have the correct stock ROM for your device, and whether Odin might be able to re flash the Stock ROM.

1 Like

Hi @aibd

Thanks for the quick reply.

The phone is directly plugged into my PC using its Thunderbolt 4 port and a 24-pin USB-C cable. So it should use USB-C 3.1 to communicate with the phone. Windows recognizes the phone and I am able to exchange files. Also Easy Installer is able to get the device info.

Log files: (I replaced the paths with {description_of_path})

After checking the checksums Heimdall fails to detect the device:
"{path_to_heimdall}" detect 1>nul
ERROR: Failed to detect compatible download-mode device.

The log files have the line: "{path_to_heimdall}" flash --RECOVERY "{path_to_twrp-3.3.1-2-dreamlte.img}" --no-reboot

After this, Heimdall initiates and throws the error Failed to access device. libusb error: -12

The log files end with “waiting for recovery” and then “stage is closing” as I closed the program when I got to the default recovery menu.

The phone does not appear to be in Prenormal state as it is not shown in the Download mode screen:

My next steps will be to see if I can resolve the issue with using Heimdlall. According to this stackexchange post, Heimdall works only with USB 2.0. I tried a new USB-C 2.0 cable and a USB 2.0 cable with USB type-A, both did not resolve the issue.

I also will look into flashing the Stock ROM onto the phone (but first I have to resolve Heimdall/Odin issues)

Thank you very much for your quick response!

Failed to access device. libusb error: -12

You have a pre-packed heimdall provided by Easy Installer, libusb has a hard job to keep up with all new hardware – https://github.com/pbatard/libwdi and https://libusb.info/ give some insight. I have updated libusb manually on Debian 11; one might hope that good Windows drivers might facilitate best delivery.

I notice the driver you link.

This is a link to https://zadig.akeo.ie/ mentioned here https://github.com/libusb/libusb/wiki/Windows#Driver_Installation

USB-C 3.1

indicates a fairly advanced or new machine.

KG STATE : Checking

is ok.

Heimdall works only with USB 2.0. I tried a new USB-C 2.0 cable and a USB 2.0 cable with USB type-A, both did not resolve the issue.

Just a thought you might have an internal hub in the machine, you could check the manual?

Last thought your Samsung Windows drivers will aim to fix the Samsung end – I am now looking at the machine end!

So I grabbed my laptop from 2016 where there should be no internal hub, installed all software: same error:
heimdall detect: Failed to detect compatible download-mode device.
heimdall flash Failed to access device. libusb error: -12

I will now try to fix the libusb issues. Maybe even boot Ubuntu from a flash-drive.

1 Like

I installed libusb-win32 and libusbkvia Zadig. Rebooted. Tried again. No change in the new log file. I’ll now flash a brand new bootable Ubuntu USB which will take some time, as I have to download at least 13gb of software

A silly question (Samsung S8) have been quite problematic, hence this device lagging in /e/ version, and dropped in LineageOS – do you actually see the device in Download mode at this point?

Ok I managed to get into Teamwin using Ubuntu :tada:
But easy-install does not continue after “Do not install” after “Format Data”. The data format log shows Failed to mount /preload (Invalid argument). Also /usr/libexec/gvsf-mtp crashed.

I now need a break and will read the logfile soon.

As I am really inexperienced with Linux/Ubuntu, I really appreciate anyones help

So now I would change to manual instructions. Now that you have TWRP you have liberated the device!

Just pick up from

Installing /e/ from recovery

You will need platfom tools on the PC: https://doc.e.foundation/pages/install-adb

For one job you might omit Add the path to you PC configuration from the lower part of the page, but remember to use the command as instructed

yourPCName@Desktop:~/platform-tools$ ./adb devices

with the emphasis on ./

@sebi Edit on a very valid pointer from @piero, if you are running Ubuntu from a live stick with no persistence you do not want to be using adb.

The /e/ image is more easily flashed by

  • copying it to the device or SD Card,
  • Boot into TWRP Recovery
  • Install
  • Select Storage
  • Navigate to your /e/ image
  • OK
  • Install image

If this is terse / unclear please ask again. Thanks @piero

1 Like

Booting ubuntu (or another debian based distribution of Linux)
from an USB stick is a very good idea, that I should dare to recommend for installing /e/.

Now, as TWRP is already installed, you can jump to step (8) of my guide,
the easiest part : install /e/

Thanks for the advice!

I’ll try it with a SD-Card soon.

Maybe the e.foundation could provide bootable linux image instead of the Java-based easy-installer which could overcome such issues. This is probably is more development effort, but would be platform independent. There is a checkra1n jailbreak called bootra1n which worked really well for me a few years ago

SDcard is not mandatory, you can paste the zip into the internal storage, but after the Wipe step !

1 Like

It worked flawlessly :tada:

Thanks for the quick and awesome support!

1 Like