Unlocking Bootloader on Xperia Z3 compact

Xperia Companion doesn’t have a section for drivers. I just used it to upgrade the software. As far as Xperia Companion is concerned the device is a Sony sa0111. That’s what it shows up as when it’s on while plugged in. That device already has the best driver.
However when I plug it in in Fastboot mode, it shows up as S1Boot Fastboot. That doesn’t have any drivers.
I am still having the same problem manually updating the driver when I use that Xperia Z3 Compact driver from Sony.

I am just looking at this as a documentation issue! :slight_smile:

I will assume you are basicly following /e/ documentation here.

Error #1 in documentation: “following the steps under the Basic Requirements”: Basic Requirements does not exist below.

Can I be clear, the bootloader is not yet unlocked?

And for you this still an unknown?
Warning: Before following these instructions please ensure that the device is on firmware version 23.5.A.1.291.
To discern this, you can run the command adb shell getprop ro.build.display.id

So reading at the heading: Unlocking the bootloader
we are referred to a Sony developer page

Can we be clear if or where you fail on that page.

I have the same issue. Try again to update (chose another option/driver) the S1Boot Fastboot that appears in Device Manager when you connect the z3c in fastboot mode.
I think one driver showed me 2 options: “adb” or “adb composition” or something like that. I choose adb and it worked. After that, in “fastboot devices” it appears in list.

Then I have another issue, also to be later updated in manual. The “fastboot flash boot recovery.img” whas not working: It returns “couldnt parse partition size 0x”. To make it work, as some posts that I found sugested, I did this: “fastboot flash:raw boot recovery.img”.

Exactly, I am following that documentation and noticed that the Basic Requirements do not exist.
The bootloader is not yet unlocked.
I successfully upgraded the firmware to 23.5.A.1.291.
On the Sony developer page, on step 2, I clicked the link to USB drivers.
Then I clicked the link to OEM USB Drivers
From there I clicked the link to Sony’s drivers. Xperia Z3 Compact driver. (The forum won’t let me post the link because new users can only post 2 links)

I downloaded it and when the device is in Fastboot mode, it shows up in Device Manager with a yellow exclamation point showing that it has no driver. I click on it to update the driver and select “browse my computer for drivers”, click on the file where the driver is, and Windows can’t find the driver.

aleam, I don’t see any options in any driver.
(I am new to this forum. How do I reply to a specific user like you did to me?)

I just click in the “reply” under your post. If you put my name after
“@”, you will mention me, like @Nifalti

I don’t know exactually how it will appear to you, but after you choose “update driver”, in device manager, click in “look for driver in my computer”. In the next window, don’t use the “look for driver in this folder”. Insted, use the option “allow me to choose in a list of available drivers” (my is in portuguese). In “types of hardware” list in the next screen, leave the option in “show all available devices” and, finally, choose the option “with disk”. Select the driver file and chose the model (I think “Adb interface driver” worked).

This is what I get after clicking “update driver”.image
Where is “with disk”?

Continue. Click in next

And now it is flashing =)
The e-recovery worked fine. It has the “wipe cache” and “wipe system”, as well the “format data”.

After I did this wipes, adb sideload (in e-recovery - “apply update”) work fine.
Trying now.

1 Like

Congratulations on getting that done! I was just about to reply to your earlier post… :grinning:

Yeaaah =D So exited. Working great so far. Thanks

@Nifalti , share if you done (or not).

Correct fastboot command for flashing recovery on z3c (when you get to it!)

fastboot flash recovery <whatever.img>

The way I wroted (with :raw) work, but not so mutch: Im unable to enter in recovery after install…
Will do now as you posted.

fastboot flash recovery <whatever.img>
fastboot boot <whatever.img>
adb reboot recovery (without this it rests in a blanc screen)
1 Like

It worked. Now the bootloader is unlocked.
The instructions in the beginning are a little confusing.

Downloads for the z3c

The version we used for our testing was 3.3.1-z3c-20200212

In case the TWRP for you device does not exist or is not working as expected try this custom recovery

It makes it sound like only of of those downloads are needed, but I think one the the /e/ operating system and the other is the custom recovery that is needed prior to installing the OS.
Either way, after downloading the Custom recovery link, when I try to open it I get an error that the disk image file is corrupted.

In the dev link, you will find the e.img as well the e-recovery.img
Use this recovery.

Before flashing, make sure you have the factory 23.5.A.1.291

That is correct. The recovery image does the same job as TWRP. You need to populate Recovery with a recovery image.

@aleam is recommending e/recovery image not TWRP.

Then the newly populated Recovery will do the job of flashing /e/build as the main OS of the device. :smile:

How do I download the e-recovery image? When I click on the link it shows a huge file that starts with this:

ANDROID!:ùY��€��²P����������ð���à�������R�����������������androidboot.hardware=qcom msm_rtb.filter=0x37 ehci-hcd.park=3 dwc3.maximum_speed=high dwc3_msm.prop_chg_detect=Y vmalloc=300M buildvariant=userdebug����������������������������������������������������������������������������������������������������������������������������

And as @chrisrg wrote, use this for flashing recovery on z3c:

fastboot flash recovery <recovery.img>

And then:

fastboot boot <recovery.img>

After that, in my z3c, it stayed in a blank screen (in adb mode). So, I did:

adb reboot recovery

If this worked fine, you will boot into recovery. If the recovery.img that you flashed was /e/ recovery (downloaded from dev), enter in the option (with the volume keys) “factory reset” and do the format data, cache and system. Then go back in menu (arrow up left) and go in the “Apply update”. Then, in the terminal in your computer, “sideload” de /e/ image:

adb sideload e-0.15-q-20210312105636-dev-z3c.zip


Then power off the device by unplugging.

Now boot up the recovery that you have just flashed by holding vol down and power button until phone vibrates: let it boot into recovery.

Plug the phone back in again.

Then you can follow @aleam’s instructions in the post above to complete the installation.

Good luck!

When I type in:
fastboot flash recovery recovery-e-0.15-q-20210312105636-dev-z3c.img
I get an error that says
fastboot: error: cannot load ‘recovery-e-0.15-q-20210312105636-dev-z3c.img’: No such file or directory

Sounds like EITHER you didn’t download the recovery from here https://images.ecloud.global/dev/z3c/. You need to download both these files

OR you are not running fastboot in the same directory as you downloaded the recovery image. In which case, you should either cd to the directory containing the downloaded files before running fastboot flash recovery ... or copy the downloaded files to your current working directory.

Hope that helps