[UNOFFICIAL BUILD] /e/OS Q [Android 10.0] for Samsung Galaxy J5 2016 (j5xnlte)

New build is here!!!
-Removed weather and browser apps
-Replaced outdated WebView with Bromite WebView

The browser removal and WebView replacement are temporary, when /e/ developers update them i will revert the changes (the weather app removal is permanent until I change my opinion about it)

Please some forum admin move this to custom builds section.
Thanks in advance.
The Penguin

I used this Rom, it is so cool
but I need Google play and google play service for some app
how do I install it?

play services is not recommended and replaced by microG.

you can check if your app is supported here:

I was very happy to find this rom. Have been using it for a week now and the only issue was with the dialer. When i started a call, the app crashes leaving the call still running. replaced with simple dialer and it’s fine.

thanks for your work

The dialer thing is weird because it never crashed for me, as soon as /e/ devs update the browser app i will make a new build.

Ok, i just made a new build and i added all the apps i deleted before, i also synced prebuiltapks with aayush_test branch which has the browser and webview updated, enjoy people!

1 Like

New build with official browser update, enjoy!

New build is here!!!
-April security patch

I had to edit contacts app Android.mk to fix build errors, sorry for the delay (the contacts app works fine)

New build is up!
-May security patch
-Updated to 0.17 version

Sorry for the delay

Hi @The_Penguin, do you plan futher updates for this model? Is it safe to use the last update of May '21 or is it too old?

As a general remark, it’s kind of a pity that J5 500FN is officially supported (on which I installed /e/ already) but this dual-sim brother of it is not :confused:

I did a Q build for this device:

Hi ronnz98, I tried your build using this procedure [HOWTO] Install /e/ on a Samsung smartphone with Windows easily , everything installed fine with no errors until the e os animation screen (9), where the battery is making a constant vibration of about 2-3 seconds leading to a phone reboot.

I have used Odin3_v3.14.4, twrp-3.7.0_9-0-j5xnlte.img.tar , and your build e-1.15-q-20230913-UNOFFICIAL-j5xnlte.zip

could you try using twrp 3.3.x-x
(twrp can install it, Odin is not need)

if don’t work, try using the recovery-e that is included in the .ZIP
(twrp can install it, Odin is not need)

are you sure baterry is charged enought ?
(it don’t charge when on download mode)

HI piero, thanks for your help, I tried it with twrp-3.3.1-1-j5xnlte.img.tar and twrp-3.4.0-0-j5xnlte.img.tar, same results, the phone restarts after the e/os animation and a vibrating of ~2 seconds. Battery is ok, it was around 70-85%.

I searched for the recovery-e in the .zip but is seems it is not included in the latest .zip, nor in OP’s original: :confused:

unzip -l e-1.15-q-20230913-UNOFFICIAL-j5xnlte.zip
Archive:  e-1.15-q-20230913-UNOFFICIAL-j5xnlte.zip
signed by SignApk
  Length      Date    Time    Name
---------  ---------- -----   ----
      357  2009-01-01 00:00   META-INF/com/android/metadata
786538275  2009-01-01 00:00   system.new.dat.br
        0  2009-01-01 00:00   system.patch.dat
  1609304  2009-01-01 00:00   META-INF/com/google/android/update-binary
     1316  2009-01-01 00:00   META-INF/com/google/android/updater-script
  8126480  2009-01-01 00:00   boot.img
     1028  2009-01-01 00:00   install/bin/backuptool.functions
     2233  2009-01-01 00:00   install/bin/backuptool.sh
     9814  2009-01-01 00:00   system.transfer.list
     1675  2009-01-01 00:00   META-INF/com/android/otacert
---------                     -------
796290482                     10 files
unzip -l e-0.11-p-20200908-UNOFFICIAL-j5xnlte.zip
Archive:  e-0.11-p-20200908-UNOFFICIAL-j5xnlte.zip
signed by SignApk
  Length      Date    Time    Name
---------  ---------- -----   ----
      341  2009-01-01 00:00   META-INF/com/android/metadata
588278079  2009-01-01 00:00   system.new.dat.br
        0  2009-01-01 00:00   system.patch.dat
  1345388  2009-01-01 00:00   META-INF/com/google/android/update-binary
     1327  2009-01-01 00:00   META-INF/com/google/android/updater-script
  9136144  2009-01-01 00:00   boot.img
     1028  2009-01-01 00:00   install/bin/backuptool.functions
     2514  2009-01-01 00:00   install/bin/backuptool.sh
     6085  2009-01-01 00:00   system.transfer.list
     5526  2009-01-01 00:00   system/build.prop
     1675  2009-01-01 00:00   META-INF/com/android/otacert
---------                     -------
598778107                     11 files

Sorry, i throught it is in all recent build,
But it seems to be only in T or S versions

Apparently Roland (ronnz98) created another, newer build which installed fine, and works flawlessly from what I see so far. Big thanks @ronnz98 and piero!

1 Like

Thanks for the feedback. Great to hear that it works!
I forgot to post the lasted update for version Q 1.17 also here, please see main post:

Since Q reached end of life this will be last version. For R I could not build, but maybe someone wants to try this.

1 Like

I had to go through a few boxes to find the old devise on which I had a problem like that and found a Galaxy A3 2016 that did that, too! I put a note on it 4-5 month ago.

And funny enough, it still did it today.
It was after a factory reset on stock Android 7 and it stayed on the Samsung boot logo, vibrating…

My SOLUTION: After I left it for +1h doing it… I unplugged it from the charger and it booted right away.

So, did you have yours on the charger, too?

Hi, no I didn’t have it on the charger, as I said above it was the newest build that only worked for me.