[UNOFFICIAL BUILD] Lenovo Vibe K5 / K5 Plus (A6020)

Device info https://wiki.lineageos.org/devices/A6020
Rom https://www.androidfilehost.com/?w=files&flid=299861

Please Note: This is an Untested build. Please try at your own risk.

I made an update for this device, enjoy :slight_smile: :

e-0.9-n-20200703-UNOFFICIAL-A6020.zip
TWRP : https://dl.twrp.me/A6020/

Don’t forget to backup and share your experience, thanks :wink:

Dont clean flash, Error 7
A6020a40 SD616

Welcome in the forum :slight_smile:

I guess you used the last version of TWRP (3.4.0) ? It’s a known issue, use the TWRP 3.3.1 version instead.

1 Like

Yes, I used the last version of TWRP (3.4.0)
Thanks, 3.3.1 works.

1 Like

good day!
thanks for your hard work.
good firmware
no fucking google …
i found a bug.
poorly detects my location on gps and mobile networks.
works well when I turn on wifi.
could you please fix this?

Hello, welcome in the forum :slight_smile:

Thank you for your feedback. Sadly I only build, I don’t develop or debug so I don’t know how to fix anything.

If the location is not the one you expect, try to change the location mode from “High accuracy” to “Device only”. Or even “Battery saving” if you only need location in a town/city.

I understood, thanks for the prompt reply.
I’ve already done all of the above.
Works only with wifi, but everywhere it is.
here in this firmware everything works completely…https: //forum.xda-developers.com/k5-plus/development/rom-lineageos-14-1-vibe-k5-k5-sim-t4009823

can try to replace the system files from this firmware?

The author recommends in the link you shared to build with sources on LineageOS github, and that’s what I did. Normally it should work very well (normally).

I’m understood, thank you!
but fact lags behind fact.
in the firmware that I reset everything works.
maybe the developer changed something.

Indeed looks like LineageOS sources aren’t always the better choice.
The sources from adinechin are more recent.

I still haven’t decided what I will do between :

  • Rebuild a nougat version
  • Wait a few days a build the Oreo version.

Stay tuned.

super! thank!
but I am already an expert in firmware))) on a6020, I tried a bunch of firmwares and 8 and 9 and 10.0!
but 7.1 is the most stable LOS based firmware!

Therefore, I am for reworking 7.1 with both hands!))
and then Oreo)

Just to update you, the build process doesn’t start even after I reinstalled Debian. I will try to build for the one that is already available (so with LineageOS sources) to know if it starts or not. If yes, there is an issue with the sources, if no there is an issue with my build environment.

Thank you very much for your work.

Sorry but you won’t have the Nougat build you want. The build process starts with LineageOS device tree but not with adinechin device tree and I don’t know and don’t have the time to debug.

nothing wrong!
thanks anyway for your hard work!