[Unofficial Build] Moto G7 play (channel) eOS - Q build

A new up-to-date unofficial Q-build for Moto G7 play.

Device info : https://wiki.lineageos.org/devices/channel


I don’t own the device so as usual, be safe and make a backup first. Enjoy and share your experience.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Thanks! I tried to make my own build for Channel, but the docs must be a bit out of date for Q builds; neither the docker nor the non-docker methods worked.

Would you mind creating a new build with a newer snapshot of the LineageOS nightlies? I flashed the 10/25 build of LineageOS before realizing your build was the 10/24 build, and now it complains that I am trying to downgrade. It probably won’t hurt anything, but I would like to eliminate as many variables as possible. Thanks again!

Building right now.:stuck_out_tongue_winking_eye:

1 Like

Thanks for the build, @itsclarence! LineageOS didn’t complain about downgrading with this build, but the update did not proceed. I am using the LineageOS recovery because the Moto G7 Play has no official TWRP available, and I think Lineage Recovery is very limited in what ROMs it will install, so think I will need an unofficial TWRP to install /e/; there are a couple available on XDA, but I need to proceed carefully so I don’t brick the phone getting everything configured. Hopefully I can get it all working in the next day or two and I’ll post my results here.

1 Like

Itsclarence, I finally got the build to install! So far, everything works perfectly, but I’ve got a few hardware pieces to verify. Fingerprint scanner, LED notification, location, camera all work. I had to use an unofficial TWRP from XDA to get it flashed using the adb command-line. Now that it has flashed, the /e/ recovery is installed so future installs should be easy.

I really need to figure out how you set up your build environment so I can make these builds myself. In the meantime, is there a way to extract out the /e/ recovery image from the build? That would close the loop and not require a half-working TWRP to bootstrap the install.

In the meantime, for the “pics or it didn’t happen” audience, here is a screenshot of /e/ running on a Moto G7 Play (channel) XT1952-4:

I am looking to install /e/ on a Moto G7 play but I’m a bit of a newbie to this. Any update on your efforts that you could share to help me be successful in my efforts? Also, would anyone know if the G7 Play will soon be a supported build?

The unofficial build works on the Moto G7 Play (channel) and all the hardware works. There are a few issues with this latest version of /e/ that are likely unrelated to the Moto G7 Play, however. The “Q” release is quite new so I’m sure those will be resolved in time. For instance, the light-mode theme has several problems such as the calendar buttons are not visible (but they work). I think I noticed similar issues with other apps. Since this is my daily driver, I opted to install LineageOS + MicroG in the meantime.

You may want to start with a stock LineageOS or LineageOS + MicroG since they both have recovery images available. For /e/ on the Channel (as of now), you have to use an unofficial TWRP in command-line mode to get the first /e/ install running. After that, updates are fine.

This was my third time installing a custom ROM on a Motorola device, and while my Moto G and Moto X2 were easy, this one fought back the most, probably because the Play is just not as popular as the other units and so supporting software is more limited.

Following the documentation for the Moto G7 (download twrp for Moto G7 Play), the installation worked smoothly and I don’t have any issue until now. I ll check further and keep you updated here…

:slight_smile: Its build worked perfectly for my device. Could you update your construction to Moto g7 play (channel) ?

if anyone wants to test :slight_smile:


Is there a backup of this build? The link appears to no longer be valid.

since the official /e/ channel images work, why would you want to go for a 0.18-q build?

Because the option to use Moto gestures to turn the flashlight on and off with the chop-chop option is “on” but isn’t doing anything. I’ve asked for help on this in a thread where I located where another user on Lineage had this issue and it was fixed and linked it in that thread. It’s been eleven days and no response. So I’m trying to find something that works.

This build (though older and unofficial) apparently is fully working. So I’m wishing to try to see if that solves my issue. That will indicate that something between this release and the official release was broken and that can at least provide some information on the issue.

ah ok I see, I followed up there - Shake to activate flashlight - #11 by tcecyk

1 Like