[UNOFFICIAL BUILD] Pi/e/ test ROM for Xiaomi Mi MIX 2S - "polaris"

BETA! Use at your own risk. See warnings/information/hints from cheeseburger (Oneplus 5) thread:


Today,Oneclickroot tried to flash the latest unofficial build of polaris on my Xiaomi Mi Mix 2S,but that didn’t work out.The phone get stuck in the “controlling for updates”.
Then they wanted tot install Lineage,but my phone got stuck in the booting.So they had to flash stock ROM again.Sad and again i can’t leave google.
What’s wrong with the flahing of the /e/ROM?


I have no idea what “controlling for updates” could be? Do you have a Screenshot by any chance? Is that before, during or after the flashing? Did the phone boot?


I don’t have screenshots.The phone controlled for updates after it was booting.It was like when they flashed stock ROM and google is looking for updates,before getting set up.

Never heard of issues at this step. If there are connectivity issues for whatever reason it sould timeout eventually.

I’ve install the last update on the last of august today and my device never boot on system after the install. I had Magisk installed on it. I am completely stuck with TWRP… Any help would be welcome!

Does anybody have saved the last version of august and can put it somewhere on the net?

Is it maybe still in /data/lineageos_updates (check via twrp)? It should reside there unless you explicitly delete it from updater app

unfortunately, I’ve removed everything on my device… But after further test, I thing we have a bug on this image since it builds again. It could be great to put back the last image of august on the server if possible, I cannot use /e/ anymore sadly

I’ve tried lineage-16.0-20190807-nightly-polaris-signed.zip and it is working but there is no update of lineage since… I think this is the last build I had before I broke my device yesterday.

It seems to be a problem of firmware version.
@thilo Do you know the firmware version needed by the last image ?

In case it helps anyone, I am running e on a Polaris (Xiaomi Mi Mix 2s) after trying for weeks.

ROM is the unofficial build from Oct 19 above


  • clean installed Miui 11 (Pie based)
  • restart to system
  • restart to fastboot
  • install TWRP via fastboot
  • boot to twrp
  • Wipe -> format data
  • reboot to recovery
  • wipe -> system + cache
  • install ROM via adb sideload
  • reboot to recovery
  • reboot to system
1 Like

UNTESTED build (I don’t own this device) : https://www.androidfilehost.com/?fid=4349826312261805491

1 Like

Any1 interested with a new Pie build ?

New build here : https://androidfilehost.com/?fid=8889791610682879690

Kindly TESTED by a owner :slight_smile:

Built with “community” /e/ Docker engine, using v1-pie branch.

NB : just made one change : reverted LOS fingerprint “patch” to Pie, in order to make it work (tested). Repository : https://github.com/BallonLac/android_device_xiaomi_polaris
According to rules it should remain an unofficial build, not a custom one.


<?xml version="1.0" encoding="UTF-8"?>
  <project name="BallonLac/android_device_xiaomi_polaris" path="device/xiaomi/polaris" remote="github" />
  <project name="LineageOS/android_kernel_xiaomi_sdm845" path="kernel/xiaomi/sdm845" remote="github" />
  <project name="LineageOS/android_packages_resources_devicesettings" path="packages/resources/devicesettings" remote="github" />


<?xml version="1.0" encoding="UTF-8"?>
  <remote name="muppets" fetch="https://gitlab.com" />
  <project name="The-Muppets/proprietary_vendor_xiaomi" path="vendor/xiaomi" remote="muppets" />

Build script

docker pull registry.gitlab.e.foundation/e/os/docker-lineage-cicd:community
docker run \
-v "/srv/src:/srv/src" \
-v "/srv/zips:/srv/zips" \
-v "/srv/logs:/srv/logs" \
-v "/srv/ccache:/srv/ccache" \
-v "/srv/local_manifests:/srv/local_manifests" \
-e "BRANCH_NAME=v1-pie" \
-e "DEVICE_LIST=polaris" \
-e "OTA_URL=" \
-e "REPO=https://gitlab.e.foundation/e/os/releases.git" \

Looks like the official Pie for Polaris is one step away from the release. Is anybody testing it already?