[UNOFFICIAL BUILD] Samsung Galaxy S6 Edge (zeroltexx)

Device info https://wiki.lineageos.org/devices/zeroltexx
Rom https://www.androidfilehost.com/?w=files&flid=300805

Please Note: This is an Untested build. Please try at your own risk.

@Unknown’s → e-0.7-o-20191017-UNOFFICIAL-zeroltexx.zip

@enesuzun2002 | Enes Uzun
Samsung Galaxy S6/Edge Developer on https://github.com/enesuzun2002 | on XDA-developers
New LineageOS 16.0 Build [UNOFFICIAL] 23-11-2019
TWRP 3.3.1-0 Modded for OTA support
G920F/FD/I/S/K/L = zerofltexx
G920T/W8 = zerofltecan
G925F/FD/I/S/K/L = zeroltexx
G925T/W8 = zeroltecan
Flash this TWRP incase you want to install updates for LineageOS 16.0 through OTA app.

A new eOS-Q-build for the Samsung Galaxy S6 edge (zeroltexx)

Device info : https://wiki.lineageos.org/devices/zeroltexx

This build is tested by @Bryophytae.
His feedback you can read here.


Again, many thanks to @Bryophytae for testing this build.
Nevertheless, be safe and make a backup first. Enjoy and share your experience…


Is it normal for these links above to take me to a page telling me I don’t have permission to access them?
I am logged in! :slight_smile:

I’ll adjust the link.

1 Like

Thanks so much for a rapid and effective response.

1 Like

Just to let you know that I downloaded and flashed this image without any issues and everything works for me other than occasional glitches with the Camera (opencamera). I don’t think I have any problems with calls, but don’t make that many given the terrible Cell coverage around my area!
I have yet to experience any other issues so, again, thank you very much for your hard work in bringing this about.


Dear all,
I have also installed this build (thank you very much @itsclarence)
I was using the previous working version before the bootloop issue (e-0.7-n-2020021541379-dev-zeroltexx.zip see issue on GitLab).

Everything was working properly with this unofficial build, until I tried to encrypt my phone (then the phone entered a bootloop presenting only the Samsung Galaxy screen at boot then rebooting again). I tried a second time and faced the same issue.

I have just reinstalled it a third time and will use it without encryption, although I would have preferred to get my phone encrypted.

Does anyone have any clue on what the problem might stand ?
Best Regards,

1 Like

Just one, relatively minor, issue I have been experiencing. My call volume, earpiece or speaker, is very very loud and I have no apparent control over this. I have ensured all the available settings are down to minimum and still IU find myself holding the phone away from my ear during a call.
Is this just my phone or are others experiencing this?

1 Like

Hello @remi-e,

I also encountered this problem when trying to encrypt my phone. I suppose other building sources would have to be used in order to make it work, or maybe it is not possible at all for this model, I do not have the proper knowledge to answer you. I want to point out that encrypting on Oreo also resulted in a bootloop.

My advice is not to leave any data that you would not want accessed should your device be stolen. @itsclarence tried various build sources before succeeding with this Q build. He invested quite a bit of time to bring it to fruition, and for that we can be really thankful.

Of course, it is not 100% perfect, but nevertheless better than Nougat. Maybe one day those problems will be solved, we’ll see.

So far, what could be improved:

  • SELinux status is not enforcing, which is a security liability
  • encryption causes a bootloop
  • the build is signed with public keys
  • an echo during phone call (only on my device and another S6 user apparently, which I was able to fix)
  • @jpirie mentions a very loud call volume on his device. Maybe tweaking the mixer_paths_0.xml file as mentionned in the post I linked could be a way to solve this. What is left to do is finding which line of code in this file should be edited to solve this volume issue. The echo fix also had the effect of lowering the call volume for me, but I do not know if that would solve @jpirie’s problem.

This build is a great way to show that /e/OS Q can run on the Zeroltexx and Zerofltexx, and I sincerely hope @itsclarence and other ROM builders will attempt to improve it. Once again, let us all be thankful to them, because we would not be having this discussion otherwise.


Thank you for your feedbak @Bryophytae

Let me be clear, if this was not the case before : I am very thankful for the job done by @itsclarence, I was very annoyed that Nougat version was not maintained anymore and was thinking of leaving /e/ for this reason, this Android 10 version is really great and I can only imagine the amount of time it took to get it working !

Best Regards,


I did not at all intend to imply that you were not thankful, apologies if it was perceived as such ! Communication by text sometimes makes it hard to convey what we feel precisely.

Also, giving feedback as you did is exactly what is needed to improve things, so cheers mate :smiley:

1 Like

I hope I have also made my absolute respect for @itsclarence and yourself for the work required to bring Android 10 to an abandoned handset? If not, that’s just a mark of my communication failure :wink:
As for the volume issue, I don’t make or receive a lot of calls so this is not a huge problem but It would be better if it could be fixed.
The fix you mention for the echo in call issue I didn’t tackle because I have no echo…isn’t technology fickle? :roll_eyes:
If the mixer_paths_0.xml file does turn out to be the root of the problem then, of course, I will be getting my sleeves rolled up and the phone rooted to have a go I am thus inspired by your efforts :grinning:
So, keep at it, know you are appreciated and envied for your skills.
All the very best from the Highlands of Scotland
And have the best festive you can manage under whatever restrictions you will no doubt be under.
James x


Hi all,
Today I rooted my phone and applied the fix you mentioned here.
The outcome is that the call volume problem has changed but, I wouldn’t call it fixed as such.
The call volume is now reasonable in a quiet room but, I’m not sure whether I would hear the caller if there were a lot of background noise, in other words, I have no control over the call volume although it is now much quieter.
So, I suppose what we need to identify is which setting in the file relates directly to the earpiece volume and perhaps raise that a little but, more importantly, find out why there is no apparent control?
The call volume indicator moves up and down correctly when the volume keys are operated but it has no actual effect on the volume.
Baby steps :smiley:


1 Like

As a P.S. the volume controls work as expected for the music playback pathway so this is targeted at the call volume only.

1 Like

Indeed this is my experience as well @jpirie. I also applied the fix offered by @Bryophytae, but the echoes continued for me. :slightly_frowning_face:

Now, with that said, there is NO echo when I use Signal or Telegram for voice calls, only calls through the “normal” dialer app- so that’s what I use. :sunglasses:

I have been using this /e/ [UNOFFICIAL BUILD] on my S6 now for about a month and it is excellent- it is snappy and responsive, even more so than the Official /e/ Q build loaded on my S9, believe it or not! Perhaps that is related to SELinux not currently being enforced, I don’t know.

I have applauded and thanked @itsclarence privately for his skill and work in making this build a reality, here’s one more to him! :beers:

1 Like

For the Galaxy S6 (zerofltexx) I made this here:

Ah yes, @SuzieQ, you are correct! I posted in the wrong thread LOL! This should’ve gone there.

Need more coffee apparently… :slight_smile:

Good work may be praised at any point!