[UNOFFICIAL BUILD] Samsung Galaxy S6 Edge (zeroltexx)

Another interesting, though surely unrelated, development.
Today I had cause to leave my house (Imagine the excitement?) Anyway, I realised quite early on that my phone had no signal, showing emergency calls only and a cross under the signal strength meter depicting no data.
I was in an area with a strong 4G signal so this is odd. My crew partner had a full EE 4G signal so I am now very confused?
I restarted the phone and still the same. About half way home, presumably at the transition point between two cell masts, I received a message on Signal but, when I stopped to see what had changed I was back to ‘Emergency calls only’
At home the phone works perfectly with data and phone calls BUT, and this is the difference, at home I use an E.E. Femtocell box so not an actual cell mast.
I’m sure this must be somewhat different, if only from a range point of view? I had considered that perhaps something has gone wrong with the antenna system?
Anyway, just in case, by some miracle, this has happened as a result of my tinkering s yesterday, I changed the name of the file I altered and put back the original so now I am back to very loud call volume and I shall report back about the cell reception when I next get an opportunity to test it.
This is quite bad news because, there are many things one can overlook when using a good Custom ROM but no network connection out of the house is not one of them unfortunately :frowning:
If anyone has any ideas please shout but, since no one else is experiencing this issue, I suspect this may be isloated to my handset and might be nothing to do with the ROM.


Okay, so the echo fix seems to only work on the S6 Edge then. At least we know now. I think we’re all clearly out of our depth here :laughing:

The xda member who commented in the xda thread and edited the xml file that I used is named Johannesdavidsen. He seems to know what he is doing.

Maybe you could try contacting him so that he explains which lines to edit precisely to fix both echo and volume issues.

Now about the network connection, I encountered no problem with my S6 Edge, no idea why that would happen.

I also have an S6 Edge though? But I had no echo problem.

I suspect that the network issue is unrelated however. I remember when
I put a new battery in this handset that I initially forgot to remove
the SIM tray and may have damaged something internally that I am not
aware of :frowning:

It does, occasionally, report “No SIM” when I have just changed the SIM
so this would support my theory.

I’m definitely in over my head but I feel it’s been a valuable learning
experience. I can always go out and buy a second hand S6 (or better)
that has e support and start again :slight_smile:

I’ll give that contact a shout and see what comes of the conversation,


1 Like

Oh yeah right, S6 Edge, I got mixed up from another thread about the S6. This is even more confusing if it is the same device. I also opened mine to change the micro-usb port, so maybe our tinkering had an impact, who knows ?

So, I went to the link you gave me and I found that Johannes has already addressed this issue with another user. I feel kind of bad bugging him again when he assumes he has already dealt with it :confused:
I found this though and wondered if you might be able to figure out what needs to be done do I just open the existing file in an editor and search for the relevant part and substitute them?
I can always put the old one back in I suppose? It’s just, there are so many duplicate entries that it’s difficult to know which “volume” is the one I need :confused:
I would appreciate your input after reading this post and, if it’s the same place you copied your file from then we are back where we started :wink:
Thanks for anything you can offer :slight_smile:

Yes, that’s exactly the reply I copied the xml file from, which allows to fix the echo issue. What I was suggesting is that you ask him which lines to edit for your loud call volume issue. In this post, I explain how to find which lines were edited for the echo issue, which yielded a file that lists the original and edited lines in order to compare them.

I suspect the loud call volume can be fixed by editing one of those lines in the xml file, but I don’t know which one. I will gladly try to help you with this in a few days when I have more time, but for now I have exams to revise.

Cheers :grin:

1 Like

Ok, understood, you have to get your priorities right :slight_smile:

The post does open with this line though:
"Hi you can fix high volume problem or say echo by editing: /system/vendor/etc/mixer_paths_0.xml
I’ve used MTmanager app after rooted with magisk "
So I suspect he is aware that my problem exists :slight_smile:

No rush, as I say, I don’t get too many phone calls anyway. My more immediate concern is why the network fails outside of my home.
I currently have a full signal marked “H” and am transferring data with WiFi switched off so the hardware clearly works! It’s very odd indeed.

Happy studying

I updated this build with a lot of changes.


You absolute legend, thanks !

If I may, I found this xda thread that mentions a Lineage 17.1 build for the Galaxy S6 (Zerofltexx) with SELinux set to enforcing. Maybe it could be a way to improve the security of the S6 build.

Thanks again and have a great day :smiley:

1 Like

Hi there everyone,
I mentioned in another thread, which at the time I thought was this one, that my phone dialer fails after flashing the latest version of this ROM package (14)
I tried to downgrade to test it but that wouldn’t work, it flashed ok but the OS refused to open from the lock screen?
So, I went back to the V14 ROM and tied again. Still the same.
If I try to dial a number from the contacts I briefly see the dialer screen pop up and then it disappears. The call is set up and is successful however but i have no further control over it so, can’t hang up!
I’m beginning to think that, once again, my phone is special and no one else is experiencing this otherwise I feel it would be being talked about :slight_smile:
I have a work around in place by installing Simple Dialer which works but is a little messy as it then drops me back into the original phone app and leaves itself open in the background. The call is terminated however which is good :slight_smile:
@itsclarence I wonder if you can shed any light on this behaviour or is my phone faulty? It all worked fine wit the last (first) release so it’s disappointing.
Thanks again for your efforts and, hopefully, you can solve this one for me.


Do I understand your procedure correctly: You’ve installed ‘Simple Dialer’ in addition to the pre-installed TeleService ‘com.android.phone’?

Hi SuzieQ,

                     Yes, it's what the app is designed for, like I 

say, I’ve used it in the past but didn’t like the way it displayed
information in the call log:

So, it takes over dialling duties from the stock phone app and you get
the choice to revert to the old one if you want. I also use a
substitute launcher in this way.


Yeah @jpirie, I use the whole Simple Mobile Tools Suite, so also the Simple Dialer. However, I don’t get the apps from the G-Play-Store but from F-Droid.

In addition, I’ve deactivated the pre-installed TeleService aka ‘com.android.phone’ at system level. The same applies to the SMS Message app aka ‘foundation.e.message’.

The phone dialer also is buggy on my phone in this v.14 build, so it’s not your device that is at fault.

I hesitate between reverting to the previous build or using the simple dialer too.

Slaps head :slight_smile: Imaging thinking you didn’t understand what simple dialer was :slight_smile:
Sorry, I’m not paying attention, of course you all do!
I’m the one who needs the help remember :wink:
So, in actual fact, the built in dialer/phone app provides me with the information I require to track my telephone calls. Although I get very few they are mostly all work related and I need to know when I was called to make up a time-claim at the end of the month. Is there an absolute need to disable it or can I run them in tandem the way they are at the moment without causing any issues?
As things stand, I can make and receive calls via simple dialer and then retrieve the time information via the phone app and all is (sort of) well
I also get my apps from FDroid where I can and only when that fails to provide the app I need, do I move out to the built in Apps store and, finally, aurora store.

Hi @anon95995175,
I was not able to revert, well, I couldn’t get past the security login/fingerprint sensor after re flashing V13. I had previously experienced such things when initially jumping from the official build to this one where, after flashing the unofficial one based on Android Q my phone would not boot past the bouncing E logo.
I was advised at the time to wipe the phone during the flash process and it would work. It did, but I had to re install all my apps and I didn’t have the time to do that this time so I went back to V14 and installed Simple Dialer. It seems to work as I’ve already explained to @SuzieQ (unnecessarily) so, for now, I’m happy enough with this as a temporary solution.

1 Like

As a Postscript to my previous reply, I wouldn’t know how to uninstall the built in apps so that is something for another day I guess :slight_smile:

A new build for the zeroltexx. Cooked with february security patch and on some updated repos from @enesuzun2002.
Unfortunately this rom isn’t builded with private key’s (yet)


:soon: That yet in round brackets sounds promising. :boom:

Hello, I am testing the “e-0.15-q-20210220-UNOFFICIAL-zeroltexx” rom.
I find it really great, but there is a big drawback, the applet application keeps stopping in a loop when you want to make a call :frowning: