I’m not sure oft it’s future, as /e seems to drop it from the supported list for newer Android versions.

I have 2 or 3 unused ones, plus one on /e R which I like a lot and having S or T would be great.

Just had a look:

Yes, but Android R (LOS 18.1) is the latest version for LineageOS. I haven’t seen a newer one…

There won’t be a newer one. For a number of reasons Lineage 18.1 / Android 11 / /e/OS R is the end of the line for these devices - along with the Z3 and (unofficial) Z3 Table Compact.

1 Like

Is there a set date/point when these releases will end?

@ronnz98 could/would you then build R for them for /e 1.16, 1.17… ?

No. At some point - probably when Android 14 / Lineage 21 bulids are released - LineageOS will stop making builds for 18.1 devices, so there will be no new code coming from them. /e/ will then make a decision about how long they continue to make releases of their functionaity

1 Like

have a try :slight_smile:

/e/OS-T for S20 now is available (untested!). For the S20 FE I still cannot build

Hi, I have tested the build and everything works fine (fingerprint, auxiliary lenses, wifi, bluetooth etc.). But flashing the build is really complicated. Adb sideloading the zip results in a hard brick, installing the zip in twrp results in an unbootable state where the device needs repartitioning in fastboot mode. I extracted payload.bin with payload-dumper-go and flashed the partitions individually. This didn’t brick the device and /e/ os booted just fine and worked. For some feature (e.g. fingerprint) to work, you need to flash the rom from the stock os and not another custom rom. Love your build anyway.

Additional information: the hard brick when installing the build also happened on the official lineage build (see: This probably happens because of the update zip being flashed to the inactive slot.

Todo list /e/OS-T?

□ “miatoll” - POCO M2 Pro / Redmi Note 9S / Redmi Note 9 Pro / Redmi Note 9 Pro Max

Runs with ‘official’ LineageOS 20., LineageOS-20.0-for-microG and BlissRoms 16.9

here you go:
Build for /e/OS-T-1.16

Thank you, @ronnz98 !

Samsung Galaxy S7 and S8 series new builds for /e/OS T-1.16.1 available:

Samsung Galaxy S8 (dreamlte)

Samsung Galaxy S8+ (dream2lte)

Samsung Galaxy Note 8 (greatlte)

Samsung Galaxy S7 (herolte)

Samsung Galaxy S7+ (hero2lte)

Samsung Galaxy Note 7 (gracerlte)

Hey @ronnz98, fancy a new project? I could test your ROM.

Xiaomi Redmi Pad

Mediatek Helio G99 (6nm), Android 13, MIUI 14
1200 x 2000 pix, IPS LCD, 1B colors, 90Hz
UFS 2.2, microSDXC, USB Type-C, OTG
Pixel Experience Plus Release for Yunluo (Redmi Pad)

LineageOS 20.0 for Redmi Pad (yunluo) releases

GitHub: Let’s build from here

LineageOS OTA setup for yunluo

Nothing Phone (1) update:


Pixel Tablet (tangorpro)

Pixel 7a (lynx)

Tried to build but got this error at some point:

[ 86% 135126/155337] Check prebuilt ELF binary: out/soong/.intermediates/vendor/xiaomi/yunluo/
FAILED: out/target/product/yunluo/obj/EXECUTABLES/
/bin/bash -c "(rm -f out/target/product/yunluo/obj/EXECUTABLES/ ) && (build/make/tools/ --skip-bad-elf-magic --skip-unknown-elf-machine --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libhidlbase.vendor_intermediates/libhidlbase.v --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/ --shared-
lib out/target/product/yunluo/obj/SHARED_LIBRARIES/lib_android_keymaster_keymint_utils.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libbase.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libbinder_ndk.vendor_intermediates/ –
shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libcrypto.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libkeymaster_messages.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libkeymaster_portable.vendor_intermediates/ --s
hared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libkeymint.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/liblog.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libutils.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIE
S/libcutils.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libcppbor_external.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libcppcose_rkp.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libTEECommon_interm
ediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libc.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libm.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_LIBRARIES/libc++.vendor_intermediates/ --shared-lib out/target/product/yunluo/obj/SHARED_L
IBRARIES/libdl.vendor_intermediates/ --system-shared-lib libc --system-shared-lib libm --system-shared-lib libdl --allow-undefined-symbols --llvm-readobj=prebuilts/clang/host/linux-x86/clang-r450784d/bin/llvm-readobj out/soong/.intermediates/vendor/xiaomi/yunluo/
.33_arm64_armv8-2a-dotprod_cortex-a76/ ) && (touch out/target/product/yunluo/obj/EXECUTABLES/ )"
out/soong/.intermediates/vendor/xiaomi/yunluo/ error: DT_NEEDED “” is not specified in shared_libs.
out/soong/.intermediates/vendor/xiaomi/yunluo/ error: DT_NEEDED “” is not specified in shared_libs.
out/soong/.intermediates/vendor/xiaomi/yunluo/ note:
out/soong/.intermediates/vendor/xiaomi/yunluo/ note: Fix suggestions:
out/soong/.intermediates/vendor/xiaomi/yunluo/ note: Android.bp: shared_libs: [“”, “”, “libTEECommon”, "lib_andro
id_keymaster_keymint_utils", “libbase”, “libbinder_ndk”, “libc++”, “libcppbor_external”, “libcppcose_rkp”, “libcrypto”, “libcutils”, “libhidlbase”, “libkeymaster_messages”, “libkeymaster_portable”, “libkeymint”, “liblog”, “libutils”],
out/soong/.intermediates/vendor/xiaomi/yunluo/ note: LOCAL_SHARED_LIBRARIES := libTEECommon lib_and
roid_keymaster_keymint_utils libbase libbinder_ndk libc++ libcppbor_external libcppcose_rkp libcrypto libcutils libhidlbase libkeymaster_messages libkeymaster_portable libkeymint liblog libutils
out/soong/.intermediates/vendor/xiaomi/yunluo/ note:
out/soong/.intermediates/vendor/xiaomi/yunluo/ note: If the fix above doesn’t work, bypass this check with:
out/soong/.intermediates/vendor/xiaomi/yunluo/ note: Android.bp: check_elf_files: false,
out/soong/.intermediates/vendor/xiaomi/yunluo/ note: LOCAL_CHECK_ELF_FILES := false

Oh jeez … Thanks anyway for trying

New updates for Samsung Tab S:

Samsung Galaxy Tab S 8.4 (klimtwifi/klimtlte) klimtwifi = SM-T700 / klimtlte = SM-T705

Samsung Galaxy Tab S 10.5 (chagalllte/chagallwifi) chagallwifi = SM-T800 / chagalllte = SM-T805

Please note feedback to get it work:
after first boot let it boot for a minute then vol down power hard turn off and let it restart then it will boot to setup !

chagalllte might not work as I had to tweak recovery image size for succesful build

Samsung Galaxy Tab A SM-T380 (gta2swifi) for /e/OS-R1.16