Update FP4 to e/OS 1.5.1-s possible?

I recently saw that a e/OS based on Android 12 is availble for the Fairphone 4.
If I understood the documentations correctly, I first need to install an Android 12 based stock firmware before I can install e/OS S.
But Android 12 stock does not exist yet for the Fairphone 4.
So how to proceed?


So, If I am using e/OS R, I have to flash back to the stock Android 11, to flash e/OS S (and have to reinstall all App and restore all data and settings)?

Hi. If you are now on 1.5 stable Android 11 you just have to wait (or manually search) the OTA upgrade without any data loss.

Efit: the eOS upgrade from A11 to A12 was released on 2/11, but I finally found it on 12/11.

I am currently on /e/os 1.5-20221030230467

no OTA update is currently found, I guess I have to wait a bit

Did you bought from Murena Store? If you did, you must have 1.5 r stable. In that case, just refresh your update page in Definitions and you’ll get the upgrade.

ah, no, I have an “original” Fairphone, so I have the dev version.
Is there no OTA possible? or will it just be released later?

Ah, dev version… Me too I have an FP4 from Fairphone shop, but after I have installed eOS stable version. I think that migrate from dev to stable need a total refresh of the system. Or maybe just deactivate the option, but now I don’t find where this setting is.
You need to search in the forum to inderstand if dev version will have OTA upgrade.

Think it’s not possible for dev :frowning_face:

I solved the problem by bricking the phone while trying to flash it back to stock firmware, so the FP4 goes to the trashbin

edit: managed to flash it, it just took over 1h to for the flash_fp_recovery to finish

1 Like

You can find the answer to what you’re asking here: Info about Fairphone FP4 - FP4

I’m also an end user, that’s why I bought my FP4 from Murena store. But since then I learned a lot reading the documentation and I feel confidente to make simple things like sideloading. I really hope you find the answers and help you need.

1 Like

I will leave Fairphone experts to answer your other questions, but …

“Command line” is a set of instructions for a new install.

The “Upgrade” page is provided to guide a user who wishes to make an Android version upgrade on a device already running /e/OS.

If a documentation page contains insufficient information one might https://doc.e.foundation/support-topics/report-an-issue.

1 Like

Me too I’m not a technician and here we are a bit off topic, I think. There are many threads about FP4 and eOS, in this forim and also in the Fairphone forum itself.

Said that, if I remember rightly (I’ve installed eOS on my FP4 months ago without problems), the security patch level is important if you want a loocked bootloader (and consequently have working SafetyNet, banking/tracing/identification apps). In that case the level as to be the same (or eOS had to be higher).

In the end, I suggest you to not install a higer version of o.s. eOS for FP4 had an OTA upgrade from R to S so you could get it after the migration to eOS.

1 Like

If you are looking for some guidance around this, you can send a mail to our helpdesk@e.email ID. The team can help you with the instructions.

1 Like

I have a FP4 which I did not buy from Murena. Nevertheless, was able to upgrade to 1.5.1-s via OTA (the possibility showed up after manually searching for new versions). All went smoothly, just for the fingerprint sensor to work I had to restart a 2nd time.

Also the upgrade to 1.5.1-S went fine for me

Hi @confu, I am sure that it will be worth the wait !

I notice that you have joined a thread with the title Update FP4…, while you are quite rightly trying to get good information about an install – other contributors have mentioned Upgrade as well as Update – I mention this because this use of language may get adjusted by machine translation !

Perhaps be aware that /e/OS in S is still very new … speculating you may be be one of the first to do a new install of /e/OS - S - on a Fairphone 4 !

Also I believe the Install and Upgrade pages which you have linked are in the process of being updated to reflect the new situation.

1 Like

Hi, I have a FP4 (bought in a Orange shop) on which I installed e/OS myself last January.
The upgrade to 1.5.1-s went fine and smooth… but I have serious trouble with the Wi-Fi now.
More precisely, I can connect to any network, but I can access the web only for a few minutes, after that I’m the dark.
I am then connected without having access.
To get it work again I have to reboot (disconnect/reconnect does not provide me internet access).
The biggest downside of it being that it drains my battery in a few hours if I don’t disable the Wi-Fi.
I tried on different networks (personal and professional) and the behavior is the same.

My question is: is an upcoming update fixing this?

… but @confu, I try to say this in the nicest possible way … this is the Update thread !

I can quite see that translated you may see yourself “updating” your new Fairphone ! but others here are Updating /e/OS or Upgrading their Android version.

You are doing an Install as I know you know !

It is pedantic, but on the forum we try to be a bit flexible but use each of the bold words as accurately as possible.

I am looking forward to hearing of your reply from the helpdesk, that will be safe !

Good luck.

I’m having the same problem. I can reset all wifi and connectivity and get internet for a few minutes, but then lose it again. I can’t remember which build i updated from originally though unfortunately, but i did update to 28 Oct and that worked fine, it was the 2 nov build that has caused the problems for me.