Update from 1.19.1-s to 1.20-t on beyond2lte

thanks for the answer, you did the flash with adb sideload?

Just don’t wipe or format anything.

Not for this one,
only when the device is still updated by the vendor, you have to flash some needed partitions before system upgrade (sometimes reinstall stock-OS to get latest firmware).

The root directory of the phone is only accessible on a rooted system, or via TWRP.
Simply copy it in the “internal-storage” that will be accessible by the recovery-e.

1 Like

thank you piero :grinning: so to sum up, i copy the e-1.20-t zip file to the internal-storage and then i can install the zip with TWRP without wiping or formatting. after reboot i should now have the new upgraded e-os version with my apps and data, right?

1 Like

Some settings will be reverted to default.
I have not lost any data.
I did adb sideload. I didn’t know I could use e-recovery, as I have not researched subject. It definitely would be faster with update file already on device, as I don’t have reliable USB3.0 cable.

1 Like

I’m sitting for the same problem with my S10e. Is there anyone who can explain in a simple way, what I have to do by using e-recovery? Thanks.

simply Download the .ZIP, reboot to recovery and apply the “update/upgrade” :

Go direct to step (8) or (9)

Si cela peut aider, voici en français et en détail comment j’ai opéré aujourd’hui pour Upgrader manuellement le Samsung galaxy S10e de S (e-1.19.1-s-20240111372761-dev-beyond0lte) vers T (e-1.20-t-20240222382228-dev-beyond0lte) [la procédure est la même pour tous les S10, seul le fichier .zip diffère]:

1 - Sauvegarder le maximum d’informations sur l’état actuel du S10e (en version S) :

2 – Télécharger le fichier de la nouvelle version du sytème /e/ (e-1.20-t-20240222382228-dev-beyond0lte.zip) depuis “https://images.ecloud.global/dev/beyond0lte/” et copier ce fichier sur la carte SD du smartphone. Remarque le nouveau e-recovery (recovery-e-1.20-t-20240222382228-dev-beyond0lte.img) est déjà inclus dans le fichier zippé “e-1.20-t-20240222382228-dev-beyond0lte.zip”, il sera mis en place en même temps que le système (il n’est donc pas nécessaire de le télécharger sur le site “https://images.ecloud.global/dev/beyond0lte/”…)

3 - Transférer le nouveau sytème /e/ (e-1.20-t-20240222382228-dev-beyond0lte.zip) avec le e-recovery actuel (recovery-e-1.19.1). Il faut auparavant vérifier que le smartphone soit bien chargée et que dans les préférences des mises à jour (dans" Paramètres/Gestionnaire de mise à jour/3 petits points en haut à droite/Préférences") “Mettre à jour la récupération” soit bien active (ON) afin de mettre à jour en même temps la nouvelle version du e-recovery…
Puis passer en mode e-recovery (il est possible de passer facilement au mode e-recovery avec le smartphone allumé, par un appui long sur le bouton “Marche/Arrêt” puis en choisissant dans le mode “Redémarrer” puis “Récupération” – Il faut que cette possibilité ait été préalablement autorisée dans les options avancées de “Paramètres/Système/Boutons/Menu Marche|Arrêt/Redémarrage avancé”).
Dans le mode e-recovery (pour naviguer, il est possible d’utiliser les touches “Volume Haut” et “Volume Bas”, et le bouton “Marche/Arrêt” pour valider) :
Choisir “Apply update”, “Choose from SDcard” et préciser le nom du fichier : " e-1.20-t-20240222382228-dev-beyond0lte.zip". Attendre d’avoir le message final "script succeeded : result was [1.000000] " puis revenir en arrière et choisir “Reboot system now” pour rebooter le système. Vérifier la version d’android dans “Paramètres”/“A propos du téléphone”.
Bonne mise à jour

5 Likes

Thanks/Merci for your help.
I installed the upgrade to T on my S10e successfully and it seems everything works. :sweat_smile:

I did it in this way (on Linux):

  • copy upgrade.zip to /directory (which is shown by starting Terminal)
  • run on PC: adb reboot sideload (to avoid buttons pressing)
  • (Phone will start in e-recovery modus)
  • run on PC: adb devices (for check connection)
  • select in e-recovery: Apply Update, then Apply from ADB
  • run on PC: adb sideload filename.zip (note: without path)
  • Wait & wait until phone shows: success
  • Tap back to: Reboot system now
1 Like

Upgraded succesfully thanks Denis2ni :smiley:

@Denis2ni Merci beaucoup pour ta description très detaillée, ca m’a bien aidé :+1:

Today I tried to dirtyflash my S10+ beyond2lte from /e/OS 1.19.1-s to 1.20-t.
In TWRP with Install. No Wipe or Format anything. But before I forgot to enable USB Debugging in /e/.
The installation ended with the error below. Same with ADB sideload.
And now my S10+ only boots in TWRP. Could it be that I’ve locked myself out now?

@Denis2ni Merci beaucoup pour ton expérience, ça démystifie et m’a très bien guidé.

Many thanks, now my S10e is ugraded to 1.20-t

1 Like

Hi, @MvdL

Do you use latest TWRP ?
If not, try to update it (you can install the new version using the"install feature of the old one).

If you already have latest and cannot install /e/OS using it
You can install the recovery-e using TWRP “install” feature,
then using the recovery-e, try to install e-1.20-t with its “apply-update” feature…

Honestly I am not sure what is the point of TWRP today.
I have dirty flashed 1.20-T over 1.19.1-S
I have flashed Aurora Services on both 1.19.1-S and 1.20-T (I have 2 beyond2lte). I have done so with adb pull.
I have unbricked my secondary phone by removing Better Battery Stats from /system/priv-app/ using recovery

I am not against TWRP or usage of it. I just want to point out fact, that at least most advanced things can be done directly with adb and e/OS.

@MvdL first i’m sorry for your issue.
I’m not really skilled on such issues that you have meet, thus I can’t help you :worried:.
it seems to me that is a really serious one and need a lot’s of exchanges with people who have more experiences on it.
I would say that it would be more relevant to create an extra topic for asking for help and support for the resolution.
Make a link from here to it, I would be really curious on how it the process would go for the investigation, and how it will be solved.
How do you think about it, is that ok for you ? Is just a suggestion…
cheers

1 Like

Merci pour les infos !

Did someone knows why this update is not on the OTA ?!

Yes,
because it is not simply an update, but an upgrade.
Only devices Officialy solded by Murena get OTA upgrade

1 Like

@cemoi71 No problem. Thank you.
I will keep the idea of creating an extra topic.

Meanwhile I tried piero’s advice:
@piero Thanks for your advice. I used the latest TWRP (3.7.0_9-2). Not really the latest (3.7.1) but the latest for the S10+.
With TWRP I installed the recovery-e successfully.
Didn’t reboot but powered off.
Then booted in recovery.
Ended with error. Needed factory data reset.
Then reboot and finally the dancing e :partying_face:
Thank you piero. You are my hero

I forgot something above to add:
After booting in recovery-e I installed the e 1.20t.
Rebooted and then had the error and the need to factory reset.

Thanks @peteos
it also works with beyond1lte