Updating to /e/OS Pie using fastboot, adb, and TWRP on Essential PH-1

A few miscellaneous notes.

Network traffic monitor/indicator in the status bar has been disabled by Lineage for devices with a notch. Bummer.
Lock screen weather. I don’t see an option for it anywhere. Double bummer. Maybe I’m just missing something, if it is there somewhere let me know.
Cameras. We get two. Open Camera and Essential’s own Klik camera. There’s an update to Klik at the Play Store. Info implies that the update is needed for the camera to function after February 2020. Not sure what that means.

Can you release or at least describe the patch that was required to TWRP for enabling touch?

Sorry, no. I know nothing about the patch. The image was provided in the Essential Rooting Guide Method 1.

Dees_Troy is the official maintainer of TWRP. Maybe he can shed some light on that. Also check with bmg1001, the author of that tutorial.

I would love to see a new TWRP that fixes both the touch and screen offset issues.

Just so I’m clear. After fastboot flashing the TWRP image to both slots you rebooted into TWRP using the volume rockers/buttons. Touch should be working since that image has that capability.

Question. You used the set-active=b thing. That assumes that your current slot was “a”. Was that the case? Either way, try setting active to the other slot and reboot into recovery. See if touch works.

I believe the original/official steps were:

  1. Get current slot.
  2. Fastboot flash TWRP image to opposite slot.
  3. Set opposite slot as active.
  4. Reboot back into recovery using volume buttons.
  5. Push and flash TWRP zip (assuming touch works).
  6. From TWRP’s reboot menu, change/switch slot back to original slot. Reboot back into recovery.
  7. Now ready for pushing and flashing a ROM.

For me, I flashed the TWRP-SEP.img to both slots to assure I had touch on either slot before flashing TWRP zip.

I’m currently in the process of starting completely from scratch. That means starting with Nougat and working my way up. From Nougat to Pie without stock in between first.
Hopefully I don’t break things badly. The Essential is a quaternary device and /e/ is also on another device so I won’t cry too much if I kill it. Well, maybe. :grimacing:

1 Like


Finally got TWRP with touch as follow:

adb shell getprop ro.boot.slot_suffix

fastboot --set-active=_b
Setting current slot to ‘b’…
OKAY [ 0.039s]
finished. total time: 0.039s

fastboot flash boot twrp-3.2.3-0-mata.img && fastboot reboot
target reported max download size of 536870912 bytes
sending ‘boot_b’ (48712 KB)…
OKAY [ 1.705s]
writing ‘boot_b’…
OKAY [ 0.690s]
finished. total time: 2.395s

finished. total time: 0.050s

adb push twrp-installer-mata-3.2.3-0.zip /sdcard
twrp-installer-mata-3.2.3-0.zip: 1 file pushed. 22.9 MB/s (34875104 bytes in 1.450s)

Then follow

  • Go back to return to main menu, then tap Wipe.
  • Now tap Format Data and continue with the formatting process. This will remove encryption as well as delete all files stored on the internal storage.
  • Return to the previous menu and tap Advanced Wipe.
  • Select the Cache and System partitions to be wiped and then Swipe to Wipe.
  • Sideload the /e/ .zip package:
  • On the device, select “Advanced”, “ADB Sideload”, then swipe to begin sideload.
  • On the host machine, sideload the package using:

adb sideload ePie.zip

Total xfer: 1.00x

I can boot on /e/ but still NO TOUCH

Note: If I use TWRP-SEP.IMG I do not have the touch on the TWRP

Ah, I was about to respond to the post that popped up in my email. Seemed like there was a step or two that seemed missing or skipped. Was going to ask if touch was not working on both slots or just one of them. Quaternium mentioned how he only had touch on one slot in this thread.

But now I see the above post. Good that some progress was made on getting the ROM installed. I’m going to try and reproduce the issues and see how I fare.
We have to get this all squared away so the docs can be updated and finalized.

from within the folder where I extracted the ZIP PQ1A.190105.112-BACK-TO-STOCk i use the following command:

sudo ./flashallnowipe.sh
And I get: sudo: ./flashallnowipe.sh: command not found

If I do:
bash: ./flashallwipe.sh: Permission denied

I am missing something here ?

Oh, yes. The scripts are not executable. As is they’re just text files. Make them executable with…

chmod 755 flashallnowipe.sh

Then it can be run.

1 Like

Glad to say, after a long and painful day, /e/ Pie is now on my PH1 and seems ok.


  1. https://doc.e.foundation/devices/mata/

  2. I install back to store using instructions on:
    Then update Android to Pie (9) from the device with Android.

  3. TWRP
    Main difficulty was to get TWRP working (lot of issues with the touch).
    I used the TWRP-SEP.img

Switch slot:
adb shell getprop ro.boot.slot_suffix

fastboot --set-active=_a
fastboot flash boot TWRP-SEP.img && fastboot reboot

And from there follow the instructions:

Installing /e/ from custom recovery

  1. Download the /e/ install package that you’d like to install from here.
  2. If you aren’t already in recovery mode, reboot into recovery mode:
 adb reboot recovery
  1. Optional Tap the Backup button to create a backup. Make sure the backup is created in the external sdcard or copy it onto your computer as the internal storage will be formatted.
  2. Go back to return to main menu, then tap Wipe.
  3. Now tap Format Data and continue with the formatting process. This will remove encryption as well as delete all files stored on the internal storage.
  4. Return to the previous menu and tap Advanced Wipe.
  5. Select the Cache and System partitions to be wiped and then Swipe to Wipe.
  6. Sideload the /e/ .zip package:
  • On the device, select “Advanced”, “ADB Sideload”, then swipe to begin sideload.
  • On the host machine, sideload the package using:
  adb sideload filename.zip
  1. Once installation has finished, return to the main menu, tap Reboot, and then System
1 Like

Well, I’m still with the old march 3 version and a bad screen. Witch is a pity for a device supposed to be easy to install/use for mainstream users and paid more than 2.000€ for supporting the project :frowning:
Reading the posts makes me uncomfortable.
A complete & safe page would be useful.

I feel you. Did two more nights of Nougat to Pie testing that didn’t go so well (when not using a back to stock method).

I wouldn’t equate or judge the project based on a single problematic device. Not really the device but about Pie and TWRP not getting along. The issues will/can/may be present even with other ROMs. Check the XDA threads for some examples.

Yes, of course a complete and safe page of instructions would be useful. That’s the reason I was going through all the tests. Separate from what Pistou and Quaternium have used but I may try something along their lines.
Update, retain data, and not have a broken Pie wrt WiFi, Bluetooth and cellular data.

The whole TWRP touch issue (when only using 3.2.3-0 from TWRP site) is a major headache. I have found that if there is no touch in TWRP there is also no touch in the ROM (same slot). The use of TWRP-SEP.img is recommended. Otherwise doing most things via adb might be the better route.

Hej @marcdw, have you ever tried the custom recovery recommendation of LineageOS?

Yes, I have that one, from a long time ago. It’s version 3.2.1. I think I used it only once during the testing. Will give it another look.

For information only and without guarantee:

4… As mentioned above, the official TWRP version doesn’t work so download this version to …

1 Like

Many thanks @archje for the links. Will use that TWRP image as well as consult the tutorial on the next round of testing. Commencing now.

Regarding Lineage Recovery. I saw that for the first time this week. Nifty.

So I tried that Dec_boot_patched_TWRP.img. Again, since I’m testing upgrading Nougat to Pie while retaining data I hit a minor snag. Started off wanting to use that TWRP but found it has no touch on Nougat firmware. Probably because it’s based on Pie(?). Always something.
Later after /e/ Nougat was squared away and it was time to upgrade I decided to flash Pie firmware without wiping userdata. Then installed the December TWRP to both slots. Touch is initially working. Flashed Pi/e/ followed by flashing TWRP zip. Touch is indeed working, on both slots. Finally! :ok_hand:
Booted the ROM. Data and settings intact. Still, in my case, WiFi and Bluetooth just do not work. A full back to stock with wipe was in order.

Don’t know if anyone else has done an actual upgrade and if the problem is just me.

Achtung: The original post has been updated a bit. Use of another TWRP image as well a link to an article about flashing LineageOS Pie with that image.

My post was for those who want to keep TWRP. For instance I don’t do OTAs and usually have other things to flash after updating. Plus addon.d backups never worked on the mata so TWRP was essential.

For others, like the linked article shows, you would use TWRP temporarily until the ROM is up.

Thanks to @archje for providing the link to the article.

Great stuff…I got another PH-1 now and planned not to return this, so your precise tutorial is of great help for me. At least it made me feel rather safe. :stuck_out_tongue:

The China Mobile SIM card didn’t work on this one too, but the device’s previous owner said it worked fine with HongKong vendor’s cards. It’s my third PH-1 that has a faulty SIM… However my fourth PH-1 is really nice, everthing just works! So if anyone encounters any “no SIM card detected” problem, don’t blame on /e/ first, it could really be hardward issues. :stuck_out_tongue:

1 Like

Great guide, matches what I’ve done on Essential for some time now (the no-touch issue with TWRP isn’t new!).

I’m having a problem getting Magisk to work. No problems with TWRP or flashing /E (well, installing via TWRP).

I’m going back to stock flashing PQ1A.190105.112-Back-to-Stock.zip
Boot to Fastboot, flash TWRP
Boot to TWRP
Install /e
Install TWRP.zip
Boot to /e
Reboot to TWRP
Install Magisk

Now if I boot to /e, it hangs, and eventually reboots to TWRP. I’ve tried installing /e, then installing Magisk, and get the same results.

Am I messing up the sequence somewhere?


Many apologies for being away so long.
Not sure about the Magisk issue but will say that recently I tried to update Magisk on Pi/e/. It was successful but the ROM would never boot afterward. Just reflashed the version I was using and all was good.
Currently using v20.4.

I have never liked Magisk. History of breaking things with new major versions. All of my ROMs on other devices (KitKat thru Oreo) use SuperSU or Lineage su. On Pi/e/, the former isn’t usable (far as I know) and the latter wasn’t adequate (for Adaway, Substratum, EdXposed).

I know it’s late but if you’re still dealing with Magisk, try 20.3 or 20.4 first. If successful then try to upgrade.