Updating to /e/OS Pie using fastboot, adb, and TWRP on Essential PH-1

Achtung: The original post has been updated a bit. Use of another TWRP image as well a link to an article about flashing LineageOS Pie with that image.

My post was for those who want to keep TWRP. For instance I don’t do OTAs and usually have other things to flash after updating. Plus addon.d backups never worked on the mata so TWRP was essential.

For others, like the linked article shows, you would use TWRP temporarily until the ROM is up.

Thanks to @archje for providing the link to the article.

Great stuff…I got another PH-1 now and planned not to return this, so your precise tutorial is of great help for me. At least it made me feel rather safe. :stuck_out_tongue:

The China Mobile SIM card didn’t work on this one too, but the device’s previous owner said it worked fine with HongKong vendor’s cards. It’s my third PH-1 that has a faulty SIM… However my fourth PH-1 is really nice, everthing just works! So if anyone encounters any “no SIM card detected” problem, don’t blame on /e/ first, it could really be hardward issues. :stuck_out_tongue:

1 Like

Great guide, matches what I’ve done on Essential for some time now (the no-touch issue with TWRP isn’t new!).

I’m having a problem getting Magisk to work. No problems with TWRP or flashing /E (well, installing via TWRP).

I’m going back to stock flashing PQ1A.190105.112-Back-to-Stock.zip
Boot to Fastboot, flash TWRP
Boot to TWRP
Install /e
Install TWRP.zip
Boot to /e
Reboot to TWRP
Install Magisk

Now if I boot to /e, it hangs, and eventually reboots to TWRP. I’ve tried installing /e, then installing Magisk, and get the same results.

Am I messing up the sequence somewhere?


Many apologies for being away so long.
Not sure about the Magisk issue but will say that recently I tried to update Magisk on Pi/e/. It was successful but the ROM would never boot afterward. Just reflashed the version I was using and all was good.
Currently using v20.4.

I have never liked Magisk. History of breaking things with new major versions. All of my ROMs on other devices (KitKat thru Oreo) use SuperSU or Lineage su. On Pi/e/, the former isn’t usable (far as I know) and the latter wasn’t adequate (for Adaway, Substratum, EdXposed).

I know it’s late but if you’re still dealing with Magisk, try 20.3 or 20.4 first. If successful then try to upgrade.