Upgrading to 1.4 DEV branch

I would like to switch to the /e/os Dev branch to take advantage of the Adb root option.
I was wondering if this could be done using the integrated upgrade fonction. That one proposed me to download the 1.4 release recently, and I know it will then proceed with a one click install (it worked like that for the 1.3).
Is there some way of replacing the downloaded Stable 1.4 branch with the 1.4 Dev one, so the installation will then proceed the same easy way ?
Thank you

Download the dev build .zip for your device.
Store it into your device storage : internal or SDcard.

Reboot in recovery mode,
follow “the update way” using recovery-e OR “the install way” using twrp,
to flash the dev build .zip to your device according to the documentation
( but without wiping anything ! )

Hi Piero,
Thank you for your answer.
This is the way I thought about. (I installed /e/os with the manual method), but then i discover the integrated auto update that led me to my initial question.
So OK for the manual method.

but still 2 questions:
1/ Can I switch from Stable 1.3 directly to Dev 1.4 ?
2/ Looking at the build downloads, it appears that a versionned recovery image (.img) is always linked to the same versionned /e/os release (.zip). Only a few bytes differ from one .img version to others.
What do those differences mean ? as it seems to be safe to upgrade .zip without upgrading the recovery first.

Thank you

PS: Tried from recovery, but found no way of upgrading from the internal Storage; Only “Apply update from adb”. Specific to S9+ Samsung perhaps.



Perhaps because your internal storage is empty ?
On my Samsung Galaxy s4 :

Unfortunately not at all :smile: !
The only difference I see is that you show V1.4 e-recovery although mine is V1.3.
But don’t mind I will sideload it.

The unified Howto is great. I already rely on it for my understanding during my first /e/os flash. But thank you to remind it.

Do you have any counter indication to switch to TWRP (in an attempt to get the update from internal storage available) ?
Please also confirm flashing a new recovery won’t wipe any data ? (As there is no need to unlock bootloader again)

No problem flashing /recovery is another partition than /data.
because, as you said :


Not from recovery-e as it only manage .zip, not .img or .tar
You need the computer to flash TWRP to the device
But from TWRP, you can install another TWRP version, or the recovery-e to the device

OK, got it.

Now doing the sideload… it ends up with “Signature verification failed”. So I cancel the update.
I’ve checked the sha256 of the e-1.3-q-20220825213388-dev-star2lte.zip file… OK.
Any clue ?

Samsung S9+ (SM-965F)

Using TWRP ? this is an expected thing

No, still using e-recovery 1.3
I got no error when installing first 1.3 Stable
But i did a factory reset, that i obviously won’t do again. Should it be an explanation ?

1 Like