Using apps with Google Play Store in-app-purchases with /e/

Before switching to /e/, I’ve used a couple of apps with in-app-purchases. Is there any way to keep using the paid features while using /e/ os? The apps themselves just error out for the runtime paid feature checking.

I tried a bunch of things. At this point, I don’t know what to do anymore and would like to know if anyone has experience with this or knows what to do.

Here is what I tried:

I’ve researched quite a bit, and what I’ve learned is that this functionality resides within the Google Play Store. Of course, /e/ ships with microG which only includes the FakeStore. So I read a bit and read somewhere that just installing the Play Store would work, it’d be using microG APIs.

So I thought that I’d have to install the Play Store. I haven’t found any discussion about anyone particularily doing this already or providing a howto or anything like that specifically for /e/ (which is mostly Lineage if I got it right), but I’ve found a couple blogs and other sources (like this).

So I tried installing the Play Store, but I failed. I first tried just installing the APK normally as a user app, which worked of course, but apparently Play Store doesn’t handle being a user app very well, it kept crashing. So I’ve tried installing it as a system app, which I’ve also failed at.

First I tried this guys standalone play store installers, which just didn’t seem to do anything, no play store after running them (I’ve checked the installer script to make sure it wasn’t malware, and it seemed to just extract the apk into /system/priv-app/Phonesky).

Then I’ve tried following these directions with and without the patch, but any time I try to start, the boot fails and sends me back into recovery.

Finally, I’ve tried downloading the opengapps pico installer, which I didn’t want because it includes actual play services, but it installed and I have a Play Store. But it doesn’t work, just shows “Error retrieving information from server”. I then tried removing everything but the actual play store from the installer script, which didn’t boot again.

1 Like

Try Aurora Store.
It is an alternative frontend to the Play Store.
There you can log in with your google account and download your purchased apps.
If they then work with microG is a second question :wink:.

But be aware of this (taken from README on gitlab):
Why would I use my own account? Is it safe?

You can use your own account to download apps purchased by you or to access your wishlist. However, you may want to be careful as Google retains the right to block any account. It might be worth using a dummy account for that reason.

I forgot to mention that I do not have any paid app, so this might not work don’t be too enthusiastic :wink:.

Thanks for the help, however that’s not what I’m talking about. I’m talking about in-app-purchases, which do license checking at runtime. Aurora doesn’t do that, which is why I think I’d need the play store for that. I’d hope to use the playstore only exactly for these apps and nothing more.

I have no experience with this, but forum search says …

Installing the genuine Google services (via Open GApps) with microG being present doesn’t go well together.

As for the standalone install of the Play Store not working … It’s possible /e/ degoogled something the Play Store App still needs in Android apart from microG mimicking Google services.
If your in-app-purchases are important to you, I guess you would have more luck with LineageOS.

I’m not sure whether this will help, but I’ve been spending some time working with Nanodroid It consists of several modules which can be installed separately. One of those modules is nanodroid_play. This contains, amongst other things, the option to

install Google Play (patched with microG (in-)app-purchase support)

This is designed to work with their version of microG, so it may be problematic to get it to work with /e/'s built-in version. But it might be worth a try

My current project is a custom build of /e/ without microG, to be used in conjunction with NanoDroid. I currently have a version which seems to be working, and I plan to post in the forum sometime soon.

Good luck!

Not directly relevant here, but Google may have changed something affecting microG users during the last three months. I have an old Galaxy Tab S running a customized stock OS (Android 6), where the dev had included an older version Play Store that could not be updated by Google, and was running on top of microG. Logged in with my personal Google account, as long as microG was up to date everything worked as normal.

This has now stopped working. I’m only offered a fraction of the updates available, including most, but not all paid apps. It may be Google is tightening the reigns on outdated Play Store installs, rather than microG. So far, AccuBattery is the only paid app where the license check failed, but I don’t expect it to stay that way.

1 Like