Warning: Moto G5 cedric: do not update to 1.21r

We have several Moto G5 cedric which are used by the kids. They updated to r1.21 and now there is no WLAN anymore!
If you switch on WLAN it switches off immediately. Apps like wifi scanner can not switch on wifi!

Also a simple way for downdate is needed by storing a lower version in sdcard and to be able to downdate to it without loosing apps and data

I suggest that e.foundation uses REAL DEVICES for basic quality control before shipping updates.

I am sure that some users donate real devices for quality control if quality control takes place.

Have a checklist that basic things like
GPS, WLAN, a gsm phone call, listening to music, operating touch screen, USB keyboard, mouse
etc are tested before shipping an update.

cedric owners thank you for the heads up.

If you run (a family) on a community device though, the testing is up to you.

Ability to downgrade easily would help, fair enough.

I guess the wifi firmware is missing or inaccessible in the system image. If you post a logcat of the moment enabling the wifi icon quick settings tile I’ll follow up

The kids, who are privacy aware, did the updating on their own without testing as many updates went through without major problems, and it was believed that basic features like wlan, display, sound, touch screen and so on have been checked before “releasing” a new version for update to the users. Cool, a new update, let’s play with it.

It is something different if one needs to install a testing version using a USB connection to a Linux PC than to just click update and things run automatically seemingly smooth.
The main problem is that there is no down date.
Or as with goog Linux distributions that you can choose the older kernel in grub boot menue.

Why not having 2 or 3 versions to boot to with a menus choice.
If such is not feasible because of the structure of android at least a rollback option with the old firmware being backed up to SD card should be an option.

So a user should always be able to restore the previous state before the update.
Then the bug like missing wlan are not that severe.

Now we need to think on how to install a new update, maybe we use network over USB using an openwrt router for this purpose if a version with working WLAN is released.



BTW: I will donate a moto g5 on the condition that subsequent versions are tested for basic features before shipping as updates.

Sideloading one version prior through the recovery will probably help, as suggested in the other thread, go do that.

Cedric was a Android 7 device on release, verified-boot with rollback protection (AVB2.0) was a Android 8 feature, so rollback protection shouldn’t be a concern.

Newer Androids do have a A/B slot recovery concept, it was released with later Androids (9 and up). Though userdata can end up being incompatible with the other slot. Sure I agree, downgrade should be easy, easier even than going through recovery+sideload.

I empathize when users run into issues, it sucks. But this software has no contract, where does the entitlement come from? Things will break, as in: donate the extra Cedric to yourself and run updates prior to when your kids do.

I had the same problem on two G5 Cedric. The downgrade to 1.20 solved the problem.
Two points from me:

  • Having a possibility in “Settings / System update” for not only selecting the newest version, but also 2 or 3 older ones would be nice. It would not be a big effort to add this. In our case (the case of broken Wifi) the image would have to be downloaded via the mobile operator… well, that might costs a few €, but still better than being stuck.
  • On the other hand, people using e/OS on G5 surely are a bit more experienced than the average phone users. Installation takes some steps that most people would not be able to follow. Yes, I too handed e/OS phones to my family - and I’m aware of the fact that I’m the tech repair guy in case something goes wrong. Just as tcecyk said: e/OS is for free, there’s no warranty. I’m very thankful to the people behind e/OS while being aware of my own responsibility when using it - and my obligations when handing it to others.

cc @Manoj could you hide “e-1.21-r-20240323388943-dev-cedric.zip” in cedrics OTA api response?

there were users hit by that timestamped’ image before this thread opened - https://gitlab.e.foundation/e/backlog/-/issues/7907 / Feedback for v1.21 - #20 by dfbrem

firmware: could not find firmware for wlan/prima/WCNSS_qcom_cfg.ini

flashing the modem firmware partition only could help without downgrading.

Have sent a request to the team to remove the build from the servers.

1 Like

This is no solution I guess.
Afik, the modem firmware is the lte radio and not wlan.
Also I prepared a bunch of cedrics for e.foundation and scripted the preparations. Here an update to 8.1? stock was needed before flashing e.foundation.
A lot of firmware and other blobs had to be flashed.

So why one would need to write “modem firmware” which is a blob and not part of e.foundation?
So nobody has overwritten this firmware afik.

So it is more likely that a kernel module is missing or the like. This has to be investigated by diffing version 1.21 against 1.20 where wlan worked.

Also there is an answer that the phone should revert to 1.20 using adb sideload

so if this reverting works, without “writing new modem firmware” then the modem firmware is not affected, right?

We are not with windows support here (“did you reboot, are the lamps on your router green”?).

Could you provide a patch to write this firmware portion to 1.21 using adb and usb.

I was wrong, it isn’t the firmware itself (wlan firmware is supplied through the same partition image as modem on motos, NON-HLOS.bin and mounted to /vendor/firmware_mnt) - it isn’t part of the image for cedric.

On partition diff it’s really just 2 missing config files at /firmware/wlan/prima/ (system perspective) from the vendor image. If the lamps on your router are green, you can use adb root to place them there - https://murena.io/s/z8BsjkxSf8Km46W

But as others wrote, sideload will work too (of the whole image, that will also write the vendor partition, placing the files).

The WLAN problem also applies for Motorola Moto One Action (troika) in eOS 1.21-t. Next Update should please also ship with correct partitions and/or driver files.

@DietmarT should be an extra thread, troika is too different in its SoC than cedric, they share no dependency repo for their builds. I looked around if there is a commonality.

Seems for the troika it’s up to selinux, see the restorecon in

for a fix. Haven’t checked why it affects lineage 20 + 21, /e/ is on 20 with t - have a read.

@tcecyk Sorry, I thought it is the same problem because both are Motorola devices with maybe the same Wi-Fi chip.

And thanks for the link! Two weeks ago, I went back to eOS 1.20-t having WLAN again but by loosing user data due to the downgrade. I am hesitating now to give this solution a try and maybe loosing user data again. :wink:

Feel free to move this topic to an own thread but if this is really a LineageOS problem, we have to wait for their solution and close it here.

@DietmarT as /e/ mostly builds from the Lineage device trees, it is a /e/ problem too. That March 13 wifi fix for troika isn’t merged/backported to L20, so you probably can’t get it for /e/ as I see no forked /e/ repo for exynos9610. Common problem when maintainers focus their attention to the current version.

But back to cedric.

This topic was automatically closed after 15 days. New replies are no longer allowed.