Weathernetwork fails to run with Latest OS up date

Updated 2 phones to the latest e/OS a terracube 2e to /e/OS 1.10-20230412278811
and a Fairphone 3 to /e/OS/1.10-s-20230412278810-stable-FP3.
The Weathernetwork refuses to open now with the warning “Someting went wrong Check that Google Play is enabled on your device and you are using an up-to-date version before opening the app. If the problem persists try reinstalling the app”

I reinstalled on the Terracube and Installed on the FairPhone. I think a problem exists with this update.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I believe this weather app is for Canada?
As an alternative, have you tried WeatherCAN?

Is that the MeteoMedia Weather Network app?

If so it requires Play Store.

E/LicenseClientV3(5717): Error while checking license: com.pairip.licensecheck3.LicenseClientV3$LicenseCheckException: Could not bind with the licensing service.

Lots of related license checking lines in the log.

On a microG ROM with Play Store the app runs fine.

Also has a lot of trackers inside.

Note: There could be light at the end of the tunnel.

/e/OS comes with FakeStore (now called App Lounge Store - not the same as the App Lounge used to install apps). It has the package name of, same as Play Store.
It is just a stub used by some apps that check for the existence of Play Store.

What is happening with some apps, like Weather Network, is that they are looking for a licensing function from the Play Store. It finds FakeStore, tries to get the info it needs but cannot. Hence the failure.
Even though the app is free I guess it’s coded to look for said function, even though not needed.

There was a pull request from five years back.

Add CHECK_LICENSE permission as some apps may require it. by alinefr · Pull Request #16 · microg/FakeStore · GitHub

The fix finally happened.

Swapped out the FakeStore on one of my ROMs and retested. Weather Network runs without the error.
Another app that produced the same error also runs fine.

Hopefully we’ll get the new FakeStore in a future /e/ build.
I would consider it a priority actually.


Are /e/ including this in the /e/ ROM directly from upstream, or are they making their own fork?

Commits history:

1 Like

Ah, I see. Thanks. Already in the works it seams. :ok_hand:

That looks to me like they /e/ are making and working with their own fork ( from microG ) (according to :frowning:

I hope I’m mistaken, but if not let’s hope that goes a bit better than forking microG GmsCore, Bromite, or their other forked apps, and that it doesn’t quickly fall behind upstream in terms of new features and bug fixes.

OK, it’s a pretty old thread. But I hope I get help. In the new /e/OS 1.11-s-2023… I have two apps now missing GooglePlay and closing with an error.
What about this fakestore? Is this an onboard feature? Or can I install/implement/activate this manually?
(One of the non working App is called Yuka and the other is called Vivino, maybe someone knows! :wink:)

Best regards,

Reading the previous messages should answer your questions I’d figure.
If not… Nothing to do really but wait until a future /e/OS release includes the changes/fix.

Thread is from last month. Not old at all. :grin:

I installed an app called omWeather, once you get use to it, it is quite good. It will show the forecast for the areas I am interested in. A BIG plus NO Ads. :grinning:

1 Like