Week 14, 2022: Development and Testing Updates

Awaiting a response from the team on the release date for stable builds. Will update

The stable builds are delayed due to some bugs… will share details. App Lounge will not be a part of stable builds for now. We have released it on the dev channel and have got numerous suggestions
The team is working on most of them.


:+1: thanks @Manoj for checking this out

Hi @Manoj I did an OTA update to my OnePlus6 a few days ago and it’s now running on the 0.23 version of Android 11 with no problem. The failures on OnePlus devices obviously doesn’t concern this one :grinning:

1 Like

Hi @Grendel glad to hear that. We are working on releasing the builds that failed

Hi there,
I just did the OTA update on my S9 to 0.23 (android 10). But I’m not supposed to received “dev” updates, is this normal?
The update went well and everything seems to work as expected, but TWRP gave me a strange (and little bit scary with a red color font) warning about an unfunctional password (I can’t remember the exact message… sorry :frowning: ), to be short, TWRP was unable to decrypt data because the default password didn’t work, but the update went to the end normaly (as far as I can tell).

Am I the only one who saw this message during the upgrade?

Can’t tell you because the update 0.23 is still not available on my S9 stralte (android 10 too). It’s a bit strange that you (or me) have (don’t have) the update on the same phone.
Maybe I’m wrong but if your phone came from the /e/ store you should have access to the dev update and so the 0.23 before me. Indeed, my phone is a refurbished one but not buy on the /e/store so without the dev update. But again maybe I’m wrong.

1 Like

Oh, that could be an explanation : I bought my S9 on /e/ store… but I understood (maybe misunderstood…) that you have to explicitly choose to use the dev version.

Thanks for the clue anyway :wink:

Yes, when you buy your phone on the /e/store but for me who bought my phone outside the /e/store (with manual installation of /e/os) I have no access to the “dev” update.

Glad if I could help you ^^

1 Like

OS updates don’t concern the data partition, so they should work regardless of any message about decrypting data.

What exactly does it say now for you in Settings - About phone - Android version (tap on it) - /e/ version?

Usually it was the other way around. Phones preinstalled with /e/OS had stable, the OS you could install yourself was dev. In the meantime, stable is also available on a few phones for installing it yourself.
And the Easy installer should install stable.

Android 10 dev is available for starlte … https://images.ecloud.global/dev/starlte/.

1 Like

Yep, updates don’t concern data partition : that’s why the update worked.

The build number in the settings is long but has “userdebug” and “dev-keys,stable-release” in it. I can copy it right here, but only if you really want it :stuck_out_tongue_winking_eye:

In the update section I have the 0.23-20220401175185, which is not short either…

Maybe /e/ opened the update for a small period for 0.23 as they did for the upgrade to android 10?

That’s why I asked for Settings - About phone - Android version (tap on it) - /e/ version, which has all the necessary info in the same format like the filenames on the download pages … which isn’t short either, but leaves no questions open, and since Android 10 you can long-tap it and copy it to clipboard :wink: .

You’re on the stable release channel.

1 Like

Thanks for the tip (the long-tap), good to know that!

I think the red message about data shouldn’t be there : when you see it, it’s too late to do anything anyway. And by the way, I didn’t encrypt my data partition… strange o_O

Thanks again for your help

Thank you for the precision, as you said it was the other way. :slight_smile:

But I cannot see the V0.23 dev. Maybe it is not available yet. Same when I check for update on the phone.

Now, when you check in Settings > Security, do you find that your phone is encrypted?

As a matter of fact I do… But I didn’t chose to encrypt my phone… And there’s nothing under users identifiers.

So TWRP is right, but I don’t know the password either…

TWRP has limited powers in an encrypted Samsung, so you noticed the warning about this. It seems at least a few people experienced this.

TWRP can still do some things … if it asks for a password, just press cancel. This applies defaut_password which is expected to have been applied.

/e/ users posts where they have experienced OTA Upgrade issues share the hashtag #ota-upgrade.

1 Like

Great to know the cancel trick to apply the default_password!

And thanks for the link too.

You are right with that, it can be confusing if you don’t deal with TWRP for much else, but the bottom line for OS updates is that it’s harmless.
You can either ignore it, or if it really bothers you, you could try to install the /e/OS recovery provided on the ROM download page instead of TWRP.
(But I don’t have a Samsung device and even the manual OS install docs for starlte refer to TWRP when installing a custom recovery, so … pick your poison :wink: .)

Android did. In recent Android the data partition is encrypted by default. You can set your own decrypt method (password/PIN/pattern/…) for this by setting an unlock method for your lock screen.

1 Like