Where to find 0.15-20210317106351 for FP3+?

Received my new phone with that preloaded. Need to reflash, and I can only find 0.15-q-20210316105636 on the download page. That’s older and has a “Q”.

Where can I find 0.15-20210317106351? That’s the version my updater says is currently installed.

There is a difference between preloaded and user-flashed phones. Preloaded (or installed by easy installer) means you are on the stable branch, user-flashed puts you on the development branch. They have different release cycles.


Install files for the stable release channel are not available on an openly accessible download page currently.

You can install the current stable release with the Easy Installer … https://doc.e.foundation/easy-installer


Lovely. Well I tried that installer, it never finishes. But since it downloaded, I’ll try applying the package manually.

I was able to successfully reapply from the IMG latest zip that the easyinstaller downloaded using the original loading instructions.


That doesn’t sound familiar to me, but the description is a bit vague. Which step hangs?
In case this is not a known issue, would you be willing to answer some questions/provide the log file of the failed attempt(s)? Maybe there is something to improve in the installer to avoid the situation for future users.

1 Like

I have heard once or twice that users are a little fearful of making an upgrade.

Is Easy Installer seen as a good solution for an upgrade, in the case of an /e/ device on a lower version than offered by Easy Installer?

I hadn’t intended to pursue the easyinstaller issue. It stopped forever at the point it was writing the system image to slot A on Windoze 10. There was a KVM USB hub between them.

I switched to my Linux box with the full ADB tools and loaded normally once I had the correct image.

The root cause of my original problem was that I had tried to relock my bootloader after installing Magisk. Apparently that causes corruption. Reloading was a breeze.

I think my only remaining concern is that I got the version of 0.15 which matches what the phone shipped with, but during my reading I found that FP3+ needs a “Q” build? I’m not sure how to confirm that I received or reinstalled this Q build. The system update doesn’t show a Q in the version string.

The version the installer installs for both FP3 and FP3+ is always a Q build.

1 Like

Settings - About phone - Android version shows whether it’s Android 9 or 10.
You can then tap on this Android version to open more info … the /e/ version string including p or q is given there at the top.

Indeed! The Q version is under /e/ version. I was checking the updater screen. Thanks for helping me confirm.

As far as I’ve seen the main reason for this is that user data will be wiped with the manual upgrade procedure currently, so the phone needs to be set up from the start again with more or less help from backups or the lack thereof … until /e/ manage to provide an OTA upgrade which doesn’t wipe user data.

@Ingo_FP_Angel: The Easy Installer wipes (or formats?) user data, too, doesn’t it?

1 Like

Yes, first unlock, then wipe, install and finally lock again.