Wifi network missing


Yesterday when I came home from work, my /e/ device no longer detected my home wifi network. I tried restart the phone but it didn’t help. Other devices accessed wifi without any issue. Only when I restart the wifi router, then my /e/ phone can see the wifi again.

Today it’s the same story. Update: restarting the router no long works. My phone completely doesn’t see the home wifi network.

Have any of you experienced something similar? If so could you please give me some help?

I use a Nexus 5, /e/ OS version 0.16-20210417110995



If you have the MAC address randomization available for your device (in access point advanced settings), try to disable it.
Also, you may try to set up manually IPv4 address, and disable ipv6.

Also, please read here : Roll back to the previous /e/ OS v.0.23 from v.1.0? - #7 by AnotherElk

May be you got the problem I reported here.

1 Like

Hi @smu44 , @irrlicht

Thank you both for your suggestions. Unfortunately they don’t work:

  • There is no MAC randomization option on my device
  • The router only uses IPv4, and is on 2.4GHz mode only (5GHz channel above 116 is therefore not available)
  • Regarding the reported problem from Irrlicht, it’s not really the case. My phone still sees other wifi networks, just the only wifi in our house is missing, although other phones can still connect to it. Not sure if this is related but if I use my wife’s phone as a 3G hotspot, my /e/ phone can connect.

If you have any other ideas, that’d be appreciated.



Are your AP log and settings available ? What is the brand & model ?
Did you try to delete the AP in the phone, reboot it, scan again ?

Also, you can try the following:

  • dial *#*#4636#*#* on the phone
  • go to “Wi-Fi information”
  • “Wi-Fi config”, then find the line starting with “ID:” for your network SSID, get the ID and share the whole network definition with us
    – NB: if the the line is starting with “DSBLE ID:” and/or you have a line un upper case saying “NETWORK_SELECTION_PERMANENTLY_DISABLED”, then follow the next steps
  • back on step, go to “Wi-Fi API”, then “enableNetwork”, enter the ID
  • wait a minute, go back one step, then “Wi-Fi status”, “Refresh stats” multiple times

Hi @smu44 ,

Thanks for your detailed instruction.

I don’t think the AP log and settings available. It’s the one provided by my ISP with very basic configuration. Here’s the info:

  • ISP provider: Vodafone UK
  • Product name: Vodafone Wi-fi Hub
  • Firmware version: 19.4.0551-3261103
  • Hardware version: Vox3.0v

On my /e/ phone, the other day when I tried to reset all network settings, the home network never appeared again in the available wifi network list. So, no option to delete the AP in the phone.

Also for the same reason, when I open “Wi-Fi config”, the home wifi network is not found because I reset all network settings. I can only see my wife’s shared hotspot SSID yesterday and nothing else.

Having said that, when I to back to “Wi-Fi API”, then “enableNetwork”, and manually enter my home wifi SSID, the app crashed saying “Setting has stopped”. I selected “Open App again”, tried to enable the home wifi again, and got the similar error “Settings keeps stopping”, this time with only option “Close App”.

So far, what I’ve tried: restart phone, restart wifi router, reset network settings on phone. I don’t know whether resetting the phone (not restarting) helps but I still don’t prefer that way - but maybe it’s the only way. I’m still seeking for advice.


It won’t work that way for you : a well-known AP ID number (0,1,2,3,…) is expected :frowning:
I guess you already tried to manually add the AP in your phone?

As your device works well with other Wi-Fi networks, it may somehow have been “blacklisted” by the Vodaphone set-top box …
Sorry, zero knowledge about Vodaphone devices here, and I’m out of ideas :crying_cat_face:

Hi @smu44 ,

Thank you for following up. It’s a shame the router is not so popular.

But you know what, today my phone picks up the home wifi network again without me doing anything. I just got home as usual, turned on wifi to check and the wifi appeared in the list. I have to input the password of course (because network setting was reset a couple of days ago).

Now I can see the network details in Wifi config page that you suggested. Not sure if it’s of any benefit, but I attach here the screenshot of this network, just in case you find something noticeable to avoid this happens again.

Thanks again,

That’s good news, thanks for your feedback! :slight_smile:

As you didn’t change anything on your phone, it’s more likely from the AP, like a blacklist expiration …
I checked your settings against mine, nothing unusual.

Hi @smu44 ,
You wouldn’t believe this but today my home wifi went missing again on the /e/ phone!
This time I can find it in “Wifi config”, the first line reads “DSBLE ID: 2”. Tried “enableNetwork” manually and “Refresh Stats” but no help.
I guess there is no choice but I have to factory reset my phone :disappointed:
Thanks for your help anyway.


That’s weird :pouting_cat:
I hope that the reset will do …

Another idea : is Ethernet is available at the Vodaphone router, buy a cheap AP to have another WiFi network running …

Perhaps effective feedback to your ISP is required; I found this in a very quick search thoughts on the new vodafone router - gigabox vox3... - Community home.

1 Like

I had/have a router problem where the router becomes confused about to which devices it has handed out leases of IP. It can actually handle duplicates, sometimes!

Actually it gets really confused by (say) a PC being booted into a different OS from a bootable stick. Here I have always to terminate an “old leased IP” before the “new system” can see the router.

When first testing /e/ the same problem occurred.

I learned to get admin access to the router – now I can make routine sweeps of IP addresses and keep mostly free of the problem.

I do not know if all routers will do this. Reset of the router might work, but then I get a different problem reregistering my password with my ISP!

@smu44 I took my old extra wifi router which creates a different SSID, it did the trick and the phone is connected in the last couple of days, thank for your idea :innocent:
@aibd Thank you for the report link, it’s not the same model though - raising question wouldn’t get support I’m afraid because they may blame /e/ OS. Also, checked my router and it doesn’t seem to have sweeping IP function. :slightly_frowning_face: I now stick with the old router work around.

Happy to read that the workaround is working :smiley_cat:
There is definitively something weird with these Vodaphone devices …