Wifi not working


after installing a fully functional /e/OS to my GS290, i bought another GS290 because I need a second device for a certain purpose.

On the new GS290, I did all available updates of the stock ROM. Wifi was working fine with stock ROM.

Then I installed /e/OS, but Wifi is not working. It is deactivated, and always when I want to activate it, wifi just stays deactivated.

Any ideas?

Maybe I did too much stock rom upates, so maybe something on the wifi firmware changed and does’t work with /e/OS?

I also get this bluetooth message

Can please someone help me?

Problem solved :slight_smile:
I installed stock Android again with this guide

Then I installed /e/OS again and it worked. Wi-fi is working fine now.

1 Like

I think you had good luck! You might have had a corresponding firmware version which fit the installation file versions of easy-installer or from OS Dowload site for GS290.
I had the same Problem - but your solution di not help! So I went on a long run of troubleshouting.
My 3 GS290 for Christmas presents were all on the highest level of firmware and OS in the moment (October 2021).
At least I found out that the boot.img, which is delivered with easy-installer or on Download site must be older ones. So I took the newest boot.img - and so newest kernel and hardware drivers - and installed it in spite of the delivered from e.foundation. And voila - it worked with the installation manual from the Download site!
Best Regards

Hi Didi
I spoke too soon unfortunately. My 290 is now dropping WiFi a lot if I go out of range and then come back in range.
0.18 was all fine so this is really annoying. I’ll open a ticket.
Glad you got yours going.

Hi AndyP,
as I told before I think that is a problem of the kernel in the boot.img! In between my wifes new gs290 is updated via system update to version 0.20. But with the system update it seems the boot.img remained untouched. I flashed the stock boot.img from October - and wifi and bluetooth is still working with this stock rom boot.img. Because it contains new wifi drivers! Additionally I have a patched version with Magisk of this boot.img. I flashed it like this:
fastboot.exe devices
fastboot.exe flashing unlock (-- after this you have to press vol up at the device!)
fastboot.exe flash --disable-verity --disable-verification boot boot.img
fastboot.exe -w
fastboot.exe reboot
If you want to try - I could send you one of this by EMail - upload it somehow…
Best regards

I flashed e os on a gs290 with updated android 10 and have no wifi. I don understand your solutions, because I cannot revert to stock rom because sp-flash tool is giving me error codes.
Would somebody be so kind and telle me where I can find this alternate boot.img you are talking about?
Best regards and a happy new year - thanks in advance!

Hi Nickyr,
here you can find the two last boot images of GS290 (Stock ROM) with timestamp YYYYMMDD. Be careful and use the commands in the order I sent before in the same post! Good luck! Best Regards - Didi

Hej Didi_6763,
this did the trick - thank you so much to you and the forum in general!
Best Regards,

Hi Didi
I’m confused. Why would efoundation send out an update with an older boot.img than the previous version. And if this is correct we should be telling them not to do this I think!

Hi AndyP,
why this is so - we can only make speculations. E.g. too many Devices to maintain and so on. Or for a long time Gigaset did not bring out updates for the GS290 device. And now e.foundation is still not aware that there are Updates from November and December 2021. But you are right somebody has to inform the developers/support that some functions are not working with the deliverd boot.img from e.foundation - and with the newer versions of Stock ROM it does. I needed the devices running, because I bought them as christmas presents - so I struggled to find a fast solution. So please open a ticket at the support if you have still problems with your WiFi. This is the best way that in future all owners of gs290 have can enjoy benefit of the global solved problem! Software Development is an always lasting improvement process!
Best Regards

1 Like

OK Didi will do…I’ve logged it at the wiki already.
Wish I could go back to 0.18 as it was perfect for me.

Hi @AndyP thank you for reporting this … but as this thread is marked Solved, it may not be the best place to raise awareness.

I see here /e/ image ROM download that a v0.18 is still available; you wish you could go back? - a downgrade of /e/ version is fairly painless.

I see also your post 0.20 is a disaster for GS290 - #3 by AndyP.

You mention a wiki post you already made - please can you provide a link - this issue does require some visibility! :slight_smile:

In a quick search I find no mention in a Gitlab search for GS290 issues.

First thing, then, Report an issue.

If first time users have any issues logging in to Gitlab, it is a known issue. In the event you cannot login, please provide details of your failing ID to support@e.email asking for assistance.

PS Correction @AndyP, sorry, I found this: problems reconnecting wifi (#4093) · Issues · e / Backlog · GitLab - but the issue is not tagged GS290!

1 Like

aibd- thank you! …I had no idea I could wind back to 0.18.

The last few weeks have been painful :slight_smile:

I will tag my post now, I had no idea I had to tag it.

How do I wind back to 0.18…and will I loose all my data?

No, you will not have to wipe Data with a change of /e/ version - that is only required with an Android upgrade.I will write as if you have TWRP if you have an /e/ Recovery, the steps might be a little bit different!

Transfer the .zip to your SD card (or it can be the phone’s internal storage).

Reboot into Recovery mode,

TWRP will be able to find the .zip by:

Install > up a level > Select: external_sd > scroll to files > Select your copied image …

Note, uncheck, signature verification, I tend to leave unchecked automatic reboot.

Swipe to confirm flash.

Once the flash is reported successful, go back > back,

Advanced wipe of Cache and Dalvic / Art Cache

Then > back, Reboot > System

If this action proves successful it might support the idea that this is a ~v0.19 Regression as proposed by that particular topic - and not the wider issue of a mismatch between Gigaset firmware and underlying stock used by /e/, as suggested by @Didi_6763 in Post #11

1 Like

It’s true that you should not lose data, but I think it is a good idea to take a TWRP backup of your data partition before you install the 0.18 ROM, juts in case. The ‘backdate’ use case has not had as much use as the 'update`, so it is possible that you may encounter problems. Better safe than sorry :slight_smile:


Thank you aibd…will get to this later today and will report back.

For the GS290 what image should I use- there is only a Gigaset GS4? Also my device is not rooted, can I still do this?

I do not understand, please can you ask the question in different words! :slight_smile:

… also /e/ does not expect or require rooting.

This was the link I posted earlier /e/ image ROM download

I got past the asking for root access page and I think I have installedTWRP.

On opening… it trys to access Google… but ‘microG Services Core’ brings up a warning and stops it?

Then I hit cancel to get to TWRP landing screen.
Then I hit TWRP FLASH (top option) and it crashes.
OK re-started my phone and now it does not crash.

When I try to reboot into recovery mode it says ‘Root Access Required’