Will /e/OS install on a Galaxy Tab S6 Lite SM-P610NZABXAR?

Understand it as SM-P610xxxxxxxxx

CAUTION : for now, /e/ is based on android 11, your device must running android 11, if not (android 12), be sure to be abble to downgrade

Edit : it is not the easiest device to unlock
Search results for 'P610 order:latest_topic' - /e/ community


Thanks, got /e/ installed on the second try. Thankfully my tablet had android 11 installed and I was able to easily unlock the bootloader from the initial download screen.

The instructions could be improved however:

Under the section " Installing the /e/ Recovery on your gta4xlwifi"

  1. Unplug the USB cable from your device.
  2. Manually reboot into recovery:
  • Hold Volume Down + Power to reboot.
  • As soon as the device powers off, hold Volume Up + Power.

Hi, having never been in Facebook :-1:, and having escaped both Microsoft and Google :fist:, I am now looking to leave the Apple walled garden, which means a non-Apple tablet. (Amazon will be the final of the Big 5 to escape from, but that is very difficult…).

My question is: does the S Pen still work on the Gal Tab S6 Lite with /e/ installed, or is that a Samsung Android capability that is lost when reflashing to /e/?

Happily, the S Pen still works.

Cool. It arrived today, so time to get a-flashing…

Well, that was annoying!

The tablet came with Android 11 - first thing I checked - as required by the install instructions.

I went through the process of downloading the (appropriate) ROM and recovery files, setting up Heimdall, and turning on USB Debugging. All OK.

BUT, there was no OEM Unlock option available under Developer Options, so I followed the advice on the Install page to do a software update in order to have the option appear after an update and reboot. Yes, that worked - there was such an option after reboot.

However, the bloody thing then kept on updating a few more times, and ended up installing Android 12 on the device! :person_facepalming:

Now I find myself in the position of having to downgrade from Android 12 to 11 again, per the install instructions which stipulate this. *sigh*

And, just to be really annoying, the OEM Unlock appears to have vanished again.

Has anyone had to do this, and if so, where can I find the instructions?

I am assuming that the e/OS/ Android S version is still a way off…

Damn that sucks. I also had no OEM unlock at first. However after connecting to wifi and getting connected to the internet, the option appeared and I was able to proceed. I don’t understand the reason for OEM unlock to be contingent on an internet connection, however it’s been the rule for every device I’ve owned.

1 Like

Here are three case studies you might read.


Boy this is getting complicated…

As I am on Linux, using Odin is (apparently) not possible, so Heimdall needs to be the tool.

Turns out there is remarkably little of use on the topic of downgrading a Sam Gal Tab S6 Lite from Android 12 to 11. Who knew?

Many online guides for Samsung devices start by saying to use TWRP for Recovery, but a look over at twrp.me shows that there is no TWRP for this model of tablet (Galaxy Tab S6 Lite gta4xlwifi). There is a TWRP for Gal Tab S6 (no Lite) gts6lwifi, but we all know how important it is to pay attention to all those digits :wink:

So, it needs to be some other approach to downgrading.

The Search Continues…

Hi JJR, You might pick up some tips on xda. They have a category for your tab. Or is it slightly different? Not sure.


1 Like

I found nothing related to downgrade stock samsung firmware on xda
Please ask @linux4 directly. ( as most of xda dev, he may don’t like /e/, so be prudent )

Maybe you can use a friend’s computer running windows for Odin in case Heimdall or Heimdall-frontend fails ?

Thanks @chrisrg and @piero for your ideas.

You know, I’ve been thinking about this a bit more, and it strikes me that there may be a way to avoid TWRP and Odin, and just use Heimdall. See if this logic makes sense:

  • install Lineage custom recovery for Android 12/S using Heimdall (since Tablet is on 12/S)
  • install stock Android 11/R from recovery & reboot.

Now the device is back in the configuration it needs to be in for the eOS install instructions. Follow instructions as per those steps.

It couldn’t be that simple, could it?

Probably not. Don’t know anything about Samsungs so sadly I’m not able to advise.
But reading through the links provided in aidb’s post I picked up a few things of interest and wondered if you noted them too.

One user reports installing eOS over android 12 anyway and it works.
Another reported that Heimdall sourced from eOS docs is out of date; go to Lineage for that.
And this doc linked from one of those topics has interesting pointers on how to bring back oem unlock and how to disable auto updates etc.

1 Like

Have a try, but i remember the e/lineage recovery don’t manage .TAR .IMG files, only .ZIP
So you need Heimdall.

Well, it wasn’t that simple, but in the end I have /e/OS running on the Gal Tab S6 Lite :tada:

The stock ROM install just wouldn’t work.

The steps:

  1. :crossed_fingers:
  2. as above, install Lineage Recovery for 12/S using Heimdall
  3. install Lineage 19.1 (S) from Recovery
  4. install Lineage Recovery for 18.1 (R), using H
  5. install Lineage 18.1 (R) from Recovery
  6. install e-recovery-1.2-r, using H
  7. install e-1.2-r from Recovery
  8. OTA update the OS to 1.3-r
  9. Chugging along :clap:

Probably ridiculously over-engineered, but this seemed the safest way to “step down” from A12/S to A11/R (and it uses @chrisrg’s trick of updating to the next-to-most-recent version then doing an OTA to the newest, so hat-tip :tophat:).

Now configuring…


I don’t understand why the lineage steps could be necessary,
But congratulation to finally running /e/

Since the /e/OS instructions are very clear not to use a lower version number of Android, I used Lineage’s equivalent of 12/S recovery to put it’s version of 12/S onto a 12/S Android device. Then, cautiously “stepped down” in stages back to /e/, via Lineage 11/R, and then to /e/OS 11/R, with go/no-go “gates” along the way for testing. Hence the re-boots and checks along the way.

I did something like this 2.5 years ago when flashing /e/OS onto my phone the first time - I went by way of Lineage when the reboots kept stalling (probably due to the A/B architecture of a Sony Xperia XA2).

I tried all of these, but in the end I needed to boot it into Download mode ([VolUp]+[VolDown] & plug USB cable into device while cable is connected to computer) and select Unlock mode. It does its warnings, and you just unlock the bootloader like that. No more buggerising around with OEM Unlock settings in Developer Options, which were mysteriously unreliable.

Hi pen lovers, did you find an answer to the question if /e/OS supports a Samsung Stylus called S-Pen? Thank you and kind regards. I see above an older answer that for someone that worked. Are there more notes about that? What about external screen and something similar like DEX?

Yes, I am using the S-Pen on the Samsung Gal tab with /e/OS. Most useful for marking up PDF files when editing, but, yes, it works.