Xiaomi - POCO F3 / Redmi K40 / Mi 11X - alioth - Documentation Suggestions

Hey Test_user! Glad to hear that your upgrade to Version S was a success and I am happy that you used my guide to do so! Have fun!

Updated to e-1.6-s-20221130239247-dev-alioth from e-1.5.1-s-20221102231515-dev-alioth.zip, updated for 10 minutes, but so far everything is fine …

I manage using fBSMT’s guide to do a first time install on a brandnew Poco F3.
The stock Rom was too new, I had to revert to the above mentioned rom.
The guide in the documentation didn’t work.
Kudo’s for fBSMT!

1 Like

Hey @Gaea thank you so much for the kind feedback! You are correct! The guide for first time setup should definitely be updated as well to include the correct ROMs depending on the users device region. Lineage 19.1, which eOS is ultimately based on, does require very specific firmware releases to work (properly).

@Manoj you and the team are doing a fantastic job and Murena devices absolutely must have priority, since they are funding everything. Also I assume you guys are way understaffed and overworked. I understand that ALIOTH is very low priority. But please consider that the official eOS install and upgrade guides incorrectly tell users to upgrade their ROM to the newest MIUI dev version, which results in people being unable to install eOS 1.6 or worse, their phone having malfunctions. eFoundation does not earn money from POCO F3 user, however I decked out my entire family and my girlfriend with Murena Store bought Gigaset GS290 phones after I successfully tested eOS with my Nexus 4 and Mi Mix devices back when I first discovered eFoundation. Providing outdated documentation damages eFoundation/Murena!

At the very least, can you guys please add a big red warning box on top of all ALIOTH guides telling people that the guides are outdated and they should either consult this thread or wait until the documentation has been updated? I rather spend the time guiding individual users through the initial installs and upgrades (should my guide not suffice) than having people go through a very negative first experience with eOS which causes them to never come back and recommend others against eFoundation/Murena.

I wish you and the team a successful 2023! :fireworks: :sparkler:

The “official” guide for alioth install has been updated to reflect the required firmware before install, so this seems to be fixed. But just followed the guide step by step and still does not work, because the e-os v1.6s (which is referenced) is still considered a downgrade and adb sideload through recovery will fail. But the e-os testing version 1.7s works fine (I think this is because it uses the newer Android Security Parch, but could be wrong). If anyone from the team is interested, I have a device I can use for further testing

In the /e/OS release notes Releases · e / os / releases · GitLab we are told that in e-1.6 Android is updated to 5 Oct 2022. There are no release notes for 1.7 today (“release candidate” dropped yesterday, I think).

In my device running e-1.7-r-xxx I see in

  • About phone > Android version

Android security update 5 November 2022.

You might check Android security update on your control phone against your e-1.7-s-xxx device.

Maybe this information will help users who follow to avoid installing /e/OS on a device where the “Stock” manufacturer build is in advance of the available /e/OS (if it is as simple as that).

So did some more testing and here is the exact error (when using the lineage OS vendor_boot mentioned in guide):

Current SPL:2022-12-05 Target SPL: 2022-10-05 This is considered a downgrade
Denying OTA because its SPL downgrade

And I think it is only connected to the “vendor_boot.img” you flash, NOT the actual OS on the phone. I tried it with vendor_boot extracted from the /e/OS “e-1.6-s-20221130239247-dev-alioth.zip” and the error was the same (just current SPL date changed slightly…), but using older vendor_boot.img from “e-1.5.1-s-20221102231515-dev-alioth.zip” worked fine, since it was not a downgrade anymore.
So two suggestions/questions:

  • Why use Lineage vendor_boot.img when /e/OS vendor_boot seems to work fine (you also get /e/OS as the the initial recovery, not having to flash throught the Lineage recovery)?
  • Always provide vendor_boot with older SPL than the current full image, so you avoid the downgrade error

If anyone can veryfi this, I would be thankful.

Found this guide very helpful. I wanted to add a few items to help others as it was not a straight forward install. I have fair amount of experience flashing but minimal coding experience. I do use the ADB method generally.

The install guide was confusing as it has added the need for installing additional partitions but the exact files and how to flash is not entirely clear.

I have found the following steps useful for installing on my POCO f3 - GLOBAL - on 13.0.6 rom.

Install SDK and use platform tools for adb commands - I use windows powershell.
Use Mi account to unlock bootloader -I had to wait one week. Developer options worked.

I tried many steps to install and flash but could not manage the partitions. I even managed to extract using payload dumper go and tried flashing as described above but kept getting stuck at partition changes and ended up back in the original rom. I was happily boot loading into fastboot.

I noted that partition issues are supposedly less of a problem with the latest TWRP.

Therefore, I downloaded TWRP from sourceforge for android 13:
https://sourceforge.net/projects/recovery-for-xiaomi-devices/files/alioth/

I installed this onto my poco f3 using adb commands and followed this video:
https://www.youtube.com/watch?v=qFw216x8FUs

I ended up with a chinese version of TWRP so used this video to set to english language - just search on youtube

THEN reading through I did an advanced WIPE of data, dalvik, data, cache.

Then I stayed in TWRP and used the ADB SIDELOAD function. Once I started the adb sideload on the phone then used powershell in windows to adb sideload e-****.zip (replace the filename with your version of eOS you are installing).

THIS CAUSED THE a/b problem to occur as it installs on empty slot b - on the TWRP is advises to reboot to recovery. So when it reboots it loaded eOS recovery 1.7. It says that you need to enter this recovery to switch to slot B.

I stayed in this recovery (it says it is on slot b) and found the adb sideload function again within eOS recovery. Then did the same process and adb sideload e-***.zip file again into slot B using eOS recovery 1.7

Then rebooted and eOS was loading. I presume I am now in slot b. No idea if the original is still in slot A. When I reboot to recovery it is eOS recovery 1.7 and now says slot A.

It will reboot to recovery and fastboot etc.

Just a quick update to say how I managed to get eOS installed and did not use most of the steps above.

Hi all,

I am trying to install /e/OS (e-1.11) on my POCO F3, but it is not working. When I followed the official documentation I got an error (recovery: Signature verification failed / error: 21) during the adb sideload step. I also tried the TWRP solution proposed by @fBSMT but also got an error (Error applying update: 7 (ErrorCode:: kInstallDeviceOpenError) Updater process ended with ERROR: 1).

Did someone manage recently to install e-1.11 on POCO F3, who can give me some advice.

Thank you very much in advance.

Hello,

I would like to install e/os. Currently I have MIUI Global 14.0.9 on my phone.

  1. must this “POCO F3 Global - V13.0.3.0.SKHMIXM” Rom be installed on the phone or is it also possible with my current Rom.
  2. there is always talk about update, are all the steps also necessary for a new installation.
  3. after a long time of trying i managed to extract all the vendor-blobs from
    “POCO F3 Global - V13.0.3.0.SKHMIXM”.

Please answer the previous questions so I am sure what the next steps are for me.

Thanks and greetings

P.S. Is translated with deepl because my English is not so good. I hope it is understandable.

Hi,

as the T version is available (https://images.ecloud.global/dev/alioth/),
does someone already tried to upgrade from S version ?

Thanks