0.14 (26.01.2021) boot loop after OTA update (TWRP)

Hello there,

I just updated /e/OS on my Samsung Galaxy A5 2017 (a5y17lte) from 0.13 to 0.14
Because I found a little bug I did some screenshots for documentation… :sunglasses:

Have a look at this one, it tells me it is ready to update to /e/OS 0.13 - 26.01.2021 which is the date of the 0.14 update.

My TWRP v.3.4.0-0 [edit] updated to 3.5.0_9-0 did not work either [/edit] did the update without any error messages but when the phone tried to reboot, I ran into a boot loop showing the “Samsung Galaxy A5” boot screen, vibrating, showing the boot screen… Wiping Dalvik/ART Cache and Cache using TWRP did not help.

I was able to workaround the problem by push and holding buttons “Vol. up”, “Menu” and “Power” at the same time until TWRP comes up. Starting “Advanced” → “ADB Sideload” allowed me to reinstall /e/OS v. 0.13 by doing adb sideload e-0.13-p-2020120789008-dev-a5y17lte.zip from the terminal.
After successfull boot I even got a message of update failed. :rofl: Thanks for the information! :wink:

Hope that helps someone else. :slight_smile:
Have a nice day!

kind regards

As new user I was not allowed to upload more than one media file in a post…

TWRP version 3.5.0_9-0 is best suited for /e/OS ‘Q’. The fact that it does not work with /e/OS ‘9-Pie’ is device-specific. Even TWRP v.3.4.0-0 does not work under certain constellations on various Samsung Galaxys - and it is recommended to use the previous version Twrp-3.3.1-x. The latest is not always the best.

1 Like

Hey SuzieQ,

please let me know where does your knowledge come from? Do you have successfully tested 0.14 OTA update with the SG A5 2017 and TWRP 3.3.1-x? The installation manual says /e/OS is tested with TWRP 3.3.1-1. I just installed latest 3.3.1-x version (where latest means x=2 atm). But wtf?! System updater does not find 0.14 update anymore…!? :flushed: So I can’t test it yet.
Are the developers doing their work already. :wink:


My knowledge is based on practical use of the A5 2017. I switch between /e/OS ‘9-pie’ and LOS 17.1 aka ‘Q’ to contribute to bug detection.

1 Like

FYI: I filed a bug about this issue.

Hey @SuzieQ,

You told us you switch between /e/OS pie and Lineage OS 17.1 on the a5y17lte. Can you confirm the device is running current version of LOS 17.1 smoothly? @rhunault stated on my issue the a5y17lte is a community device which does not get support soon. If I understand his statement correct, the error – and a fix of course – comes from upstream…
On the other hand /e/OS pie is not based on LOS 17.1, Isn’t it?
Pretty annoying situation though. :-/
I’m not able to build LOS 16.0 from the sources so it seems we need to wait for an /e/OS port of LOS 17.1… :frowning:

kind regards

Hi @chrisphl, the Galaxy A5 (2017) ‘a5y17lte’ was one of the first devices to be migrated to /e/ OS 9-pie. It ran very well for a long time. The current /e/ problem is a home-made one.

LOS 17.1 as well as LineageOS-17.1.-for-microG and their lineage recovery versions work very well. Also the images of crDroid 6.14 ‘Q’ work fine as well as the now discontinued PixPixelExperience ‘Q’ edition.

Thanks for your answer! Would you mind to state that in the issue tracker too? Maybe some further explanation helps also. I think dropping support for a device is one thing but breaking some thing and not repairing the other…
Thanks in advance!


The /e/ issue tracker does not convince me. That’s why I don’t leave messages there.