A newbie who wants to build /e/ Pie, possible?

LineageOS 16.0: OpenJDK 1.9

Only the last one …

1 Like

New failure : https://del.dog/ePieBuildFail2.

I pasted the last line on Startpage which is “Target Java: /srv/src/PIE/out/target/common/obj/APPS/SystemUI_intermediates/classes-full-debug.jar” and the fisrt two results were topics on this forum.

Like the author of those two topics, openjdk-9-jdk isn’t available by a simple “apt install openjdk-9-jdk” and I read a comment somewhere that says openjdk-11-jdk replaced the 9 and could be used instead.

So I installed openjdk-11-jdk. Though openjdk-9-jdk is manually downloadable https://jdk.java.net/archive/. I will uninstall the 11 and try to manually install the 9 in case it’s the problem.

The big good news is that now it takes 4h to reach 98% instead of 13h !! I guess it’s due to the 11 GB in ccache (and maybe to the fact I added the line “vm.swappiness=30” in /etc/sysctl.conf to change the default “60” value).

Quick question, once the repositories have been synced and the build process is running, the internet connection can be shut, right ?

EDIT : actually no I won’t because looks like the 11 really replace the 9 and can’t be the issue.

1 Like

Yes that should not be okay :slight_smile:

1 Like

I guess it means that it should be okay :yum:

Finally I changed my mind and won’t uninstall the 11 for the 9 because it seems weird, it’s not a normal behaviour to install an archived thing with “don’t use that” warning on top of the download page and it’s too tricky. So I don’t know what I should do or what’s wrong exactly.

The only tiny clue I have is that it says “Using OpenJDK 8” in the terminal (I think everyone has this line no matter the Android version the person try to build) :

>> [Thu Apr 30 16:24:13 UTC 2020] Adding OTA URL overlay (for custom URL https://ota.ecloud.global/api)
>> [Thu Apr 30 16:24:13 UTC 2020] Using OpenJDK 8
>> [Thu Apr 30 16:24:13 UTC 2020] Preparing build environment

OpenJDK 8 wasn’t install, only the 11. What I could try is use OpenJDK 8 instead of 11 but like Harvey said :

Though it’s probably not the solution.
Thank you all.

Oh yes sorry i guess it s to early in the morning… I was stuck in between its okay and should not be a problem xD just to verify that your roomservice is working, i made a build for it yesterday evening and it worked :slight_smile: if you want i can check for my jdk version, but that is why we suggested to build for a supported device the same android version as you aim to build for the unsupported device, that way you would have noticed the missing jdk package before building…

Okay thank you very much, now I know at 100% it will be me the issue at each failure.

Oh yes it would be nice, take the time you want I’m not in a rush.

Yep sorry about that :yum: I’m not a perfect student but I will definitely do this the next time I need to check if my build environment is ready.

Now that I know it’s not ready because it worked for you and not for me, I guess I don’t need to build for a supported Pie device anymore.

i have the openjdk-11-jre-headless:amd64 11.0.4+11-1~deb10u1 so i guess replacing 9 by 11 is working :smiley:

1 Like

apt list --installed :

openjdk-11-jdk-headless/focal,now 11.0.7+10-3ubuntu1 amd64
openjdk-11-jdk/focal,now 11.0.7+10-3ubuntu1 amd64
openjdk-11-jre-headless/focal,now 11.0.7+10-3ubuntu1 amd64
openjdk-11-jre/focal,now 11.0.7+10-3ubuntu1 amd64

java -version :

openjdk version "11.0.7" 2020-04-14
OpenJDK Runtime Environment (build 11.0.7+10-post-Ubuntu-3ubuntu1)
OpenJDK 64-Bit Server VM (build 11.0.7+10-post-Ubuntu-3ubuntu1, mixed mode, sharing)

Thank you for the confirmation. But since that’s what I have too, it means the issue is somewhere else…

FAILED: /srv/src/PIE/out/target/common/obj/APPS/Gallery2_intermediates/classes-proguard.jar
It seems there is some error with the gallery, i had that once as well but can t remember the fix for it…
I guess the only thing i did different from you is the build script which i didn t update yet…

btw it is weird that your first build managed to get passed the point of the build error on the second build… did you change anything else then jdk version?

Indeed that’s an obvious thing I didn’t think of…

I don’t think I changed something… I will just retry and see if it fails at the same point or not :slight_smile:

1 Like

ICC (in french) bugs are the most fréquents causes of issues
CKI (in english) chair to keyboard interface…


New failure : https://del.dog/ePieBuildFail3

Recap :

Attempt 1 (without openjdk-11-jdk) :

[ 99% 69230/69566] Docs droiddoc: /srv/src/PIE/out/target/common/docs/api-stubs
javadoc: warning - The old Doclet and Taglet APIs in the packages
com.sun.javadoc, com.sun.tools.doclets and their implementations
are planned to be removed in a future JDK release. These
components have been superseded by the new APIs in jdk.javadoc.doclet.
Users are strongly recommended to migrate to the new APIs.
DroidDoc took 205 sec. to write docs to /srv/src/PIE/out/target/common/docs/api-stubs
ninja: build stopped: subcommand failed.
11:39:02 ninja failed with: exit status 1

Attempt 2 :

[ 98% 68860/69566] Target Java: /srv/src/PIE/out/target/common/obj/APPS/SystemUI_intermediates/classes-full-debug.jar
ninja: build stopped: subcommand failed.
01:58:23 ninja failed with: exit status 1

Attempt 3 :

[ 99% 68918/69566] target Dex: Telecom
ninja: build stopped: subcommand failed.
09:44:54 ninja failed with: exit status 1

So it always fails at different moments, and the best try was the first one without the needed openjdk :yum:

I prefer what @Chimpthepimp has written. First build a full supported device rom to ensure, our build environment is OK.

On friday I have made a complete new Linux install on my iMAC and what do I in the moment ? Building a standard rom :wink:

By the way, which Linux distro do you using ?
I have build on thursday on Ubuntu18.4. the build needs more than 8 hours
Today I’m building on Mint 19 and the build will need around 4 hours

1 Like

Yes that’s what I will do. I will start from scratch. I will delete my VM, create a new one with Ubuntu 18.04 instead of 20.04, install docker-ce from docker source instead of docker.io, install openjdk-11-jdk and start to build for Galaxy A7 (2017) or Galaxy A5 (2016) or Galaxy A5 (2017) (if supported by LineageOS) to test my build environment.

good choice, but as I have written, better using Mint19. It works perfect with docker and eOS

Ubuntu is sooooo overloaded :frowning:


it seems to be around the same point as the second build attempt… so i guess it is a similar error both times some java file…

FAILED: /srv/src/PIE/out/target/common/obj/APPS/SystemUI_intermediates/classes-full-debug.jar
[ 99% 68916/69566] Proguard: /srv/src/PIE/out/target/common/obj/APPS/Gallery2_intermediates/classes-proguard.jar

it has been years since i last used ubuntu but i remember leaving it because of all that overload stuff it comes with…


I think I’m cursed. Indeed it’s better with Linux Mint Xfce, much less freezes than with Ubuntu.

I installed it, I apt update apt upgrade, apt install openjdk-11-jdk, I installed the 5 packages listed in the installation page of Docker and I installed docker from docker source for Ubuntu 18.04 bionic (because Linux mint is based on Ubuntu 18.04 bionic). I created the needed folders.

I reboot. I run docker run hello-work and it works. Then I follow the instruction of the /e/ documentation (so without "-v “/srv/e/local_manifests:/srv/local_manifests:delegated” and without "-e “INCLUDE_PROPRIETARY=false” because I build for a5y17lte which is supported by LineageOS and /e/ and on Pie on both.

Guess what ? it failed at the beginning of the build process…

I really don’t know what I could do to make it works.
I will try again and see, that’s the only thing I can do.

Pls. …’’’ first build for official supported device !!