AC2003 stuck after easy-installer /e/

After trying the easy installer for booting a ac2003 device (android 12, may), it’s stuck in this mode;

The last step before the easy installer would start the installation was in Bootmode, and I needed to accept the “update”. But there was no such option on screen.

I use a macbook pro, which makes the adb more complicated, hence the easy installer…
Used this succesful on several gigaset devices…

Any help please?

Any takers?
Just to help me get started… Can I proceed on macbook or would a windows pc be easier?

I’ve used adb on Mac laptops with no problems at all. Easier than Windows as you don’t have to worry about USB drivers which, from what I’ve seen in these forums, cause problems for Windows users

Well it seems I will need a windows pc to revert to STOCK ROM as described here:

https://doc.e.foundation/pages/revert_oneplus_to_stock_on_windows.html

After that I can try to manually instal /e/ on my avicii OnePlus phone.
I’m however clueless (easy installer user up until now) as to which ROM to install.
Android S / R / Q? My GS290 runs 1.17-S (installed via Easy Installer)
Then there are “recovery” versions.
https://images.ecloud.global/stable/avicii/
Do I download MD5 / SHA356 / Recovery and boot img.???

I’m lost

I got a second identical device, AC2003.
Once again tried easy installer. Completely new issue this time:

I’m through. Any developers in the area France - Germany - Benelux that I can send both devices to?
Will pay to flash /e/ on both.
HELP!

what was the android version you had in stock on your Avicii? 12 or 12.1?

afaik android 12 update may. for the first device
also 12 for the second

1 Like

i had 12.1 on my avicii and with easy installer i couldn’t install e os. the update was from Sept23.

i solved rolling back to A11 and then installing eos for Android 11 with the line command guide.
after installed i updated OTA to eos for A12.
Not care to try A13 yet as it’s still in dev only…

Well this is as far as I get, nothing happens on msmdownload. Any advise?

Use of MSM tool needs very careful reading. My first guess was that MSM is looking for a device in EDL mode (The aim in that case would be to unbrick the phone.)

Your phone appears to be in fastboot mode.

If you are using the instructions you quoted in Post #4 , these start

Assumptions

The user can’t reboot to recovery or fastboot.

This would be one explanation…because it seems you can boot into into fastboot.

What I might do next is to try to run

fastboot devices

to confirm if you have a working fastboot mode.

Do you have adb / platform-tools https://doc.e.foundation/pages/install-adb-windows on a Windows PC at this stage ?