Accidentally installed wrong app, can't uninstall

Hi all. Today I wanted to install Duolingo. I went to the /e/OS app store, searched “Duolingo”, and stupidly installed the first thing I saw. The package name is (rather then com.duolingo, which is the official app) and it appears to be a PWA. Now I can’t seem to uninstall it and I’m afraid I installed something malicious on my phone. Does anyone have any advice?

What did you try until now?

There’s an Apps section in the settings, each app is listed there. When you tap on an app you can also uninstall it there.

1 Like

Sorry I forgot to add that. It does not show up in settings → apps.

Sometimes something is listed under an unexpected name in that apps list.

I have a small app called CPU Info (from F-Droid) installed which has another listing of all installed apps (and system apps). But you can’t uninstall them there, it’s just to get some informations.

You could try another app store client like Foxy Droid to uninstall it.

1 Like

I just installed and uninstalled the PWA.

Uninstall by long press the home screen icon, then touch the - (minus) sign worked for me.

I’m pretty sure it does not show up under a different name in the app list.

I installed CPU info, but it doesn’t show up there, unfortunately.

It also doesn’t show up under “installed” in Foxy Droid.

(Thanks for your help though!)

Do you mean the PWA Duolingo? For me it does not show up on my home screen. Using the default launcher (BlissLauncher).

Then you probably didn’t install anything, at least not in an ordinary way.

1 Like

Ok. Weird and dissatisfying. This is what it looks like:

Yes, the PWA Duolingo, from App Lounge (as your image) is what installed, and using Bliss.

Do you have any non standard Browser that might interfere?

Interestingly, the usual alternative way to install a PWA is to open it in Browser then, top right 3 dot menu > Add to Home screen. But I get Browser not supported from !

If you don’t have other PWAs installed you can safely go to Settings > Applications > Three dot menu: show system apps > Search PWA Player and clear its cache and storage.

Then all PWAs are uninstalled and you should not see the Duolingo PWA as installed in App Lounge (but installing it should show you an icon on the launcher, this part is weird).


This worked for me.

Thanks for that.

(And thanks everyone for the quick help and advice!)