Account Manager stuck with Authentication failed despite correct credentials

I recently got a Fairphone 4 with /e/OS and almost everything is working well :tada: And I really like the hardware. One thing is not working well though.

Just when I first booted the phone I added a Google Account to synchronize my calendar and contacts, and it worked fine. However, after the first day and without me changing anything, I started getting prompts saying “synchronization failed (check credentials)” and similar. Sometimes I was able to see lengthy logs showing HTTP 401 errors but could not copy them anywhere, nor there was any indication of what to do with them.

At the moment, I’m stuck in this loop:

  1. I get a notification from Account Manager saying “Authentication failed (check login credentials)”
  2. If I click “Retry”, same notification reappears
  3. I click the notification, then open “Credentials - Update username and password”
  4. I see a warning saying “/e/ will report a fake device” etc
  5. I get redirected to the native browser (not my default one) and prompted to “Choose an account”. There is only one. I click it.
  6. Since the browser seems to have my proper credentials already, the next page is Google asking me “Account Manager wants to access your Google Account, make sure you trust” etc.
  7. I click “Allow”
  8. Phone says “account added successfully”
  9. I click “Retry” on the “Authentication failed” notification, and still get a failure. Back to step 2.

I checked on and Account Manager has properly been given access.

How am I supposed to proceed? How can I troubleshoot or debug what’s happening? I have experience with Linux and the terminal so I can do whatever is needed.

Pl can you check if the issue you are reporting is similar to the one reported here

1 Like

Looks like it, thanks for the quick response @Manoj . Will subscribe there.