Adb sideload issue on Nexus 5x : Total xfer 1.01x

hello,

This is my fourth Nexus 5x I install /e/ on. but i’m having some trouble .

I’m following the wiki procedure and the adb sideload is finishing with Total xfer message when progress status is at 47%

The status bar on device is 100% complete with a hopfull console message “script succedded: result was [1.000000]”

(bootloader unlocked, archive checksum OK)
$adb devices -l
List of devices attached
00cde35433a9a30d       recovery usb:1-1 product:omni_bullhead model:Nexus_5X device:bullhead transport_id:40
$  fastboot flash recovery twrp-3.3.1-0-bullhead.img 
target reported max download size of 536870912 bytes
sending 'recovery' (16321 KB)...
OKAY [  0.625s]
writing 'recovery'...
OKAY [  0.163s]
finished. total time: 0.788s
$ fastboot boot twrp-3.3.1-0-bullhead.img 
downloading 'boot.img'...
OKAY [  0.514s]
booting...
OKAY [  0.554s]
finished. total time: 1.069s
$ adb sideload e-0.7-o-20
e-0.7-o-2019072317807-dev-bullhead.zip  e-0.7-o-2019102328284-dev-bullhead.zip  e-0.7-o-2020012438713-dev-bullhead.zip  
$ adb sideload e-0.7-o-2020012438713-dev-bullhead.zip 
Total xfer: 1.01x                                                

I’ve tested several solutions :

  • using older version of TWRP or e-0.7-o-*.zip who are working on other devices.
  • using lineageOS
  • Adding vendor flash instructions for bullhead (Nexus 5X), before and/or after TWRP

/e/ is not stating. Only staying on starting logo.

Solution : copy the /e/ ROM locally on the device and use the install menu in TWRP (zip control is never OK for me, so I never use this option)

$adb push e-0.7-o-2020012438713-dev-bullhead.zip /data/media/

It’s obvious, but since I haven’t read anywhere that this solution has worked (because it never seems to work), I write that it works somewhere.

Hi @scanlegentil the sideload method rarely works for me especially since I have an old phone and PC. The USB cable , port all have to work perfectly. I also use the adb push and install from TWRP as it works better.
If more users agree to this I can have this added to the documentation on ewiki.

1 Like

sideload method jus worked now with same PC and cable , just with another Nexus 5X device.