Add attached photo to mail one at time?

On “mail” when I want to attach more than one photo, I have to go through the selection process (attach, go to file manager, select gallery, select camera, select photo) for each and every picture.
Not very convenient.

Do I have a mis-setting somewhere ?

Try using “Images” then “OpenCamera” or “DCIM” in file manager, then long-press on every image you want to attach.

Thanks @smu44. It works as described, but the system answers with a mysterious " no translation found for… " a message already seen somewhere else in the past

“no translation found for” is a Weblate import gone wrong, the details of will need to be untangled in the v0.18 cycle.

I tried to reproduce but failed to do so when attaching multiple images to Mail. Could you post here or file a bug with instruction/screenshot for where “no translation found for” surfaced in your steps?

Open Mail
Write a message
Attach file
Navigate to DCIM (or recent)
Long press on image
See screenshot below

It happens on long pressing even a single file.

Shouldl I report here if the message appears somewhere else ?

if you find the time, you can comment with the example to as it’s happening within Files. The string it should show is the translation of "<number of files> selected".
I’m confident this will be solved across affected Apps for v0.18, the cause is understood.