Advanced Privacy blocks trackers from "/e/ System"

Hello all,

Today I noticed that Advanced-Privacy finds a tracker at “/e/ System” and blocks it. Has /e/ not removed this tracker from the code yet?

Thanks for answers in advance!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Are you talking about It’s weird indeed, however it only seems to affect the small map inside Advanced Privacy that gets constantly reloaded. Probably just a small bug - or they weren’t aware mapbox collects data until their own system told them?

1 Like

Hi. @SkewedZeppelin explains. I’ll try to link the tpic or the post.


But of note the version in Advanced Privacy itself is the newer proprietary one:

In my testing this looks a good catch @Tux17. In a3xelte-q I tested Advanced privacy as ok. I did not press it to do anything out of the usual for me in first 24 hours, then carried on using the device with settings which worked for me.

However same device testing a3xelte-UNOFFICIAL-r, First start wizard seemed to complete ok; device seemed to work; (I had earlier got the hang of location spoofing); using Maps started the problem; the mapbox wiget never resolved; the phone became non usable.

I worked for over an hour to collect logcats, with some success; I will submit an issue, but cannot do it for a couple of days – first impression is that something like an old fashioned memory leak is responsible. I see camera, battery and “unable to write … systemfiles” all coming in with seemingly very slow resolution.


I have the same problem, but I found a solution given by @RdLr in the gitlab that works for me :slight_smile:

Hi @aibd, I can confirm your observations. A workaround for me was to toggle the “Use WiFi” switch of the “Mozilla UnifiedNlp Backend” configuration in MicroG to “off” and then “on” again (while the wheel was spinning in the mapbox sub-window). This resolved the issue for a single turnaround from “random” to “real”. The next days I’ll try to build v1.1-r for comparison. Maybe things are better then. I’ll tell)

Surprisingly, the GPS works normally on the maps application or on an F-Droid application (GPS cockpit), but does not work on Transportr or on GMaps WV. I initially thought it was due to mapbox and advanced privacy but even after fixing the mapbox problem these two apps (Transpotr and GMaps WV) still don’t work.

Moreover if I activate GPS spoofing, in this case Transpotr and GMaps WV give the spoofing position like on mapbox.

I don’t understand why my GPS works with some apps and not with others when the same permissions are given.

EDIT : My phone : Samsung galaxy S9 dev build v1.1.