Advanced Privacy breaks media streaming for Talk HPB

With a recent Talk Android client it is not possible to join calls when the Advanced Privacy VPN is enabled.

This happens when a Talk HPB is configured in the Nextcloud Server the client is connected to.

Same happens from the browser (Firefox).

What would be the root cause?

my wild guess is some component can’t do tcp and does udp only (turnserver?)

Tor, the underlying tech for the AP hide-my-ip feature (not a vpn), doesn’t carry UDP, it’s TCP only (there are spec proposals for tunneled UDP over TCP though).

So WebRTC, what Talk is using, needs to fall back to TCP for everything it does if udp is detected to be unavailable. Admins of the talk-hpb instance maybe didn’t expect users with no udp?

(on another note: enabling Tor on any network route negatively impacts latency, not something I’d do to voice communication)

hello @tcecyk , thanks for sharing your thoughts. TURN server is configured as fallback over TCP (besides UDP) in case direct connection device to Talk HPB cannot be established.

Regarding your note about Tor impacting negatively the latency that is key to smooth WebRTC communications, it is definitely to take into account. The solution in this case would be for the user to be able to define an app whitelist, that doesn’t need to go through Tor onions.

Maybe some developer / maintainer of Advanced Privacy to give some feedback?

there is a per-app setting to disable the tor-route.

In gitlab exists an issue to exclude specific apps by default from hide-my-ip ( autoban when connecting through tor to their imap). You could create an issue for Talk and crossref.

Curating an incompat. list seems unsustainable though.

As much as I like onion routing, it’s not a fit for all things.